Can't update Chromium

Hello, I did a “sudo dnf upgrade” then my Chromium fonts got changed.

I went in to the settings and set the fonts to default, restarted Chromium. Fonts were same. I started looking for a solution and then a pop-up message appeared:

“Can’t update Chromium”

Screenshot_20200412_175525
The pop-up message with changed fonts

Then I reinstalled Chromium with:

sudo dnf remove chromium
dnf clean all
sudo dnf install chromium

Now it still says “Can’t update Chromium” with same fonts.

1 Like

Hi @cuqer. I had a quick look, at this appears to be already reported:

https://bugzilla.redhat.com/show_bug.cgi?id=1745745

It has been fixed upstream, but I do not know if the fix has made it to a release (and so to Fedora) yet.

Please take a look and comment there if needed. You should be able to log in to Bugzilla using your Fedora account.

7 Likes

Hello, I checked Fedora forums to see if this is posted. I didn’t know it was poasted in Red Hat forums. I have checked the link and other links inside the links and honestly didn’t understand much. Is there something I can do to fix it? Also, in forums they don’t talk about the fonts. I have an old looking font in my Chromium and when I type something, they are on that font, the auto-completion is in the normal font.
-Thanks

No, that isn’t a forum. That’s the bug-tracker that Fedora uses. From the information there, there isn’t much you can do for the time being. We need to wait for:

  • Chromium developers to make a new release with the fix, (“upstream”)
  • the Fedora package maintainer to then update the package in Fedora to the new version

Not sure about the fonts. Perhaps open a new topic for that so folks can help troubleshoot it?

2 Likes

So what is your installed version of chromium?

I would get that info by doing:
dnf repoquery --installed|grep chromium

2 Likes

Here is the output:

chromium-0:77.0.3865.90-2.fc31.x86_64
chromium-common-0:77.0.3865.90-2.fc31.x86_64
chromium-libs-0:77.0.3865.90-2.fc31.x86_64
chromium-libs-media-0:77.0.3865.90-2.fc31.x86_64
chromium-libs-media-freeworld-0:77.0.3865.90-2.fc31.x86_64

Okay, thanks! So, if the problem is not with my computer, then shouldn’t it be on all Fedora users?

Hello, I have updated Fedora and now my fonts on Chromium got changed.
Here is an example:
Screenshot_20200412_175525

Opened a new topic and got merged with this one :no_mouth:

Oh well, sorry but it looked the same question as this topic. Isn’t it?

2 Likes

This is mainly on update problem. The other post was focusing on fonts.

Two aspects, first you indeed have an old version of chromium. Second, you have the libraries of the freeworld but not chromium-freeworld.

On the first aspect, as I have learned in recent days, it is normal for the packages to “never… almost never?” be updated in the main repository of a released version of Fedora. Last version of Chromium browser is the same in all the still supported and released versions of Fedora: 80.0.3987.149-1.fc31 (I means the 80.0.3987 part is the same) as can be seen on https://apps.fedoraproject.org/packages/chromium So I believed you have the version that was there when Fedora 31 was released, most probably because you do not have the Fedora 31 update repository (not testing… updates) enabled. You should be able to add it with “dnf config-manager --add-repo /etc/yum.repos.d/fedora-updates.repo”

The second part I see you have chromium-libs-media-freeworld-0:77.0.3865.90-2.fc31.x86_64 of chromium-freeworld (chromium version in rpmfusion which does not have patented codecs removed). But I would then expect you to have chromium-freeworld package installed. I have learned ot this chromium-freeworld today… and will not comment too much on if this is normal (in F31) because I don’t know.

2 Likes

Hello, I already had the repo enabled. I now installed chromium-freeworld. I will give you more information soon.

Hello, here is some output from my console when I write “sudo dnf upgrade”
@pauld @FranciscoD

Last metadata expiration check: 0:00:01 ago on Tue 14 Apr 2020 02:59:34 PM +03.
Dependencies resolved.

 Problem 1: package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64 requires chromium-libs(x86-64) = 77.0.3865.90-2.fc31, but none of the providers can be installed
  - cannot install both chromium-libs-80.0.3987.149-1.fc31.x86_64 and chromium-libs-77.0.3865.90-2.fc31.x86_64
  - cannot install both chromium-libs-77.0.3865.90-2.fc31.x86_64 and chromium-libs-80.0.3987.149-1.fc31.x86_64
  - cannot install the best update candidate for package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64
  - cannot install the best update candidate for package chromium-libs-77.0.3865.90-2.fc31.x86_64
 Problem 2: problem with installed package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64
  - package chromium-libs-media-freeworld-77.0.3865.90-2.fc31.x86_64 requires chromium-libs-media(x86-64) = 77.0.3865.90-2.fc31, but none of the providers can be installed
  - cannot install both chromium-libs-media-80.0.3987.149-1.fc31.x86_64 and chromium-libs-media-77.0.3865.90-2.fc31.x86_64
  - cannot install both chromium-libs-media-77.0.3865.90-2.fc31.x86_64 and chromium-libs-media-80.0.3987.149-1.fc31.x86_64
  - cannot install the best update candidate for package chromium-libs-media-77.0.3865.90-2.fc31.x86_64
========================================================================================================================================================================
 Package                                    Architecture                  Version                                       Repository                                 Size
========================================================================================================================================================================
Upgrading:
 flash-player-ppapi                         x86_64                        32.0.0.363-release                            adobe-linux-x86_64                        9.0 M
 flash-plugin                               x86_64                        32.0.0.363-release                            adobe-linux-x86_64                        8.6 M
 gdisk                                      x86_64                        1.0.5-1.fc31                                  updates                                   248 k
 libxcrypt                                  i686                          4.4.16-1.fc31                                 updates                                   134 k
 libxcrypt                                  x86_64                        4.4.16-1.fc31                                 updates                                   126 k
 libxcrypt-compat                           x86_64                        4.4.16-1.fc31                                 updates                                    99 k
 libxcrypt-devel                            x86_64                        4.4.16-1.fc31                                 updates                                    34 k
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 chromium-libs                              x86_64                        80.0.3987.149-1.fc31                          updates                                    81 M
 chromium-libs-media                        x86_64                        80.0.3987.149-1.fc31                          updates                                   2.3 M

Transaction Summary
========================================================================================================================================================================
Upgrade  7 Packages
Skip     2 Packages

Total download size: 18 M
Is this ok [y/N]:

Can you give the output of “sudo dnf repolist”?

2 Likes
repo id                                                                            repo name
Atom                                                                               Atom Editor
adobe-linux-x86_64                                                                 Adobe Systems Incorporated
code                                                                               Visual Studio Code
copr:copr.fedorainfracloud.org:kwizart:fedy                                        Copr repo for fedy owned by kwizart
fedora                                                                             Fedora 31 - x86_64
fedora-modular                                                                     Fedora Modular 31 - x86_64
google-chrome                                                                      google-chrome
opera                                                                              Opera packages
rpmfusion-free                                                                     RPM Fusion for Fedora 31 - Free
rpmfusion-free-updates                                                             RPM Fusion for Fedora 31 - Free - Updates
rpmfusion-nonfree                                                                  RPM Fusion for Fedora 31 - Nonfree
rpmfusion-nonfree-updates                                                          RPM Fusion for Fedora 31 - Nonfree - Updates
updates                                                                            Fedora 31 - x86_64 - Updates
updates-modular                                                                    Fedora Modular 31 - x86_64 - Updates

I still do not get the problem :confused:

I updated to Fedora 32 and now both update problem and font problem seems to be fixed.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.