Can't Update SilverBlue. Getting SecAdvisories running manual upgrade

I’ve run a few updates over the last week or two (through GNOME software) and suddenly noticed that I seemed to be running the same update over and over again. I tried to update manually from the command line and I get the following error:

vailableUpdate: Version: 36.20220818.0 (2022-08-18T01:32:08Z) Commit: 7dd29734d2403cb8cd8e86b0af53d9e92de5eff8ad5c22ab9f145131cdaf51b7 GPGSignature: Valid signature by 53DED2CB922D8B8D9E63FD18999F7CBF38AB71F4 SecAdvisories: 1 unknown severity, 1 low, 2 moderate, 2 important Diff: 62 upgraded

I’m lost. :slight_smile: I don’t know how to find out what the apparent security problems are or how to correct them. I’ve never seen this before.

Anyone have any suggestions or know how to fix this?

1 Like

I ran into similar issues with my Silverblue machine. This looks to be issue [BUG] cannot update silverblue (grub2-mkconfig error) · Issue #322 · fedora-silverblue/issue-tracker · GitHub

When running rpm-ostree status I got the same message and was able to fix it by running the command in [BUG] cannot update silverblue (grub2-mkconfig error) · Issue #322 · fedora-silverblue/issue-tracker · GitHub and then rebooting my machine. After rebooting I was able to update again successfully.

Thank you for the suggestion. That took care of it for me.

I ran the update manually then ran grub2-mkconfig before rebooting and everything seems to be back on track now.

1 Like