Can't upgrade pipewire due to problems with fdk-aac-free, libldac and ldacbt conflicts

Hello,

I have trouble upgrading pipewire on my Fedora 33 Gnome installation. Initially I get:

Problem: fdk-aac-free-2.0.0-5.fc33.i686 has inferior architecture
  - package pipewire-libs-0.3.20-1.fc33.i686 requires libfdk-aac.so.2, but none of the providers can be installed
  - cannot install both fdk-aac-free-2.0.0-5.fc33.x86_64 and fdk-aac-free-2.0.0-7.fc33.x86_64
  - cannot install the best update candidate for package pipewire-libs-0.3.19-2.fc33.i686
  - cannot install the best update candidate for package fdk-aac-free-2.0.0-7.fc33.x86_64

After removing fdk-aac-free and trying to upgrade again, I get:

Error: Transaction test error:
  file /usr/lib64/libldacBT_abr.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64
  file /usr/lib64/libldacBT_enc.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64

libldac is a dependency that pipewire tries to install on upgrade. I can’t uninstall ldacbt, because gnome-shell would be removed along, according to dnf. I would be grateful if you could suggest some solution…

Btw. it is important for me, since since yesterday, perhaps after another upgrade, my Fedora plays sound on both headphones and internal laptop speakers at the same time :frowning:

1 Like

Here it goes:

[]# rpm -q -a pipewire-libs\* fdk\* libldac\*
fdk-aac-2.0.1-5.fc33.x86_64
pipewire-libs-0.3.19-2.fc33.x86_64
pipewire-libs-0.3.19-2.fc33.i686
[]# dnf -q list pipewire-libs\* fdk\* libldac\*
Installed Packages
fdk-aac.x86_64                                                                                                         2.0.1-5.fc33                                                                                                @unitedrpms
pipewire-libs.i686                                                                                                     0.3.19-2.fc33                                                                                               @updates   
pipewire-libs.x86_64                                                                                                   0.3.19-2.fc33                                                                                               @updates   
Available Packages
fdk-aac-devel.x86_64                                                                                                   2.0.1-5.fc33                                                                                                unitedrpms 
fdk-aac-free.i686                                                                                                      2.0.0-5.fc33                                                                                                fedora     
fdk-aac-free.x86_64                                                                                                    2.0.0-7.fc33                                                                                                unitedrpms 
fdk-aac-free-devel.i686                                                                                                2.0.0-5.fc33                                                                                                fedora     
fdk-aac-free-devel.x86_64                                                                                              2.0.0-7.fc33                                                                                                unitedrpms 
libldac.i686                                                                                                           2.0.2.3-7.fc33                                                                                              fedora     
libldac.x86_64                                                                                                         2.0.2.3-7.fc33                                                                                              fedora     
libldac-devel.i686                                                                                                     2.0.2.3-7.fc33                                                                                              fedora     
libldac-devel.x86_64                                                                                                   2.0.2.3-7.fc33                                                                                              fedora     
pipewire-libs.i686                                                                                                     0.3.20-1.fc33                                                                                               updates    
pipewire-libs.x86_64                                                                                                   0.3.20-1.fc33                                                                                               updates    
[]# dnf -q repoquery --duplicates
sysdig-0:0.26.4-1.x86_64
sysdig-0:0.26.5-1.x86_64
sysdig-0:0.27.1-1.x86_64
1 Like

Thank you. Something is still wrong, I am afraid. The first command works fine I think, but the second:

[]# sudo dnf --disablerepo unitedrpms\* distro-sync
Last metadata expiration check: 2:40:51 ago on Wed 27 Jan 2021 10:23:59.
Error: 
 Problem 1: package gstreamer1-plugins-bad-free-gtk-1.18.2-7.fc33.x86_64 requires gstreamer1-plugins-bad-free = 1.18.2-7.fc33, but none of the providers can be installed
  - gstreamer1-plugins-bad-free-1.18.2-7.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package gstreamer1-plugins-bad-free-gtk-1.18.2-7.fc33.x86_64
 Problem 2: package opencv-xfeatures2d-4.5.0-7.fc33.x86_64 requires libopencv_core.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-xfeatures2d-4.5.0-7.fc33.x86_64 requires libopencv_features2d.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-xfeatures2d-4.5.0-7.fc33.x86_64 requires libopencv_imgproc.so.4.5()(64bit), but none of the providers can be installed
  - opencv-core-4.5.0-7.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package opencv-xfeatures2d-4.5.0-7.fc33.x86_64
 Problem 3: package opencv-xfeatures2d-4.5.0-7.fc33.x86_64 requires libopencv_core.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-xfeatures2d-4.5.0-7.fc33.x86_64 requires libopencv_features2d.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-xfeatures2d-4.5.0-7.fc33.x86_64 requires libopencv_imgproc.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-core-4.5.0-7.fc33.x86_64 requires libopencv_calib3d.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-core-4.5.0-7.fc33.x86_64 requires libopencv_optflow.so.4.5()(64bit), but none of the providers can be installed
  - package opencv-xfeatures2d-devel-4.5.0-7.fc33.x86_64 requires opencv-xfeatures2d = 4.5.0-7.fc33, but none of the providers can be installed
  - opencv-contrib-4.5.0-7.fc33.x86_64 does not belong to a distupgrade repository
  - problem with installed package opencv-xfeatures2d-devel-4.5.0-7.fc33.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

However, maybe this is expected with the change of priority. Would you be so kind to tell me what should be the next step, I mean the command for rollback to official package versions? This system has a long history of upgrades of Fedora versions…

1 Like

Thanks. I was able to reinstall fdk-aac-free from repository “fedora”, with the command

sudo dnf --disablerepo unitedrpms* reinstall fdk*

However, the upgrade still gives:

# sudo dnf -q --refresh upgrade
Is this ok [y/N]: y
Error: Transaction test error:
file /usr/lib64/libldacBT_abr.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64
file /usr/lib64/libldacBT_enc.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64

1 Like

However, the results of the checking commands have changed:

[]# rpm -q -a pipewire-libs\* fdk\* libldac\* ldacbt\*
ldacbt-2.0.2.3-7.fc33.x86_64
fdk-aac-2.0.1-5.fc33.x86_64
pipewire-libs-0.3.19-2.fc33.x86_64
pipewire-libs-0.3.19-2.fc33.i686
fdk-aac-free-2.0.0-5.fc33.x86_64
[]# dnf -q list pipewire-libs\* fdk\* libldac\* ldacbt\*
Installed Packages
fdk-aac.x86_64                                                                                                      2.0.1-5.fc33                                                                                             @unitedrpms      
fdk-aac-free.x86_64                                                                                                 2.0.0-5.fc33                                                                                             @fedora          
ldacbt.x86_64                                                                                                       2.0.2.3-7.fc33                                                                                           @unitedrpms      
pipewire-libs.i686                                                                                                  0.3.19-2.fc33                                                                                            @updates         
pipewire-libs.x86_64                                                                                                0.3.19-2.fc33                                                                                            @updates         
Available Packages
fdk-aac-devel.x86_64                                                                                                2.0.1-3.fc33                                                                                             rpmfusion-nonfree
fdk-aac-free.i686                                                                                                   2.0.0-5.fc33                                                                                             fedora           
fdk-aac-free-devel.i686                                                                                             2.0.0-5.fc33                                                                                             fedora           
fdk-aac-free-devel.x86_64                                                                                           2.0.0-5.fc33                                                                                             fedora           
fdkaac.x86_64                                                                                                       1.0.0-5.fc33                                                                                             rpmfusion-nonfree
ldacbt-devel.x86_64                                                                                                 2.0.2.3-7.fc33                                                                                           unitedrpms       
libldac.i686                                                                                                        2.0.2.3-7.fc33                                                                                           fedora           
libldac.x86_64                                                                                                      2.0.2.3-7.fc33                                                                                           fedora           
libldac-devel.i686                                                                                                  2.0.2.3-7.fc33                                                                                           fedora           
libldac-devel.x86_64                                                                                                2.0.2.3-7.fc33                                                                                           fedora           
pipewire-libs.i686                                                                                                  0.3.20-1.fc33                                                                                            updates          
pipewire-libs.x86_64                                                                                                0.3.20-1.fc33                                                                                            updates          
[]# dnf -q repoquery --duplicates
sysdig-0:0.26.4-1.x86_64
sysdig-0:0.26.5-1.x86_64
sysdig-0:0.27.1-1.x86_64
1 Like

Here you go:

[]# dnf upgrade
Last metadata expiration check: 0:14:45 ago on Wed 27 Jan 2021 14:44:11.
Dependencies resolved.

 Problem 1: package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64 conflicts with xorg-x11-drv-nvidia-cuda provided by xorg-x11-drv-nvidia-cuda-3:455.28-1.fc33.x86_64
  - cannot install the best update candidate for package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64
  - cannot install the best update candidate for package cuda-drivers-440.95.01-1.x86_64
 Problem 2: installed package nvidia-driver-3:440.95.01-1.fc29.x86_64 obsoletes xorg-x11-drv-nvidia provided by xorg-x11-drv-nvidia-3:455.28-1.fc33.x86_64
  - package akmod-nvidia-3:455.28-1.fc33.x86_64 requires nvidia-kmod-common >= 3:455.28, but none of the providers can be installed
  - cannot install the best update candidate for package nvidia-driver-3:440.95.01-1.fc29.x86_64
  - cannot install the best update candidate for package akmod-nvidia-3:440.95.01-1.fc29.x86_64
 Problem 3: problem with installed package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64
  - package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64 requires nvidia-persistenced = 3:440.95.01, but none of the providers can be installed
  - cannot install both nvidia-persistenced-3:455.28-2.fc33.x86_64 and nvidia-persistenced-3:440.95.01-1.fc29.x86_64
  - cannot install the best update candidate for package nvidia-persistenced-3:440.95.01-1.fc29.x86_64
==============================================================================================================================================================================================================================================
 Package                                                           Architecture                                    Version                                                   Repository                                                  Size
==============================================================================================================================================================================================================================================
Upgrading:
 pipewire                                                          i686                                            0.3.20-1.fc33                                             updates                                                    121 k
 pipewire                                                          x86_64                                          0.3.20-1.fc33                                             updates                                                    121 k
 pipewire-alsa                                                     i686                                            0.3.20-1.fc33                                             updates                                                     52 k
 pipewire-alsa                                                     x86_64                                          0.3.20-1.fc33                                             updates                                                     52 k
 pipewire-gstreamer                                                x86_64                                          0.3.20-1.fc33                                             updates                                                     52 k
 pipewire-libs                                                     i686                                            0.3.20-1.fc33                                             updates                                                    962 k
 pipewire-libs                                                     x86_64                                          0.3.20-1.fc33                                             updates                                                    965 k
 vcdimager                                                         x86_64                                          2.0.1-9.fc33                                              rpmfusion-free                                             301 k
 vcdimager-libs                                                    x86_64                                          2.0.1-9.fc33                                              rpmfusion-free                                             101 k
Installing dependencies:
 bluez-libs                                                        i686                                            5.55-1.fc33                                               fedora                                                      91 k
 fdk-aac-free                                                      i686                                            2.0.0-5.fc33                                              fedora                                                     322 k
 fdk-aac-free                                                      x86_64                                          2.0.0-5.fc33                                              fedora                                                     329 k
 libldac                                                           i686                                            2.0.2.3-7.fc33                                            fedora                                                      42 k
 libldac                                                           x86_64                                          2.0.2.3-7.fc33                                            fedora                                                      41 k
Removing dependent packages:
 python2-pip                                                       noarch                                          19.1.1-7.fc33                                             @unitedrpms                                                8.7 M
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nvidia-persistenced                                               x86_64                                          3:455.28-2.fc33                                           rpmfusion-nonfree                                           35 k
 xorg-x11-drv-nvidia-cuda                                          x86_64                                          3:455.28-1.fc33                                           rpmfusion-nonfree                                          342 k
Skipping packages with broken dependencies:
 akmod-nvidia                                                      x86_64                                          3:455.28-1.fc33                                           rpmfusion-nonfree                                           27 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  5 Packages
Upgrade  9 Packages
Remove   1 Package
Skip     3 Packages

Total size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] bluez-libs-5.55-1.fc33.i686.rpm: Already downloaded                                                                                                                                                                                
[SKIPPED] fdk-aac-free-2.0.0-5.fc33.i686.rpm: Already downloaded                                                                                                                                                                             
[SKIPPED] fdk-aac-free-2.0.0-5.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                           
[SKIPPED] libldac-2.0.2.3-7.fc33.i686.rpm: Already downloaded                                                                                                                                                                                
[SKIPPED] libldac-2.0.2.3-7.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                              
[SKIPPED] pipewire-0.3.20-1.fc33.i686.rpm: Already downloaded                                                                                                                                                                                
[SKIPPED] pipewire-0.3.20-1.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                              
[SKIPPED] pipewire-alsa-0.3.20-1.fc33.i686.rpm: Already downloaded                                                                                                                                                                           
[SKIPPED] pipewire-alsa-0.3.20-1.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                         
[SKIPPED] pipewire-gstreamer-0.3.20-1.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                    
[SKIPPED] pipewire-libs-0.3.20-1.fc33.i686.rpm: Already downloaded                                                                                                                                                                           
[SKIPPED] pipewire-libs-0.3.20-1.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                         
[SKIPPED] vcdimager-2.0.1-9.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                              
[SKIPPED] vcdimager-libs-2.0.1-9.fc33.x86_64.rpm: Already downloaded                                                                                                                                                                         
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /usr/lib64/libldacBT_abr.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64
  file /usr/lib64/libldacBT_enc.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64
1 Like

Unfortunately still the same:

[]# dnf clean all
145 files removed
[]# dnf upgrade
Adobe Systems Incorporated                                                                                                                                                                                    4.8 kB/s | 1.9 kB     00:00    
Adobe Systems Incorporated                                                                                                                                                                                    8.6 kB/s | 2.0 kB     00:00    
cuda                                                                                                                                                                                                          3.5 MB/s | 433 kB     00:00    
Draios                                                                                                                                                                                                        270 kB/s | 356 kB     00:01    
Fedora 33 openh264 (From Cisco) - x86_64                                                                                                                                                                      2.8 kB/s | 5.1 kB     00:01    
Fedora Modular 33 - x86_64                                                                                                                                                                                    4.7 MB/s | 3.3 MB     00:00    
negativo17 - Steam                                                                                                                                                                                            7.4 kB/s | 1.8 kB     00:00    
Fedora Modular 33 - x86_64 - Updates                                                                                                                                                                          5.6 MB/s | 3.0 MB     00:00    
Fedora 33 - x86_64 - Updates                                                                                                                                                                                  9.5 MB/s |  22 MB     00:02    
Fedora 33 - x86_64                                                                                                                                                                                             13 MB/s |  72 MB     00:05    
google-chrome                                                                                                                                                                                                  24 kB/s | 3.5 kB     00:00    
google-earth-pro                                                                                                                                                                                               36 kB/s | 5.3 kB     00:00    
MEGAsync                                                                                                                                                                                                       38 kB/s |  13 kB     00:00    
Opera packages                                                                                                                                                                                                 38 kB/s |  13 kB     00:00    
RPM Fusion for Fedora 33 - Free - Updates                                                                                                                                                                     901 kB/s | 379 kB     00:00    
RPM Fusion for Fedora 33 - Free                                                                                                                                                                               944 kB/s | 897 kB     00:00    
RPM Fusion for Fedora 33 - Nonfree                                                                                                                                                                            430 kB/s | 278 kB     00:00    
RPM Sphere - Basearch                                                                                                                                                                                         3.8 MB/s | 3.1 MB     00:00    
RPM Sphere - Noarch                                                                                                                                                                                           4.2 MB/s | 3.9 MB     00:00    
skype (stable)                                                                                                                                                                                                8.6 kB/s | 3.7 kB     00:00    
unitedrpms 33 - x86_64                                                                                                                                                                                         55 kB/s | 883 kB     00:16    
Dependencies resolved.

 Problem 1: package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64 conflicts with xorg-x11-drv-nvidia-cuda provided by xorg-x11-drv-nvidia-cuda-3:455.28-1.fc33.x86_64
  - cannot install the best update candidate for package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64
  - cannot install the best update candidate for package cuda-drivers-440.95.01-1.x86_64
 Problem 2: installed package nvidia-driver-3:440.95.01-1.fc29.x86_64 obsoletes xorg-x11-drv-nvidia provided by xorg-x11-drv-nvidia-3:455.28-1.fc33.x86_64
  - package akmod-nvidia-3:455.28-1.fc33.x86_64 requires nvidia-kmod-common >= 3:455.28, but none of the providers can be installed
  - cannot install the best update candidate for package nvidia-driver-3:440.95.01-1.fc29.x86_64
  - cannot install the best update candidate for package akmod-nvidia-3:440.95.01-1.fc29.x86_64
 Problem 3: problem with installed package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64
  - package nvidia-driver-cuda-3:440.95.01-1.fc29.x86_64 requires nvidia-persistenced = 3:440.95.01, but none of the providers can be installed
  - cannot install both nvidia-persistenced-3:455.28-2.fc33.x86_64 and nvidia-persistenced-3:440.95.01-1.fc29.x86_64
  - cannot install the best update candidate for package nvidia-persistenced-3:440.95.01-1.fc29.x86_64
==============================================================================================================================================================================================================================================
 Package                                                           Architecture                                    Version                                                   Repository                                                  Size
==============================================================================================================================================================================================================================================
Upgrading:
 pipewire                                                          i686                                            0.3.20-1.fc33                                             updates                                                    121 k
 pipewire                                                          x86_64                                          0.3.20-1.fc33                                             updates                                                    121 k
 pipewire-alsa                                                     i686                                            0.3.20-1.fc33                                             updates                                                     52 k
 pipewire-alsa                                                     x86_64                                          0.3.20-1.fc33                                             updates                                                     52 k
 pipewire-gstreamer                                                x86_64                                          0.3.20-1.fc33                                             updates                                                     52 k
 pipewire-libs                                                     i686                                            0.3.20-1.fc33                                             updates                                                    962 k
 pipewire-libs                                                     x86_64                                          0.3.20-1.fc33                                             updates                                                    965 k
 vcdimager                                                         x86_64                                          2.0.1-9.fc33                                              rpmfusion-free                                             301 k
 vcdimager-libs                                                    x86_64                                          2.0.1-9.fc33                                              rpmfusion-free                                             101 k
Installing dependencies:
 bluez-libs                                                        i686                                            5.55-1.fc33                                               fedora                                                      91 k
 fdk-aac-free                                                      i686                                            2.0.0-5.fc33                                              fedora                                                     322 k
 fdk-aac-free                                                      x86_64                                          2.0.0-5.fc33                                              fedora                                                     329 k
 libldac                                                           i686                                            2.0.2.3-7.fc33                                            fedora                                                      42 k
 libldac                                                           x86_64                                          2.0.2.3-7.fc33                                            fedora                                                      41 k
Removing dependent packages:
 python2-pip                                                       noarch                                          19.1.1-7.fc33                                             @unitedrpms                                                8.7 M
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nvidia-persistenced                                               x86_64                                          3:455.28-2.fc33                                           rpmfusion-nonfree                                           35 k
 xorg-x11-drv-nvidia-cuda                                          x86_64                                          3:455.28-1.fc33                                           rpmfusion-nonfree                                          342 k
Skipping packages with broken dependencies:
 akmod-nvidia                                                      x86_64                                          3:455.28-1.fc33                                           rpmfusion-nonfree                                           27 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  5 Packages
Upgrade  9 Packages
Remove   1 Package
Skip     3 Packages

Total download size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/14): bluez-libs-5.55-1.fc33.i686.rpm                                                                                                                                                                       632 kB/s |  91 kB     00:00    
(2/14): fdk-aac-free-2.0.0-5.fc33.i686.rpm                                                                                                                                                                    1.6 MB/s | 322 kB     00:00    
(3/14): fdk-aac-free-2.0.0-5.fc33.x86_64.rpm                                                                                                                                                                  1.5 MB/s | 329 kB     00:00    
(4/14): libldac-2.0.2.3-7.fc33.x86_64.rpm                                                                                                                                                                     1.2 MB/s |  41 kB     00:00    
(5/14): libldac-2.0.2.3-7.fc33.i686.rpm                                                                                                                                                                       462 kB/s |  42 kB     00:00    
(6/14): pipewire-0.3.20-1.fc33.x86_64.rpm                                                                                                                                                                     2.0 MB/s | 121 kB     00:00    
(7/14): pipewire-alsa-0.3.20-1.fc33.i686.rpm                                                                                                                                                                  629 kB/s |  52 kB     00:00    
(8/14): pipewire-0.3.20-1.fc33.i686.rpm                                                                                                                                                                       1.1 MB/s | 121 kB     00:00    
(9/14): pipewire-gstreamer-0.3.20-1.fc33.x86_64.rpm                                                                                                                                                           1.0 MB/s |  52 kB     00:00    
(10/14): pipewire-alsa-0.3.20-1.fc33.x86_64.rpm                                                                                                                                                               640 kB/s |  52 kB     00:00    
(11/14): vcdimager-2.0.1-9.fc33.x86_64.rpm                                                                                                                                                                    2.2 MB/s | 301 kB     00:00    
(12/14): vcdimager-libs-2.0.1-9.fc33.x86_64.rpm                                                                                                                                                               1.8 MB/s | 101 kB     00:00    
(13/14): pipewire-libs-0.3.20-1.fc33.i686.rpm                                                                                                                                                                 3.4 MB/s | 962 kB     00:00    
(14/14): pipewire-libs-0.3.20-1.fc33.x86_64.rpm                                                                                                                                                               3.9 MB/s | 965 kB     00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                         1.7 MB/s | 3.5 MB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /usr/lib64/libldacBT_abr.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64
  file /usr/lib64/libldacBT_enc.so.2.0.2.3 from install of libldac-2.0.2.3-7.fc33.x86_64 conflicts with file from package ldacbt-2.0.2.3-7.fc33.x86_64
1 Like
sudo dnf config-manager --save --setopt=unitedrpms\*.priority=100
sudo dnf swap ldacbt libldac

Worked! Thanks!
Perhaps I didn’t completely understand the syntax that you’ve provided, because like that it only complained about lack of ldacbt.i686, but after solving this, it did nothing. So I ran shell manually and finished with “transaction run”. Afterwards dnf upgrade worked.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.