Caps lock and number line

Hi guys

So i use a azerty TKL keyboard on my desktop, and when i press “caps lock” it allow to type in uppercase yes but the special character line is not affect by it.
So if i would like to type number i need to maintain shift…


i have install gnome-tweak-tool and try to change the cap lock behave, the only one how work is “cap lock switch on uppercase (affect all keys)” but… it affect all keys so i shift click when cap locks is enable :confused:

1 Like

Still stuck at the same point, no French people have the same issue?

I think this is a bug that will require some digging into with the developers. Can you please clarify what is expected behaviour here so that we’re all clear on the problem? Should caps lock behave like a shift lock as Wikipedia suggests for this keyboard layout (or have I misunderstood)? I’m using a QUERTY EN-GB layout here, and caps does not function as shift lock, but that seems to be expected behaviour.

However, on certain non-QWERTY keyboard layouts, such as the French AZERTY and the German QWERTZ, Caps Lock still behaves like a traditional Shift lock, i.e., the keyboard behaves as if the Shift key is held down, causing the keyboard to input the alternative values of the keys; example the “5” key generates a “%” when Caps lock is pressed. This is not true for the layout “German (IBM)”.

1 Like

Thanks for your answer, yes it’s exactly that.

On a AZERTY keyboard the number row is use for special character ( &é"’(-è_çà ).
On windows when we activate the the Cap lock key, this row transform to 1234567890 and of course the alphanumerical characters will be on uppercase.

On the gnome advance settings the option cap “Lock switch on uppercase (affect all keys)” is behave like expected, except that it affect the left click, and make me shift click.

Do you know where can i report this ?

I’m not sure to be honest. Since it seems to be a gnome related bug, perhaps the Gnome user forums would be the first place to start. You can also file bugs on the Fedora packages, perhaps for gnome-control-center or speak to the workstation SIG:

@chrismurphy @mcatanzaro: sorry for the ping: any chance you’d have some ideas here?

1 Like

I don’t know, sorry.

1 Like

Thanks, i will make a contact the Gnome forum and get back here the issue is fix :slight_smile:

1 Like