Captive portal not functional

captive portal is not working if my isp internet connection logged out it does not prompted me to log back in i have to open my phone to do so i have asked gnome forum but they told that captive p already in gnome 3.34 so there must be a bug can i have some help workaround.

Gnome captive portal opens up only when you connect your phone, the first time to initiate an internet connection. Once you have closed that window, if you want to disconnect the internet connection or restart the internet connection, it must be done through the internet browser.

that does not happening to me it never show me anything related to captive portal.

Are you actually using that version of gnome?
Which fedora version do you have? If fedora 34 or later then you are using gnome 40 or later (gnome 42.3 on my fedora 36 system).

i am on fedora 36 on latest fix whatever available till now but captive login still not working.

Lets take a step back here.

How are you connecting your fedora to your android phone? “USB Tethering” or “Hotspot”?

Is the captive portal supposed to pop up when you connect your phone to fedora?

Below is a sample captive portal (gnome-shell-portal-helper). In my case, when I connect my USB modem, captive portal pops ups. Once I have closed the captive portal window, I have to open the URL in a browser to disconnect or reconnect internet without having to remove the USB modem.

no i don’t connect my system with hotspot i connect it with a usb wifi dongle
but if i connect my home wifi with my pc it does not ping captive portal but if i connect my phone to my home wifi it does prompt me for login