Changed diacritical characters in the names of backup files and folders - Pika Backup

Hi.

I backed up my files yesterday using Pika Backup software, installed via flathub on Fedora 37.
Today I tried to restore this backup using Pika Backup and noticed that all diacritics in the file and folder names are changed to some strange symbols. The problem also occurs when I open backup in Vorta.

wrong names 2

The above names should look like this:
Hiszpańska zupa z ciecierzycą_1.jpg
Hiszpańska zupa z ciecierzycą_2.jpg
The same is true of diacritical marks from any other language.

I searched for a solution on the Internet, but found nothing similar.

Does anyone have an idea how to open the backup correctly so that the characters display correctly? or how to change all those symbols in the names of all files and folders to the correct letters. I have thousands of files and folders with corrupted diacriticals.

Your sincerely.

Ok.
I manually replaced the strange characters using the “Szyszka” tool available in the software section.

I’m still curious why the Pika backup made errors in the backup file names.
If anyone ever knows the answer, please write about it.

I guess that it doesn’t support all accented characters. I didn’t find a relevant open issue in the project’s GitLab, so I think it would be good if you could create a new one and let the developers know about it and fix it.

Just curious, what kind of device/under what system are you backing up to? Pika is based on BorgBackup, and in browsing the BorgBackup issues there was discussion of different systems having different encoding schemes by default (across Windows, macOS and Linux) - I experienced almost the exact same issue with certain characters when backing up to a drive connected to my Windows desktop, so I wonder if the issue occurs when backing up to the same device, and if it occurs backing up to another device of the same OS?

Possibly related?