Changing keyboard layout from command line issue

Hi,

we use a lot of laptops with fedora image and we are defining keyboard layout based on a csv file using command-line.

This keyboard layout attribution was made at boot on fedora 29 using localectl utility and changes where also valid in KDE.

Now on Fedora 31 the keyboard layout seems to be set by some new regional option, none of the localectl commands helps changing keyboard layout in KDE, on login screen layout is defined correctly but it changes at logon.

I found that using setxkbmap I can change the keyboard but I cant achieve to set a script that change this layout at logon :

  • putting a .desktop file in /.config/autostart/
  • putting a .sh file in /.config/autostart-script/

It does not work anymore, the keyboard is always set on another layout apparently based on regional settings.

The user interface related to this settings does not help :

Unchecking β€œconfigure layout” does not work : at every boot the keyboard layout is changed and β€œconfigure layout” is enabled again for unknown reason.

Is this a know bug of version 31 ?

Thanks in advance for any help on this issue.

As explained in my previous post ive tried this workaround but this is not working on our setup : Keyboard layout resets on reboot

Β Β Hi. Β Is this happens for a new test-user too (GUI sometimes get fixed by cleaning the old stuff in ~/'s dot-folders)?

Hi thanks for your suggestion, setting a new profile solved the issue as the keyboard layout was again set as expected.

EDIT : I confirm that removing the ~/.config folder fixed the keyboard layout attribution issue.

Probably a old config file that was messing with KDE preventing our system to get correctly configured.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.