Chrome: enable in Amazon Prime: 1080p / 1440p / 4k UHD Quality

Hi,
in Chrome: every Movie/Serie looks like SD Quality.
How can i enable 1080p/1440P/4k uhd Quality?

When i start a Episode, example: https://www.amazon.de/gp/video/detail/B083F6KYHL/ref=atv_hm_hom_1_c_e7ulE1_8_11
or for 4k uhd:
https://www.amazon.de/Die-Weisheit-der-Wüste/dp/B07QHXLQ8Q/ref=sr_1_1?__mk_de_DE=ÅMÅŽÕÑ&dchild=1&keywords=uhd&qid=1589666925&s=instant-video&sr=1-1

the movie looks like Eyes Crash.
:innocent:
How can i enable maximum Quality?

Speed Test shows:

Something to activate with command in Terminal at first?

Thanks for helping !
:slightly_smiling_face:

1 Like

the sun is shining…
= when anyone can help me, and make the Videos to full Qualtiy working
:innocent: :innocent: :innocent:

it is so crazy, that amazon prime works fine with TV ( Amazon App) = with high Quality. ( i tested them yesterday)
but on my desktop pc ( with fedora 32) only i mean SD Quality in all Movies/Series

= in past, desktop pc with Windows, never Problems with Amazon Prime.
only now with fedora installed

Thanks for helping…

to solve the Problem: maybe…

How to Install Windows 10 on Virtualbox in Linux ( Fedora 32)

this are a great Tutorial for that?

i want to watch prime not in SD - so, i search for finding solutions…

Did you try with Firefox? Do you have the same definition?

Yes, with Firefox, in my Case - same Issue.
i think, it is the Problem Linux and Amazon Prime (DRM Copyprotection)
so, that is the result for, only just SD Quality …

I can see that on Firefox
Screenshot from 2020-05-19 17-15-47
(it is in Italian. Video Quality: Good, Higher, Excellent)

Do you mean that you haven’t these options, and you are stuck to the first one?

i have these Options too.
No, i did´t mean that.
i mean: Start a Movie/Serie and look at the bottom left.
You see the Time ( example: 00:00 / 39:06 )
when Prime works fine, the right solution is: 00:00 / 39:06 1080p
or
00:00 / 39:06 uhd hdr

in my Case: only: 00:00 / 39:06
and that means: Movies/Series only in SD Quality - and that is Accident in my Eyes

Oh, well, there is this document on Amazon: Prime Video System Requirements for Computers

If you are running an operating system other than Windows or Mac OS, playback is restricted to standard definition.

1 Like

this is what i mean - and that is holy sh…
WHY did they shut down Linux?
WHY did not Millions of Linux Users open the Amazon Prime Door and say: enable your Stuff for Linux Users…
?
:hot_face:

I recommend you, install chromium-freeworld…

However this doesn’t solve the issue.

i can not understand, why A. Prime set Linux User to un-respectful second line, you know what i mean. i find this Step, for Linux User, that Movies Stuff only possible to get in SD Quality, not really friendly. what do you think?

If chromium-freeworld has vaapi, widevine enabled and full media support it would works… Other problem is the drivers but it is other topic…

@davidva: Greetings - thanks for your Post.
i use chrome, not chromium.
i do not know, what is vaapi and widevine and full media support.
and do not know, what steps to do, to use all stuff.

is here just one user, who use amazon prime with Linux?
best case, fedora?

so, i can hope - but, i thought, with Linux just only SD Quality works with Amazon Prime.
and not important, which browser you use.
just linux, okay, only SD Quality

@dawson Install it from UnitedRPMs or Rpmfusion… I can secure the installation of widevine and others things is automatic from UnitedRPMs. But as I am user of Netflix I am not tested Amazon… Your question about if it works can help.

i am sure, Amazon Prime not work in full hd, 1440p or uhd with Linux…
that are told in notes in amazon page: https://www.amazon.com/gp/help/customer/display.html?nodeId=GUVGB3QMQRYRERYW
so, with chromium, or firefox or any other browers = not possible, i thing

Conjectures isn’t possible; Check it out for yourself. Install chromium-freeworld and test, and if you want remove after… https://en.wikipedia.org/wiki/Encrypted_Media_Extensions

sudo dnf install chromium-freeworld

same result: Files only starts in SD Quality

sudo dnf remove chromium-freeworld