Cinnamon won't start after upgrade to Fedora 36

I use Cinnamon DE. It works fine on Fedora 35. After upgrade to 36, typing my password and hitting enter immediately returns me to the login screen. I see nothing in the logs that mention Cinnamon. Gnome and Gnome Classic both work on 36. Others with this issue? Any ideas? Thanks

Welcome to ask.:fedora:edora @tuolumne68
If you not had time yet please read >> #start-here

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Can you please also past the info from grep '/usr/s\?bin' /etc/systemd/system/display-manager.service

It will make searching about the problem easier when we do know the display-manager.

From the boot of F35 (running Cinnamon):
inxi -Fzx

System:
  Kernel: 5.17.6-200.fc35.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-17.fc35 Desktop: Cinnamon v: 5.2.7
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Desktop System: HP product: HP Z2 Tower G4 Workstation v: N/A
    serial: <superuser required>
  Mobo: HP model: 8455 v: KBC Version 07.D4.00 serial: <superuser required>
    UEFI: HP v: Q50 Ver. 01.07.00 date: 04/28/2021
CPU:
  Info: 6-core model: Intel Core i7-8700 bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 858 high: 900 min/max: 800/4600 cores: 1: 836 2: 900
    3: 855 4: 890 5: 846 6: 865 7: 854 8: 800 9: 804 10: 851 11: 900 12: 900
    bogomips: 76799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA GP107GL [Quadro P1000] vendor: Hewlett-Packard
    driver: nvidia v: 510.60.02 bus-ID: 01:00.0
  Display: x11 server: X.Org v: 1.20.14 driver: X: loaded: nvidia
    gpu: nvidia resolution: 1920x1080~60Hz
  OpenGL: renderer: Quadro P1000/PCIe/SSE2 v: 4.6.0 NVIDIA 510.60.02
    direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.17.6-200.fc35.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    bus-ID: 00:17.0
Drives:
  Local Storage: total: 1.38 TiB used: 37.77 GiB (2.7%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000H2
    size: 476.94 GiB temp: 23.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-60ZF5A0
    size: 931.51 GiB
Partition:
  ID-1: / size: 48.91 GiB used: 19.52 GiB (39.9%) fs: ext4 dev: /dev/dm-0
    mapped: fedora_bcox--dualboot-root
  ID-2: /boot size: 474 MiB used: 334.3 MiB (70.5%) fs: ext4 dev: /dev/sda4
  ID-3: /boot/efi size: 199.8 MiB used: 62 MiB (31.1%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 139.2 GiB used: 15.01 GiB (10.8%) fs: ext4
    dev: /dev/dm-2 mapped: fedora_bcox--dualboot-home
Swap:
  ID-1: swap-1 type: partition size: 7.7 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-1 mapped: fedora_bcox--dualboot-swap
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 30.0 C pch: 45.0 C mobo: N/A gpu: nvidia
    temp: 33 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 34%
Info:
  Processes: 337 Uptime: 11h 22m Memory: 15.47 GiB used: 5.31 GiB (34.3%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.1 clang: 14.0.0
  Packages: N/A note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.14


grep '/usr/s\?bin' /etc/systemd/system/display-manager.service
ExecStart=/usr/sbin/gdm

From the boot of F36 (running Gnome Classic):
inxi -Fzx

System:
  Kernel: 5.17.6-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.0
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Desktop System: HP product: HP Z2 Tower G4 Workstation v: N/A
    serial: <superuser required>
  Mobo: HP model: 8455 v: KBC Version 07.D4.00 serial: <superuser required>
    UEFI: HP v: Q50 Ver. 01.07.00 date: 04/28/2021
CPU:
  Info: 6-core model: Intel Core i7-8700 bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 852 high: 900 min/max: 800/4600 cores: 1: 800 2: 800
    3: 830 4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 800 11: 800 12: 800
    bogomips: 76799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA GP107GL [Quadro P1000] vendor: Hewlett-Packard driver: N/A
    bus-ID: 01:00.0
  Display: wayland server: X.Org v: 1.22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: N/A failed: nvidia gpu: N/A
    resolution: 1920x1080~60Hz
  OpenGL: renderer: llvmpipe (LLVM 14.0.0 256 bits) v: 4.5 Mesa 22.0.3
    direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.17.6-300.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    bus-ID: 00:17.0
Drives:
  Local Storage: total: 1.38 TiB used: 37.63 GiB (2.7%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000H2
    size: 476.94 GiB temp: 25.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-60ZF5A0
    size: 931.51 GiB
Partition:
  ID-1: / size: 48.91 GiB used: 19.52 GiB (39.9%) fs: ext4 dev: /dev/dm-0
    mapped: fedora_bcox--dualboot-root
  ID-2: /boot size: 474 MiB used: 334.3 MiB (70.5%) fs: ext4 dev: /dev/sda4
  ID-3: /boot/efi size: 199.8 MiB used: 62 MiB (31.1%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 139.2 GiB used: 14.86 GiB (10.7%) fs: ext4
    dev: /dev/dm-2 mapped: fedora_bcox--dualboot-home
Swap:
  ID-1: swap-1 type: partition size: 7.7 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-1 mapped: fedora_bcox--dualboot-swap
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 30.0 C pch: 47.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 306 Uptime: 4m Memory: 15.47 GiB used: 2.15 GiB (13.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.1 clang: 14.0.0
  Packages: N/A note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.14

[Brian@localhost ~]$ grep ‘/usr/s?bin’ /etc/systemd/system/display-manager.service
ExecStart=/usr/sbin/gdm

Please try to replace gdm with lightdm, to see if you can use your cinnamon installation:

Thanks for the info, but this didn’t work. When I boot F36, lightdm failed to start (SIGABRT from /usr/bin/X) and the boot log was dumped to the screen.

$ tail boot.log

[  OK  ] Started nordvpnd.service - NordVPN Daemon.
         Starting rpc-statd-notify.service - Notify NFS peers of a restart...
         Starting systemd-user-sessions.service - Permit User Sessions...
[  OK  ] Finished systemd-user-sessions.service - Permit User Sessions.
[  OK  ] Started atd.service - Deferred execution scheduler.
[  OK  ] Started crond.service - Command Scheduler.
         Starting lightdm.service - Light Display Manager...
         Starting plymouth-quit-wait.service - Hold until boot process finishes up...
[  OK  ] Started libvirtd.service - Virtualization daemon.
[  OK  ] Started rpc-statd-notify.service - Notify NFS peers of a restart.

$ cat /var/log/lightdm.log

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=1608
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-run-directory.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/90-slick-greeter.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /var/lib/flatpak/exports/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Using VT 1
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 1
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.00s] DEBUG: XServer 0: Launching X Server
[+0.00s] DEBUG: Launching process 1614: /usr/bin/X -core -noreset :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch
[+0.00s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.00s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.00s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.00s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.18s] DEBUG: Process 1614 terminated with signal 6
[+0.18s] DEBUG: XServer 0: X server stopped
[+0.18s] DEBUG: Releasing VT 1
[+0.18s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.18s] DEBUG: Seat seat0: Display server stopped
[+0.18s] DEBUG: Seat seat0: Stopping session
[+0.18s] DEBUG: Seat seat0: Session stopped
[+0.18s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.18s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.18s] DEBUG: Seat seat0: Stopping
[+0.18s] DEBUG: Seat seat0: Stopped
[+0.18s] DEBUG: Required seat has stopped
[+0.18s] DEBUG: Stopping display manager
[+0.18s] DEBUG: Display manager stopped
[+0.18s] DEBUG: Stopping daemon
[+0.18s] DEBUG: Exiting with return value 1

It looks like you have trouble with the Nvidia Driver. Does Cinnamon have the option to switch to wayland?

Thanks for the help. Cinnamon doesn’t seem to support Wayland. Also, it would seem that since Cinnamon works fine using F35 with kernel 5.17.6 and nvidia driver 510.60.02, and doesn’t using F36 with the same kernel and nvidia driver, that the issue is that something has changed in F36 that prevents Cinnamon from running on it. Also note that I’ve run Cinnamon since switching to Fedora with release 25 (or so). Any other ideas?

I do not think that replacing gdm with lightdm could have solved the issue. Actually it made it worse. Now, lightdm should work as should gdm, so that’s one part of the problem, while the Cinnamon could be another one.

If this happened after upgrade, I would first start to check whether newer Cinnamon could expect a different configuration file? Try to create a new user and then log into Cinnamon and see if it works. If it does, delete the configuration files for Cinnamon from your home directory.

If it does not help - do not log into the system using gdm, but go to TTY instead (press Ctrl-Alt-F3 and log using the prompt.
Then:

  1. Stop gdm (sudo systemctl stop gdm.service).
  2. Try running startx and see if any session opens.

If it does, it will open as a X11 session and you will know that drivers are not a problem. If it does not, it will spit out some errors and you will be able to go from there.

Thanks, but that didn’t reveal anything useful. The problem is the simpledrm in F36 doesn’t work with the NVIDIA driver and simpledrm in F35 does. For a fix see:

1 Like