Closed Caption Fedora36 KDE

,

When watching tv shows online I’m noticing there are times when the show speaks in a language other then english, for example on Andor when they speak Kassari, the closed caption just says, “speaking kassari” instead of showing what they are saying in english. At first I thought this was just how the show was but my father, who uses windows, says he can see what they are saying in english instead of what I’m getting.

Is this a linux issue? Am I missing a library I would need or something? I’m on Fedora 36 KDE and use Firefox 105.0.1 (64-bit).

Welcome to ask.:fedora:edora @noobardanu

From the information you gave here it is difficult to say that it is a linux specific problem.
Fedora Linux comes without “codecs” preinstalled because of patented/non-free licensed software.

For this read please the following manual entry and try to add them as explained:
Installing plugins for playing movies and music :: Fedora Docs

But probably it is just a setting you have to do on the service you watch the video from. For helping on this we would need more information.