Closing lid does not initiate sleep/standby/suspend

I have brand new install of Fedora 36. Using Lenovo X13 Yoga Gen 2.

When I close the lid, suspend does not occur. I have gnome-tweaks installed and confirmed the setting to start suspend when lid is closed is enabled.

Anybody know if there is a fix for this?

Alternatively, is it possible to create a keyboard shortcut to initiate suspend? For example, I can create a keyboard shortcut to logout with “gnome-session --logout”. Is there an equivalent ability to create a keyboard shortcut for suspend?

It is actually initiate lock screen you can do suspend with power switch set this with gnome settings app under power submenu.

Maybe try making a custom keyboard shortcut that suspends the computer. You can create custom shortcuts through the keyboard section of gnome settings.

The command for suspending is

systemctl suspend

Fantastic. Thank you for the shortcut, Mr Scientific. This helps. (I didn’t know what “command” was for suspend)

Ugh. The problem is that if I lock the screen, I can’t then suspend. But if the computer would sleep when shutting the lid, then I can lock screen, and close lid and get suspend.

the gnome settings menu already shows the power button with suspend but when I press the power button nothing happens. Maybe related to why laptop won’t sleep when lid is closed?

That is strange. Can you show a picture of that.

When I put the laptop to sleep, I then close the lid and confirm by Lenovo’s pulsing red light that the laptop is sleeping. But after several minutes, the computer wakes up even though the lid is still down.

So something is wrong here. The laptop is not staying asleep. Anyone know a fix?

Try to check journal with journalctl commands
https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/