Computer won't auto boot into fedora

Hello,
I dual-boot with windows. I want to by default boot into fedora. So I set the boot order to start with the drive that has the grub and the fedora install. Next drive is the windows drive.
So with auto-boot it boots into windows even though when I manually boot into the same drive it boots into fedora. What am I missing?

setting the boot order in bios /uefi

manually booting the m2 drive (that has fedora and grub)

Not sure if this is relevant but I have a ASROCK x99 extreme 4 motherboard. And my fedora and grub or on an Samsung 860 EVO M.2 drive.

1 Like

You likely need to modify the EFI boot order that is usually a separate configuration from device boot order.

You should be able to check the current settings with:

sudo efibootmgr

See also:
https://askbot.fedoraproject.org/en/question/111637/how-can-i-create-a-efi-boot-menu-entry-using-efibootmgr/

EFI variables are not supported on this system.

Does this mean I will never be able to auto boot into fedora?

1 Like

Check the following and post the output here:

rpm -q -a grub\* shim\*
lsblk -o NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT
grep -e /boot /etc/mtab
sudo ls /sys/firmware/efi /boot/efi /boot/efi/EFI
[alex_trune@fedbox Downloads]$ rpm -q -a grub\* shim\*
grub2-pc-2.02-81.fc30.x86_64
grub2-pc-modules-2.02-75.fc30.noarch
grub2-efi-ia32-cdboot-2.02-81.fc30.x86_64
grub2-tools-extra-2.02-81.fc30.x86_64
grub2-efi-ia32-2.02-81.fc30.x86_64
grub2-tools-2.02-81.fc30.x86_64
shim-ia32-15-8.x86_64
grub2-efi-x64-cdboot-2.02-81.fc30.x86_64
grubby-8.40-31.fc30.x86_64
grub2-tools-2.02-75.fc30.x86_64
shim-x64-15-8.x86_64
grub2-pc-modules-2.02-81.fc30.noarch
grub2-tools-minimal-2.02-81.fc30.x86_64
grub2-efi-x64-2.02-81.fc30.x86_64
grub2-tools-efi-2.02-75.fc30.x86_64
grub2-common-2.02-75.fc30.noarch
grubby-8.40-30.fc30.x86_64
grub2-common-2.02-81.fc30.noarch
grub2-tools-minimal-2.02-75.fc30.x86_64
grub2-tools-extra-2.02-75.fc30.x86_64
[alex_trune@fedbox Downloads]$ 

[alex_trune@fedbox Downloads]$ lsblk -o NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT
NAME     SIZE TYPE FSTYPE MOUNTPOINT
sda    931.5G disk        
├─sda1 540.9G part ntfs   
├─sda2     1G part ext4   /boot
├─sda3    70G part ext4   /
├─sda4     1K part        
├─sda5     2G part swap   [SWAP]
└─sda6   315G part ext4   /home
sdb    465.8G disk        
├─sdb1   500M part ntfs   
├─sdb2 464.5G part ntfs   
└─sdb3   850M part ntfs   
sdc    931.5G disk        
└─sdc1 931.5G part ntfs   
sdd      2.7T disk        
├─sdd1   128M part        
└─sdd2   2.7T part ntfs   /media/data_mule
[alex_trune@fedbox Downloads]$ 

[alex_trune@fedbox Downloads]$ grep -e /boot /etc/mtab
/dev/sda2 /boot ext4 rw,seclabel,relatime 0 0

[alex_trune@fedbox Downloads]$ sudo ls /sys/firmware/efi /boot/efi /boot/efi/EFI
[sudo] password for alex_trune: 
ls: cannot access '/sys/firmware/efi': No such file or directory
/boot/efi:
EFI  mach_kernel  System

/boot/efi/EFI:
BOOT  fedora

A typical Fedora installation should automatically create the ESP partition which is mandatory for the EFI boot.
I’m not sure if it is possible to safely create and utilize it when the system is already installed.

So, you have the following options:

  • According to your motherboard manual, disable the EFI boot and switch to the device-based boot order if available.
  • Edit the EFI boot order from the EFI/BIOS if available or from Windows with some external software.
  • Reinstall Fedora in the EFI mode and make sure the ESP partition is created properly, then you can change the boot order from linux.