Conflict between GstVulkan-1.0.gir and gstreamer1-plugins-bad-free-devel-1.18.4-1.fc34.x86_64

Hi all,

So today I tried to upgrade my system from fedora 33 to 34 but i’m facing an issue,

while running sudo dnf system-upgrade download --releasever=34

I got this :
Error: Transaction test error: file /usr/share/gir-1.0/GstVulkan-1.0.gir conflicts between attempted installs of gstreamer1-plugins-bad-free-devel-1.18.4-1.fc34.x86_64 and gstreamer1-plugins-bad-free-devel-1.18.4-1.fc34.i686

My system is up to date and I rebooted before doing the upgrade so I have the latest kernel.

I’m running fedora 33 on a Thinkpad T14, if it may help.

Have a nice day.

1 Like

https://docs.fedoraproject.org/en-US/quick-docs/dnf-system-upgrade/

As per the quick-doc, you can try:

  • use --allowerasing
  • use --allowerasing --best
  • manually remove packages before running dnf system-upgrade (remove with --setopt=keepcache=1 to avoid download everything again later.)
1 Like

Hello,
actually I did that, the first 2 ones gives a conflict with iptables so I used the third one to remove it (see: here).

But the issue persist.
thanks for your answer.

1 Like

The conflict appears not to be between 2 packages but between a file (the .gir one) and a package. I tried to mv the .gir file but it seems to be useless because for the script it’s still here.

Remove the package that owns the file:

sudo rpm -q -f file_name
sudo rpm --nodeps -e package_name
4 Likes

Thanks it worked

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.