Conflict between remi php56 and mysql-workbench fedora 32

Hello,
I have the package remi with php56 in to fedora 32, and It is works. But now I want to install mysql-workbench and I have a conflict with a file from remi php56, like this: The /usr/lib64/libzip.so.5 file in the libzip-1.6.1-1.fc32.x86_64 installation conflicts with the libzip5-1.7.3-1.el7.remi.x86_64 package file.

I tried to remove remi php56 and then install workbenck and it is ok but then I can’t install php56 remi because the same problem…other versions from workbench doesn’t work and in my job we use workbench, so I’m stuck…

Any ideas?
Thank you.

1 Like
dnf -q repolist

What does this say?

epel Extra Packages for Enterprise Linux 7 - x86_64
fedora Fedora 32 - x86_64
fedora-cisco-openh264 Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 32 - x86_64
google-chrome google-chrome
mysql57-community MySQL 5.7 Community Server
nginx nginx repo
remi-php71 Remi’s PHP 7.1 RPM repository for Enterprise Linux 7 - x86_64
remi-php72 Remi’s PHP 7.2 RPM repository for Enterprise Linux 7 - x86_64
remi-safe Safe Remi’s RPM repository for Enterprise Linux 7 - x86_64
rpmfusion-free RPM Fusion for Fedora 32 - Free
rpmfusion-free-updates RPM Fusion for Fedora 32 - Free - Updates
rpmfusion-nonfree RPM Fusion for Fedora 32 - Nonfree
rpmfusion-nonfree-updates RPM Fusion for Fedora 32 - Nonfree - Updates
updates Fedora 32 - x86_64 - Updates
updates-modular Fedora Modular 32 - x86_64 - Updates
vscode Visual Studio Code

Hello.

I don’t see mysql-tools-community package that bundles MySQL Workbench in your repository list. Please install it first. You can download it from here https://dev.mysql.com/downloads/repo/yum/

Regards.

Hi,
I tried that (I did a lot things and maybe wrong) with bad result:

sudo rpm -Uvh mysql-workbench-community-8.0.21-1.fc32.x86_64.rpm
advertencia:mysql-workbench-community-8.0.21-1.fc32.x86_64.rpm: EncabezadoV3 DSA/SHA1 Signature, ID de clave 5072e1f5: NOKEY
error: Error de dependencias:
libpython2.7.so.1.0()(64bit) es necesario por mysql-workbench-community-8.0.21-1.fc32.x86_64
libzip es necesario por mysql-workbench-community-8.0.21-1.fc32.x86_64

And the other result trying to resolve the dependencies:

sudo rpm -Uvh mysql-workbench-community-8.0.21-1.fc32.x86_64.rpm
usr/lib64/libzip.so.5 de la instalación de libzip-1.6.1-1.fc32.x86_64 entra en conflicto con el archivo del paquete libzip5-1.7.3-1.el7.remi.x86_64

This is a package for RHEL/CentOS 7, so that’s not good …

(Emphasis mine) These repos are for CentOS/RHEL, not Fedora. You can simply disable the EPEL repo, it is completely pointless on Fedora. The other three you should replace with the ones for Fedora 32. Then try again.

Unrelated to your issue, but I don’t think you need the NGINX repo - to my knowledge, it does not contain anything that isn’t in Fedora proper & is designed for CentOS/RHEL anyway.

[edit: Even less related, @nullpointer00, that’s a nice console prompt :slight_smile: ]

1 Like

https://github.com/b-ryan/powerline-shell

1 Like

That it’s!
I`ve removed epel and remi centos, then I installed remi for fedora 32 and it works perfect, thx!!!
Regards!

2 Likes

Easier than that:

sudo dnf install powerline

:rofl:

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.