Could not resolve host mirrors.fedoraproject.org. New /etc/systemd/resolved.conf

Hi Guys,

I have installed a new Fedora 33 server. The first thing I do after installation is yum/dnf update. Everything is updated as expected, no problem here. Then I reboot the server for kernel replacement with the new version from the update command. After the server is back online, nothing resolves anymore. I cannot ping any external domain names.

The entries from /etc/resolv.conf file did not change. I can ping the nameservers. I also added google nameservers there and it still doesn’t work. Has anyone encountered this problem and can you help me? Thank you in advance.

What error message do you get? If you use the IP address does that work? What happens if you reboot into the original kernel? These are just a few of the things we may need to know in order to help you.

Yes, because there has changed something. Searching …

Releases/33/ChangeSet - Fedora Project Wiki
Enable systemd-resolved by default.

Try this:
Changing DNS with systemd-resolved | Enovision Notes
/etc/systemd/resolved.conf

This helped. I fixed it. Thank you!

1 Like

Uhh what is we use unbound? Is there a work around?

You can enable DoT in systemd-resolved if that’s your reason.

Was this for me? The only (temporary) workaround is to add something like 8.8.8.8 or 1.1.1.1 to /etc/resolv.conf but this of course disappears on reboot or restart of NetworkManager.