CPU temperature raises high while DNF UPDATE, Fedora34

Hi,

I run a notebook with Fedora 34, actually Kernel Linux 5.12.11-300.fc34.x86_64 x86_64 and a processor ‘Intel Core™ i7-10750H CPU @ 2.60GHz × 12’. Usually the processor runs with a temparatur betweem 50-55 ° Celsius. But when I run a DNF UPDATE, even for small packages, the temperature quickly raises to about 90-95 ° Celsius and the fan runs at high speed. After DNF UPDATE ends then it takes a minute until the processor is at low temperature again.
What causes this? Do I have a chance to prevent this high temperature?

Thanyk you

Usually high temperatures are an indicator of insufficient cooling. Either your fan’s cooling body is not making good contact with the cpu or the fan duct is clogged

1 Like

Hi Florian,

the notebook is pretty new, so I doubt that this behaviour is caused by the hardware (only). Again: I see the high temperature/fan only when using dnf, no matter if I run it via command or via the dnfdragora gui. Esp. when dnf is ‘applying changes to the system’ the temperature rises high. Any other command or application that I can run for testing purposes to see it this is only caused by dnf?

Thank you.

you might try “stress” to run the cpu under load for a time and see what happens.

You can also potentially install lm_sensors and gkrellm to allow continuous monitoring of the system sensors and see in real time what is happening.

1 Like

how best to stress the cpu? I have no idea…

Here is one of many examples: How to Impose High CPU Load and Stress Test on Linux Using 'Stress-ng' Tool

The command to install the utility is

sudo dnf install stress

To run the stress command, use

sudo stress --cpu  8 --timeout 30 

(timeout can be changed).

While running the stress test, you can monitor your fan speed and core temperatures in another terminal window using:

watch -n 2 -d sensors

(sudo dnf install lm_sensors as @computersavvy pointed out, if not yet installed)

What’s the make and model? Maybe others with the same machine have some more insight. Could be too new…?! Are the fans spinning up, when the load increases? Is the BIOS firmware up to date?

I was not aware of ‘stress’. I installed and ran it for 30 seconds. Everything worked as expected: cpu temperature raised to 90° celsius, fans ran at 70-80%, and after the 30 seconds test it took just 10 seconds until cpu temperature came down to 50° celsius and fan at 10%. Seems to be fine for my part. So a highly assume a bug in dnf that stresses the cpu.

I don’t think it is a bug. Dnf does use a lot of cpu during the actual update while unpacking and installing the packages after the download part is complete. If the update is large it can be seen with cpu temps.

1 Like

you could, as a workaround, try to disable delta rpms. that will cause larger downloads but less load on the CPU.

https://dnf.readthedocs.io/en/latest/conf_ref.html#options-for-both-main-and-repo

Anyways, especially with a new machine, the fan should be able to keep the temperature lower that what you report. Maybe update your BIOS firmware and your system, maybe some hardware is not yet fully supported by the kernel?

BTW, dnf keeps my CPU busy as well, but the temperature never rises above 74C. (oldish Thinkpad T440s)

I use a notbook esp. manufactured for Linux: TUXEDO Polaris 17 - Gen1

Again, DNF is the only application that stresses its CPUs. Luckily when I recently upgraded to 5.12.13-300.fc34.x86_64 the cpu temperature did not raise above 65 °C and fan ran low.
I will keep this open and double check with the next kernel upgrade.

1 Like

I just detected that the temperature increases differently depending on the power supply. I tested with stress command: [jojo@fedora ~]$ sudo stress --cpu 12 --timeout 30

In case I run my laptop using battery the CPU temperature the temperature increases about 20 ° C only (from approx. 45° to 65° C) .
In case I run my laptop with power supply the temperature increases about 40-45°C! Strange enough (from approx. 45° up to 85° C). What might cause the different behaviour?

CPU speed.
The cpu is normally throttled when it is running on battery to extend battery life, but is not limited when the power supply is attached.

1 Like

following commands will give you some information about governors available.

cpupower frequency-info --governors
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
ondemand

thany you all hints!

Command ‘cpupower’ can not be found. I checked the repositories, but n/a. But:

[jojo@fedora ~]$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
powersave

I need to correct: saw that cpupower is part of kernel-tools. After having installed I get:

[jojo@fedora ~]$ cpupower frequency-info --governors
analyzing CPU 0:
  available cpufreq governors: performance powersave