Cryptocurrency wallet that really works on Fedora?

Dear Fedora fans, I have been looing for a multi currency wallet which works with Fedora.

Type of Wallet : Hot wallet

Price/Fee Information: User-set miner fees from low to high priority; wallet and exchange fees

Compatible with Hardware Wallets? Yes or No

Number of Supported Coins and Tokens : more is better

Privacy, security and anonymity are required as well as 2FA.

I am looking for a Exodus wallet alternative which includes 2FA.

1 Like

Hi @fedoranewbie This is a request? Maybe someone will take it and develop a wallet? Maybe you?

Well this is a idea really. I started to lock and test Exodus and similar wallets and some of them have qualities mentioned above but non of them work really good with Fedora in my opinion. Furthermore, they are’ open source and when a user installs such a wallet they need to trust the closed code thery are using (e.g. Exodus) .

I could try developing the code for it , it sounds like a fun project.

You can look into this website category and you may find something useful for your need
https://www.privacytools.io/#wallet

1 Like

Hi there,

We store with atomic. The atomic wallet works flawless on fedora, great UI and simple interface too. Highly recommended. Very secure,

They have rpm packages

Not as actively developed as earlier but still good.

Also binance has an rpm backage which is updated almost weekly. Although not a wallet, it a great client and very light for making quick and easy trades.

1 Like

Thankl you both @frankjunior @bennyisaiah , these options work great. Regarding the Atomic wallets performace and review it seems like a solid wallet for a cryptocurrency user. It isn’t fully open source but I understand why, it’s decentralized structure eliminates 2FA so that’s great,it accepts multiple currencies , users solely hold the responsibility of their wallet’s security, t requires precautionary and critical steps to maintain your password and backup phrase safe & secure etc.

The biggest problem with Binance are private keys so that’s a hard NO from me.
And there are also alternatives which are awesome as well , thanks to @frankjunior. If you don’t mind I would like to share your post here .

You are fully allowed till you are promoting foss.

1 Like

This happens when I try to install the said wallet , any ideas ?

1 Like

Yes that can sometimes happen with these sorts of programs.

Here are the steps to install that I recommend.

  1. Open up the folder where your downloaded file, then right click in the folder and click “Open in Terminal”

  2. you should then type

sudo dnf install atomicwallet-2.35.0-176.rpm

  1. Enter your password and hit enter

Well this happened.

$ sudo dnf install atomicwallet-2.35.0-176.rpm

[sudo] password for d4u: 
Fedora 35 - x86_64 - Updates                     11 kB/s |  14 kB     00:01    
Fedora 35 - x86_64 - Updates                    320 kB/s | 1.8 MB     00:05    
Fedora Modular 35 - x86_64 - Updates             24 kB/s |  21 kB     00:00    
Can not load RPM file: atomicwallet-2.35.0-176.rpm.
Could not open: atomicwallet-2.35.0-176.rpm

What version of Fedora are you running ?

Goto the terminal again and please run :

sudo dnf upgrade

then goto the correct directory again type:

cd Downloads

then type

ls

and hit return

copy the red file name it should be

atomicwallet-2.35.0-176.rpm

then type:

sudo dnf install (paste the file name here)

it should be

sudo dnf install atomicwallet-2.35.0-176.rpm

hit enter again

Still the same error appears , I am runing Fedora 35 with the latest updates.

Okay please try this command

please open the terminal and got the downloads folder

show me the output for the command

dir

then try this command

sudo rpm -ivh atomicwallet-2.35.0-176.rpm

Output : sudo rpm -ivh atomicwallet-2.35.0-176.rpm
Next I ran the command and this happens :

Downloads]$ sudo rpm -ivh atomicwallet-2.35.0-176.rpm
Verifying...                         ################################# [100%])
Preparing...                         ################################# [100%])
Updating / installing...
   1:atomic-2.35.0-1                 ################################# [100%])
error: unpacking of archive failed on file /opt/Atomic Wallet/LICENSE.electron.txt;61acc84d: cpio: Digest mismatch
error: atomic-2.35.0-1.x86_64: install failed
1 Like

try this:

Rpm -ivh -nofiledigest atomicwallet-2.35.0-176.rpm

Nope , didn’t work. I also tried lower case rpm.

$ Rpm -ivh -nofiledigest atomicwallet-2.35.0-176.rpm
bash: Rpm: command not found...
Similar command is: 'rpm'
[d4u@C4-34-6B-27-D1-F7 Downloads]$ dir
atomicwallet-2.35.0-176.rpm
[d4u@C4-34-6B-27-D1-F7 Downloads]$ rpm -ivh -nofiledigest atomicwallet-2.35.0-176.rpm
rpm: -nofiledigest: unknown option

I have installed this digital wallet on many systems, not sure why your package has errors with the electron part.

It may have not downloaded correctly. Can you delete that copy and redownload a new version. Retry and see if it fixes it.

Which url did you download from?

This is the link from which I downloaded. The strange thing is that the system doesn’t recognize the files path or if it does it’s unable to open it . I will repeat everything now.

It’s a GPG check error , any suggestions ? Has this happend to you before , maybe ?

$ sudo dnf install atomicwallet-2.35.0-176.rpm

Last metadata expiration check: 4:04:37 ago on Sun 05 Dec 2021 12:32:38 PM CET.
Dependencies resolved.
================================================================================
 Package         Architecture    Version            Repository             Size
================================================================================
Installing:
 atomic          x86_64          2.35.0-1           @commandline           62 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 62 M
Installed size: 247 M
Is this ok [Y/n]: y
Downloading Packages:
Package atomicwallet-2.35.0-176.rpm is not signed
Error: GPG check FAILED

1 Like

Okay there is another easier way to install it

go to Downloads

click Ubuntu

click save

then goto your Download folder in your file explorer.

right click on that file and click “Properties”

then click the “Permission Tab”

then at the bottom where it says “Allow executing file as a program” click the checkbox

Then close that tab and double click the file you downloaded

1 Like