Cryptocurrency wallet that really works on Fedora?

I have reached out to atomic support to get the signature key and report this error. quite odd indeed.

I’ll let you know asap

1 Like

Thank you , I wanted to reachout but I didn’t have an ID . Also , I did try that bu it didn’t work . I will try again for the sake of it .

The AppImage won’t open, and it’s not the first to do so on my system. I tried locating the problem but with-out sucess.

So you have had trouble running app images in the past?

Its possible your system may have trouble running apps that depends on electron.

Can you try installing an app that depends on electron from the software centre say for example VS code or GitKraken. Install the flathub versions

See if those open.

1 Like

It seems so this was the ruselt of the try. The system tries to install the rpm file but it’s unable to. Is it possible that’s the problem is simple as just enabling the right software repository ? I can post the current repository setup.

Okay so what message do you see ? I don’t think that’s the case as those apps generally won’t appear I’d the software repos are not enabled.

Your system is having trouble installing and running any software. What kind of computer are you using?

Please type this command into the terminal

pkcon refresh force

And show me the output.

$ pkcon refresh force
Refreshing cache              [=========================]         
Waiting for authentication    [=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Downloading repository information[=========================]         
Loading cache                 [=========================]         
Querying                      [=========================]         
Loading cache                 [=========================]         
Finished                      [=========================]

Now enter this command

killall gnome-software && gnome-software --verbose

Then type

sudo flathub upgrade

Then show the output

$ sudo flathub upgrade
[sudo] password for d4u: 
Sorry, try again.
[sudo] password for d4u: 
sudo: flathub: command not found

My mistake that should say

sudo flatpak upgrade

$ sudo flatpak upgrade
Looking for updates…
Nothing to do.

You should be able to run without sudo

look at the output of flatpak remotes

if flathub isn’t listed there enable it in the software center or perform the steps here

If it is enabled try doing

flatpak repair

you could also try
flatpak install flathub com.axosoft.GitKraken

to see if it’s something up with the software center.

thanks

1 Like

Did everything and GitKraken isn’t working.

$ flatpak remotes
Name    Options
fedora  system,oci
flathub system
[d4u@meow ~]$ flatpak repair
Working on the system installation at /var/lib/flatpak
[3/17] Verifying flathub:runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/21.[8/17] Verifying flathub:runtime/org.freedesktop.Platform.GL.default/x86_64/21.0[15/17] Verifying flathub:runtime/org.gnome.Platform.Locale/x86_64/41…
Checking remotes...
$ flatpak install flathub com.axosoft.GitKraken

Looking for matches…

com.axosoft.GitKraken permissions:
    ipc                   network        pcsc       pulseaudio
    ssh-auth              x11            dri        file access [1]
    dbus access [2]       tags [3]

    [1] /media, /mnt, /run/media, home, xdg-run/gvfs, xdg-run/gvfsd
    [2] org.freedesktop.Flatpak, org.freedesktop.Notifications,
        org.freedesktop.secrets, org.gtk.vfs, org.gtk.vfs.*
    [3] proprietary


        ID                       Branch    Op   Remote    Download
 1. [✓] com.axosoft.GitKraken    stable    i    flathub   90.2 MB / 96.2 MB

Installation complete.

What shell and desktop are you using?

What happens if you type flatpak run com.axosoft.GitKraken

The desktop is Gnome 41.1. and the shell is Bash.
This is the response :

$ flatpak run com.axosoft.GitKraken
bwrap: Creating new namespace failed: No space left on device
error: ldconfig failed, exit status 256

Post the output of
df -h

Sounds like you may have a full partition

Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        3.8G     0  3.8G   0% /dev
tmpfs           3.9G  129M  3.8G   4% /dev/shm
tmpfs           1.6G  2.1M  1.6G   1% /run
/dev/dm-0       167G  8.2G  158G   5% /
tmpfs           3.9G  3.8M  3.9G   1% /tmp
/dev/dm-0       167G  8.2G  158G   5% /home
/dev/loop1       56M   56M     0 100% /var/lib/snapd/snap/core18/2253
/dev/loop0       43M   43M     0 100% /var/lib/snapd/snap/snapd/14066
/dev/loop6      226M  226M     0 100% /var/lib/snapd/snap/riseup-vpn/172
/dev/loop4       93M   93M     0 100% /var/lib/snapd/snap/session-desktop/192
/dev/loop7       66M   66M     0 100% /var/lib/snapd/snap/gtk-common-themes/1519
/dev/loop3      128K  128K     0 100% /var/lib/snapd/snap/bare/5
/dev/loop2       62M   62M     0 100% /var/lib/snapd/snap/core20/1242
/dev/loop5      219M  219M     0 100% /var/lib/snapd/snap/gnome-3-34-1804/77
/dev/sda1       976M  317M  593M  35% /boot
tmpfs           784M  164K  784M   1% /run/user/1000


Okay now open that app and make sure it runs.

Then type this into the terminal

sudo dnf list installed "*fuse*"

And then this

sudo dnf install fuse-sshfs

Then type

cd Downloads
ls

Show the output

$ ls
atomicwallet-2.35.0-176.AppImage  atomicwallet-2.35.0-176.rpm

Note the AppImage is in green letters while the rpm is in red.

1 Like