Cryptocurrency wallet that really works on Fedora?

localinstall is a deprecated alias, see DNF Command Reference — dnf latest documentation

1 Like

I still uses it and it still works. Last time I used to test installing package above.

But, good to know about that. Thank you.

I agree , no doubt there. What I am trying is to find a wallet which really works on Fedora and is secure so if you can give me an example I can try out using the software repository.Furthermore, I at the moment the community is trying to help me find a solution to why I can’t run flathub in general.

$ sudo dnf --nogpgcheck install atomicwallet-2.35.0-176.rpm
[sudo] password for d4u: 
Last metadata expiration check: 0:59:51 ago on Tue 07 Dec 2021 12:56:54 PM CET.
Dependencies resolved.
================================================================================
 Package         Architecture    Version            Repository             Size
================================================================================
Installing:
 atomic          x86_64          2.35.0-1           @commandline           62 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 62 M
Installed size: 247 M
Is this ok [Y/n]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : atomic-2.35.0-1.x86_64                                 1/1 
Error unpacking rpm package atomic-2.35.0-1.x86_64
  Verifying        : atomic-2.35.0-1.x86_64                                 1/1 
Pipe does not exist (/var/run/fapolicyd/fapolicyd.fifo)
Perhaps fapolicy-plugin does not have enough permissions
or fapolicyd is not running...

Failed:
  atomic-2.35.0-1.x86_64                                                        

Error: Transaction failed
$ sudo dnf localinstall atomicwallet-2.35.0-176.rpm
[sudo] password for d4u: 
Last metadata expiration check: 1:02:19 ago on Tue 07 Dec 2021 12:56:54 PM CET.
Dependencies resolved.
================================================================================
 Package         Architecture    Version            Repository             Size
================================================================================
Installing:
 atomic          x86_64          2.35.0-1           @commandline           62 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 62 M
Installed size: 247 M
Is this ok [Y/n]: y
Downloading Packages:
Package atomicwallet-2.35.0-176.rpm is not signed
Error: GPG check FAILED

Try to run sudo dnf clean all, it will clean all cache then try to install again your package.

1 Like

Just to confirm this is not a problem with the software this is an issue with your system. Just installed atomic again to validate.

[root@fedora Downloads]# dnf install atomicwallet-2.35.0-176.rpm
Last metadata expiration check: 0:57:21 ago on Wed 08 Dec 2021 00:05:16 AEDT.
Dependencies resolved.
================================================================================
 Package         Architecture    Version            Repository             Size
================================================================================
Installing:
 atomic          x86_64          2.35.0-1           @commandline           62 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 62 M
Installed size: 247 M
Is this ok [Y/n]: 
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : atomic-2.35.0-1.x86_64                                 1/1 
  Running scriptlet: atomic-2.35.0-1.x86_64                                 1/1 
  Verifying        : atomic-2.35.0-1.x86_64                                 1/1 

Installed:
  atomic-2.35.0-1.x86_64                                                        

Complete!
[root@fedora Downloads]# 

At this point your system appears to missing some libraries from what I can gather or some dependencies, i.e electron as mentioned earlier. I would consider a fresh reinstall if it is not too difficult.

I do know the dev team very well at atomic and trust the software even though parts of it are closed source. Atomic has a lot the code being based on open source code their are some elements of the security which they have decided for business reasons to keep private.

1 Like

Well thank you for confirming my doubts, I am not really into the idea of reinstalling because I really like the whole system setup I have got done now. If nothing else helps and last resort will be to reinstall.

Hi, by adding value of localpkg_gpgcheck=1 in /etc/dnf/dnf.conf I was able to replicate the problem about GPG check on *.rpm local installation.

The line localpkg_gpgcheck=1 by default should not be present in this /etc/dnf/dnf.conf and the default value should be localpkg_gpgcheck=0.

dnf.conf
[main]
gpgcheck=1
localpkg_gpgcheck=1   <--- here should be the problem
installonly_limit=3
clean_requirements_on_remove=True
best=False
skip_if_unavailable=True

By the way I found this variable from running sudo dnf config-manager --dump. It will show all the configurations.

2 Likes

It seems like it might work, I hope so. I will reboot and try to install a rpm.Wish me luck.

@oprizal Well this happend :

$ sudo dnf --nogpgcheck install atomicwallet-2.35.0-176.rpm
[sudo] password for d4u: 
Last metadata expiration check: 2:30:13 ago on Tue 07 Dec 2021 05:23:33 PM CET.
Dependencies resolved.
================================================================================
 Package         Architecture    Version            Repository             Size
================================================================================
Installing:
 atomic          x86_64          2.35.0-1           @commandline           62 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 62 M
Installed size: 247 M
Is this ok [Y/n]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : atomic-2.35.0-1.x86_64                                 1/1 
Error unpacking rpm package atomic-2.35.0-1.x86_64
  Verifying        : atomic-2.35.0-1.x86_64                                 1/1 
Pipe does not exist (/var/run/fapolicyd/fapolicyd.fifo)
Perhaps fapolicy-plugin does not have enough permissions
or fapolicyd is not running...

Failed:
  atomic-2.35.0-1.x86_64                                                        

Error: Transaction failed

Are you installing fapolicyd before? I don’t know about this package.

Btw, It’s great to customize our security system, but if we didn’t know how it works it will give us lot of trouble. Even in some basic things.

2 Likes

To be honest I am not even sure anymore if my usage of SCAP Workbench to harden the system the reason of the problem because I replicated the conitions on a completelynew system and I was able to download the Atomic wallet. So let me repeat that again I used SCAP Workbench on a different system which also had on in installed Fedora 35 Workbench. So the real question is why can’t install the wallet on here ?

Why disable gpg check for local packages by default?

1 Like

You need to contact the support of “Atomic”, they seem to provide an rpm that doesn’t install. Remember, the software is not open-source…

1 Like

Please run on your system dnf config-manager --dump | grep localpkg_gpgcheck to see your current setting.

2 Likes

@bennyisaiah Did contact them but , no progress there. Also I tried installing software rpms which are open source but still the same error emerges.

The localpkg_gpgcheck line is not in /etc/dnf/dnf.conf on my clean system. It must have been added by the user.

1 Like

indeed thanks for pointing that out, there is a clear difference between the users system and a fresh install. Something has been tampered with in the OS. I have suggested the user reimage his system and reinstall a fresh install of Fedora. I established this quote early on for the new user.

Apparently the user has indeed done this Unable to run flatpaks - #55 by fedoranewbie

So technically it should run now, the GPG signing keys are important security feature which is to validate the integrity of rpm package and without those being validated programs should not be installed even if we deem them from a trusted source, i.e dont trust me. trust the maths of encryption.

I feel compelled to get this program running as that was the goal of this post and further I was the one who recommended the atomic wallet, so I feel responsible.

Let me reiterate there is nothing wrong with the program, we have a lot of experience with it and also speak with the developers regularly, it cannot be installed as the OS running it has not been installed correctly as we can now clearly see it seems.

i should also mention that the misconception here that this program is not open source is not entirely true. it has the vast amount of it open source here :

We don’t run closed source programs as we dont like the idea of being unable to audit and review the codebase. Although, we trust this program and this is the only application that we have that is closed source on our systems (other than zoom and skype for inescapable reasons) that we run because we know the developers and we have experience with it.

Respectfully, I would like to mark this as resolved though I would prefer @augenauf to do so as he is the moderator here.

I would love to see it running on the users system although it seems that may not happen and there are a lot more important and critical issues to have our attention on. I am one to chat too much so perhaps we can put this in the pipeline for later.

1 Like