cut and paste disabled in fedora 30

Which terminal are you using?

In Gnome Terminal I highlight text with mouse and press:
Ctrl-Shift-C to copy.
Ctrl-Shift-P to paste.
Ctrl-Shift-X to cut.

1 Like

Thanks for your reply.
Gnome terminal or whatever comes up when I select Terminal from the Cinnamon desktop. Also fails with “vi”. As described above the failure occurs during the “highlight with mouse”

Today I learn Cinnamon does not have their own terminal.

I do not know if Cinnamon shares GSettings with Gnome.

This is a rather silly question: When you open up Gnome Terminal Preferences, is Enable shortcuts in Shortcuts have a check marked?

I ask as I just spent 15 minutes trying to figure out why a computer would not power on. Hint: it helps if it is plugged in. Sometimes the problem is something simple but overlooked.

1 Like

Thanks for your reply. I will check on your suggestion later today. Being in the computer industry for over 60 years, I’m aware that answers to these problems often are as simple as an option that needs to be changed and be assured I spent several days looking for the answer. And if and when I find the answer I won’t be embarrassed to share it.

Felix

1 Like

The only way I can reproduce your issue is if I disable shortcuts.
Since you are having different experiences between Cinnamon and Gnome makes me think it is GSettings which both use. I would see if Cinnamon or Gnome have different GSettings for Gnome Terminal. It may also be possible if both desktops are installed that they may create issues for one or the other.

1 Like

Just completed an installation of fedora 30 LXDE, and had issues with copy/paste. @stephenadler, I’m assuming you’re in the Workstation, but maybe my solution will give you a hint. I clicked the clipboard icon on the lxpanel:

under Settings, deselect Capture hyperlinks only

under History, deselect Purge history after timeout or select a different Timeout seconds (mine was set at 1)

I copy/paste tested in midori (webbrowser), gedit, xterm, lxterminal, vim, emacs.
As @happycat00 pointed out, the solution might be that simple. Like taking your vehicle to the mechanic because of a loud screeching noise - which he can’t solve - only to find, when arriving home, that the pet cat is missing.

Thanks ptrck4193 Making those changes in Cinnamon appears to correct the problem. It may case another but I will look into it and report on it here.

Your comment reminds me of a story I hope they will allow here. A wife left her family in Alabama to visit Paris for 2 months. 2 weeks later she got a letter that her cat had died. She loved that cat and was very upset. She wrote her husband directing him to give the news more gradually, like “Your cat is on the roof”. Two weeks she got a letter that “Your grandmother is on the roof.”

I am having the same problem (cannot copy and paste anything, or cut and paste either) in Gnome on Fedora 30.

I don’t know if this issue was happening right after install, as I didn’t try using my pc right after installing, rather the first thing I did was install a bunch of other desktops as I only like using Gnome sometimes.

So here’s what I’ve found out:

-The issue does not happen at all in KDE. (When I am running KDE / logged into KDE I have no trouble at all being able to copy and paste and being able to cut and paste in all programs.

-The issue DOES happen regardless of whether Gnome is running on wayland or X.

-I am not able to even select something to copy in Gnome, and cannot use the right click on a link and “copy link location” option in Firefox (it never gets pasted when I try to paste in into a text editor afterward).

The above mentioned “copy link location” option in firefox DOES work fine in KDE.

I researched online quite a bit and found a lot of mentions of using a clipboard manager program to try and resolve this sort of issue when it is happening. … And that led to finding out more information, though not any solution:

What I found out next is that I could not run almost ALL clipboard managers on Gnome successfully, i.e., what would happen most of the time is, when trying to launch whatever clipboard manager (in the terminal within Gnome) it would appear to run the program (without a crash) in the terminal, but with most all clipboard managers, no GUI would EVER appear at all. And yet, weirdly enough, they all work just fine in KDE.

So, having said all that, I won’t say I know enough to say that there is a Gnome problem happening, I will only say I wonder if maybe there is?

Ok more information:
This problem IS happening on LXDE as well, but not on LXQT, tried changed all the settings (withing LXDE) I could relating at all to clipboard, nothing helps. Problem also does not happen when running an icewm session.
So, Gnome and/or GTK related maybe??
Quite a weird issue this is too, I cannot select anything in leafpad (or most programs) when running in Gnome or LXDE, but no problems, in KDE, LXQT, and icewm.
Additionally, when running KATE in Gnome, I CAN select text and the selection does not disappear rapidly like with most all other programs. … But… I STILL CANNOT paste anything back that is copied or cut (even in kate) – unless it is done inhumanly rapidly (i.e., an extremely (and I mean extremely) fast ctrl-x and ctrl-y did succeed). But that is the ONLY way it succeeds, EVEN IN kate!

(and tried tweaking settings with gnome-tweaks, no luck there either (program works but changing the settings does not solve the issue what-so-ever!)

This is a different issue, and is probably because they still use the old “notification icon” way of things which no longer works in Gnome. They all need to update to use the status notification specification. I use parcellite, which has the same issue.

More information:

https://bugzilla.gnome.org/show_bug.cgi?id=785956

https://developer.gnome.org/notification-spec/

I believe this is the solution. The problem I suspected was introduced turned out to be non-existent.

I have added this information to bugzilla report https://bugzilla.redhat.com/show_bug.cgi?id=1714334.

My work around was to reinstall fedora 30 from scratch. The cut and past function works again.

The solution suggested by ptrck4193/ works with Cinnamon and LXDE. Probably works anytime the clipboard icon is available.

What package is that bug filed against? The “Terminal” package is an orphan (has no maintainer), so no one is going to look at that particular bug.

Bug Report 1714334 filed under “Terminal”. It was not clear what terminal came up under Cinnamon. Also, correction made via Clipboard Management and the bug affects more than just “Terminal”.

I think I commented on the bug report already—“terminal” is not a package, and bugs must be filed against specific packages. Otherwise the maintainers will not receive a notification. So, what terminal are you using?

(Anyone else here on Cinnamon who may be able to provide this information? I suspect it’s Gnome-terminal, but I’m not sure)

https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

1 Like

Someone remarked, sometimes the fix is very simple. For me, finding this link solved my problem:

http://irawoodring.net/fedora-xfce4-and-clipit-wayland/

It’s a brief explanation of how an older clipboard manager, “clipit” interferes with current Fedora. So, if had an older installation, see if it’s installed, then remove it. Reboot after removal. The link points to further explanation.

3 Likes

Wish I’d just looked for the answer first. That would have been too easy though. Can confirm that it was the Clipboard manager that I okayed during installation. Once removed copy paste functionality returned everywhere.

2 Likes

Well, it’s like when someone calls the help desk and it looks like there’s some really complicated issue. and it turns out
to be that the power cable is unplugged. It better when it’s a simple thing.

1 Like