Daily updates, no extensions in gnome-shell anymore

After this update today no extensions is able to load anymore on gnome shell

Packages Altered:
    Upgrade  ModemManager-1.16.8-1.fc34.x86_64                                      @updates
    Upgraded ModemManager-1.16.6-1.fc34.x86_64                                      @@System
    Upgrade  ModemManager-glib-1.16.8-1.fc34.x86_64                                 @updates
    Upgraded ModemManager-glib-1.16.6-1.fc34.x86_64                                 @@System
    Upgrade  bind-libs-32:9.16.19-1.fc34.x86_64                                     @updates
    Upgraded bind-libs-32:9.16.18-1.fc34.x86_64                                     @@System
    Upgrade  bind-license-32:9.16.19-1.fc34.noarch                                  @updates
    Upgraded bind-license-32:9.16.18-1.fc34.noarch                                  @@System
    Upgrade  bind-utils-32:9.16.19-1.fc34.x86_64                                    @updates
    Upgraded bind-utils-32:9.16.18-1.fc34.x86_64                                    @@System
    Upgrade  gstreamer1-plugins-bad-free-1.19.1-3.1.18.4.fc34.x86_64                @updates
    Upgraded gstreamer1-plugins-bad-free-1.19.1-2.1.18.4.fc34.x86_64                @@System
    Upgrade  ibus-m17n-1.4.6-1.fc34.x86_64                                          @updates
    Upgraded ibus-m17n-1.4.5-1.fc34.x86_64                                          @@System
    Upgrade  kde-settings-34.7-2.fc34.noarch                                        @updates
    Upgraded kde-settings-34.6-1.fc34.noarch                                        @@System
    Upgrade  libidn2-2.3.2-1.fc34.i686                                              @updates
    Upgraded libidn2-2.3.1-1.fc34.i686                                              @@System
    Upgrade  libidn2-2.3.2-1.fc34.x86_64                                            @updates
    Upgraded libidn2-2.3.1-1.fc34.x86_64                                            @@System
    Upgrade  mutter3.38-libs-3.38.5-1.fc34.x86_64                                   @updates
    Upgraded mutter3.38-libs-3.38.4-1.fc34.x86_64                                   @@System
    Upgrade  onedrive-2.4.13-2.fc34.x86_64                                          @updates
    Upgraded onedrive-2.4.8-3.fc34.x86_64                                           @@System
    Upgrade  qt-settings-34.7-2.fc34.noarch                                         @updates
    Upgraded qt-settings-34.6-1.fc34.noarch                                         @@System
    Upgrade  switchboard-plug-about-6.0.0-1.fc34.x86_64                             @updates
    Upgraded switchboard-plug-about-2.6.3-4.20210218gitcd220ae.fc34.x86_64          @@System
    Upgrade  switchboard-plug-applications-6.0.0-1.fc34.x86_64                      @updates
    Upgraded switchboard-plug-applications-2.1.7-4.20210216git4c86682.fc34.x86_64   @@System
    Upgrade  switchboard-plug-mouse-touchpad-6.0.0-1.fc34.x86_64                    @updates
    Upgraded switchboard-plug-mouse-touchpad-2.4.2-5.20210218gitf2d22e1.fc34.x86_64 @@System
    Upgrade  switchboard-plug-notifications-2.2.0-1.fc34.x86_64                     @updates
    Upgraded switchboard-plug-notifications-2.1.7-4.20210217git6bb9054.fc34.x86_64  @@System
    Upgrade  switchboard-plug-sharing-2.1.5-1.fc34.x86_64                           @updates
    Upgraded switchboard-plug-sharing-2.1.4-4.20210217git2a0eb27.fc34.x86_64        @@System
    Upgrade  switchboard-plug-sound-2.2.7-1.fc34.x86_64                             @updates
    Upgraded switchboard-plug-sound-2.2.6-3.20210215git22b101e.fc34.x86_64          @@System
    Upgrade  syncthing-1.18.0-1.fc34.x86_64                                         @updates
    Upgraded syncthing-1.17.0-1.fc34.x86_64                                         @@System
    Upgrade  systemd-248.6-1.fc34.x86_64                                            @updates
    Upgraded systemd-248.5-1.fc34.x86_64                                            @@System
    Upgrade  systemd-container-248.6-1.fc34.x86_64                                  @updates
    Upgraded systemd-container-248.5-1.fc34.x86_64                                  @@System
    Upgrade  systemd-devel-248.6-1.fc34.x86_64                                      @updates
    Upgraded systemd-devel-248.5-1.fc34.x86_64                                      @@System
    Upgrade  systemd-libs-248.6-1.fc34.i686                                         @updates
    Upgraded systemd-libs-248.5-1.fc34.i686                                         @@System
    Upgrade  systemd-libs-248.6-1.fc34.x86_64                                       @updates
    Upgraded systemd-libs-248.5-1.fc34.x86_64                                       @@System
    Upgrade  systemd-networkd-248.6-1.fc34.x86_64                                   @updates
    Upgraded systemd-networkd-248.5-1.fc34.x86_64                                   @@System
    Upgrade  systemd-oomd-defaults-248.6-1.fc34.x86_64                              @updates
    Upgraded systemd-oomd-defaults-248.5-1.fc34.x86_64                              @@System
    Upgrade  systemd-pam-248.6-1.fc34.x86_64                                        @updates
    Upgraded systemd-pam-248.5-1.fc34.x86_64                                        @@System
    Upgrade  systemd-rpm-macros-248.6-1.fc34.noarch                                 @updates
    Upgraded systemd-rpm-macros-248.5-1.fc34.noarch                                 @@System
    Upgrade  systemd-udev-248.6-1.fc34.x86_64                                       @updates
    Upgraded systemd-udev-248.5-1.fc34.x86_64                                       @@System
    Upgrade  wireshark-1:3.4.7-1.fc34.x86_64                                        @updates
    Upgraded wireshark-1:3.4.6-1.fc34.x86_64                                        @@System
    Upgrade  wireshark-cli-1:3.4.7-1.fc34.x86_64                                    @updates
    Upgraded wireshark-cli-1:3.4.6-1.fc34.x86_64                                    @@System
Scriptlet output:
   1 Glob pattern passed, but globs are not supported for this.
   2 Invalid unit name "syncthing@*.service" escaped as "syncthing@\x2a.service".
1 Like
gsettings set org.gnome.shell disable-user-extensions "false"
gsettings set org.gnome.shell disable-extension-version-validation "true"
3 Likes

Okey it worked, so basically because it changed from 40 to 40.1 ?

2 Likes

Yes—extensions need to include the versions of Gnome-shell that they work with. Please do file issues upstream with the extension developers to let them know.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.