DBus Error, GNOME Software cannot perform updates (Xfce)

I’ve always used CLI for package updates and system upgrades. However, there doesn’t seem to be a way to stage updates for reboot on CLI, AFAIK. But, GNOME Software does this and I want to use it.

However, GNOME Software is broken on my system. I use Xfce DE, but I assume that is not the problem. When I start Software, I get this error:

Sorry, something went wrong:
GDBus.Error:org.freesesktop.DBus.Error.NameHasNoOwner:
Could not activate remote peer.

Then, when I got to the Updates tab, I get an identical error, with the preface “unable to git list of updates”.

I hate PacakgeKit and have disabled parts of it in the past, like, uninstalled it completely. However, it appears to be installed, now. Also, I don’t see what is wrong with DBus; it seems to be running. I switched to DBus-broker, manually, with F29.

Thread 677 is similar, but there was not resolution; a bug was blamed and an update fixed it. That is not my problem. It gives me update notifications for flatpak software, but I cannot do any system updates.

1 Like

Hi @pdestefa—welcome to the community! Please take a look at the informative posts in #start-here if you’ve not yet had a chance.

Before we try anything else, could you try reinstalling Gnome-software to ensure that it is correctly installed along with all dependencies? If you can reboot, and then see if it works that’ll give us a start.

Running it in a terminal with --verbose will give you more information on the error too:

gnome-software --verbose

It’ll also be worth looking at the system logs before you run it, and after to see what other errors if any we run into:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

1 Like

Sure, that was easy to do. I just did dnf reinstall gnome-software. It didn’t update any other packages.

When I start gnome-software, I see these errors in the journal:

jounal output
Aug 19 11:38:31 gnome-software[515509]: disabled plugins: dummy, shell-extensions, repos
Aug 19 11:38:31 dbus-broker-launch[2049]: Activation request for ‘org.freedesktop.PackageKit’ failed.
Aug 19 11:38:31 dbus-broker-launch[2049]: Activation request for ‘org.freedesktop.PackageKit’ failed.
Aug 19 11:38:31 gnome-software[515509]: not GsPlugin error pk-control-error-quark:0: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.
Aug 19 11:38:31 gnome-software[515509]: not handling error failed for action search-provides: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.
Aug 19 11:38:31 systemd[1]: Starting Firmware update daemon…
Aug 19 11:38:31 dbus-broker-launch[2049]: Activation request for ‘org.freedesktop.PackageKit’ failed.
Aug 19 11:38:31 devilspie[3396]: e_sexp_eval: assertion ‘f->tree != NULL’ failed
Aug 19 11:38:31 dbus-broker-launch[2049]: Activation request for ‘org.freedesktop.PackageKit’ failed.
Aug 19 11:38:31 gnome-software[515509]: failed to set proxy: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.
Aug 19 11:38:31 gnome-software[515509]: failed to set proxies: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.
Aug 19 11:38:31 fwupd[515542]: 18:38:31:0828 FuHistory failed to migrate /var/lib/fwupd/pending.db database: Failed to prepare SQL for creating tables: table schema already exists
Aug 19 11:38:32 systemd[1]: Started Firmware update daemon.
Aug 19 11:38:32 dbus-broker-launch[2049]: Activation request for ‘org.freedesktop.PackageKit’ failed.
Aug 19 11:38:32 gnome-software[515509]: not GsPlugin error pk-control-error-quark:0: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.
Aug 19 11:38:32 gnome-software[515509]: not handling error failed for action refresh: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not activate remote peer.
Aug 19 11:38:32 dbus-broker-launch[2049]: Activation request for ‘org.freedesktop.PackageKit’ failed.

I wonder what packages are required by gnome-software. Perhaps I can reinstall them, too? What is pk-control-error-quark?

That would be related to PackageKit, the package manager abstraction Software uses in the background. What does journalctl -b -u packagekit say?

1 Like

Nothing.

$ journalctl -b --since=‘90 days ago’ -u packagekit
– Logs begin at Fri 2019-05-03 18:36:02 PDT, end at Mon 2019-08-19 21:10:02 PDT. –
– No entries –

As I said before, I certainly have fought PackageKit in the past. But it basically has never worked for me, so I don’t know what I should be seeing in the journal. Is this right? What should I see?

Okay, so I see PackageKit daemon lines on my laptop that I run more default than my desktop. Why can’t I find any service or process called packagekit on either system? Where is this daemon???

Aha! masked services don’t show up in ‘list-units’. I turned it off! Let me see if I can unmask the service…

How do you list masked services with systemctl?

Hmm I think it’s still uninstalled, but iirc PackageKit is what manages the offline updates you want. Software is failing with that error because it’s saying that PackageKit’s D-Bus service name has no owner / isn’t available to activate.

(Full system upgrades are available offline via dnf, but that’s another topic.)

Okay, hold the phone. That’s what I really want. Is this a topic here somewhere??? Please link. I wouldn’t bother with packagekit if I could stage updates with DNF.

I think we know why packagekit isn’t running: I disabled it and forgot I had done it.

Let me know about DNF offline updates before I turn PK back on.

Afaik that’s only for full system upgrades though (e.g. F29 -> 30), which is why I said it’s another topic. :sweat_smile:

1 Like

okay, right. I do that. rats.

Okay, I unmasked the service, but I cannot enable it:

$ sudo -i systemctl enable packagekit.service
The unit files have no installation config (WantedBy=, RequiredBy=, Also=, Alias= settings in the [Install] section, and DefaultInstance= for template units). This means they are not meant to be enabled using systemctl.

Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit’s
.wants/ or .requires/ directory.
• A unit’s purpose may be to act as a helper for some other unit which has
a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
D-Bus, udev, scripted systemctl call, …).
• In case of template units, the unit is meant to be enabled with some
instance name specified.

I wonder if I reinstall packagekit now?

What does systemctl status packagekit show for the path, and what does systemctl cat packagekit say?

1 Like

6$ systemctl status packagekit.service
● packagekit.service - PackageKit Daemon
Loaded: loaded (/usr/lib/systemd/system/packagekit.service; static; vendor preset: disabled)
Active: inactive (dead

systemctl cat packagekit.service
# /usr/lib/systemd/system/packagekit.service
[Unit]
Description=PackageKit Daemon
# PK doesn't know how to do anything on ostree-managed systems;
# currently the design is to have dedicated daemons like
# eos-updater and rpm-ostree, and gnome-software talks to those.
ConditionPathExists=!/run/ostree-booted

[Service]
Type=dbus
BusName=org.freedesktop.PackageKit
User=root
ExecStart=/usr/libexec/packagekitd

So, even though the service is disabled, it is running. I see stuff in the journal, now.

Aug 20 06:39:33 PackageKit[954190]: daemon start

Aug 20 06:46:34 PackageKit[954190]: daemon quit
Aug 20 06:46:34 systemd[1]: packagekit.service: Main process exited, code=killed, status=15/TERM
Aug 20 06:46:34 systemd[1]: packagekit.service: Succeeded.

Maybe I should try it now…
Whee! Yeah, it seems to be working now. Although, GNOME Software still gives me an error about GDbus. But, maybe that will go away after reboot or when I login to the DE again.

Sweet! Thanks all. I guess I solved the problem. Let me leave this open for a bit and see if the error goes away. But, then I will mark it solved.

2 Likes

Yeah, okay, I don’t get that error anymore…but I got a new one. I’ll start a new thread. Thanks for the help!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.