Dconf update causes gnome-shell to freeze in Fedora 36

Running sudo dconf update causes gnome-shell to freeze. Can anyone suggest a fix for this?

Thanks!

Is there a reason you are using dconf? I have never needed that for updates, simply using dnf myself for all updates and allowing the system to manage the dconf database.

I would suggest you run dconf in a virtual terminal while logged in as root (or su to root), not a terminal window, since what it affects likely includes the gnome config metadata.

HI @computersavvy ,

I’m trying to make some system-wide changes to the settings on computers at work. After adding the custom dconf keyfiles, I need to run sudo dconf update to update the dconf database according to this article. When I attempt to update the dconf database the gui freezes.

Thanks

Ron H.

That page also suggests you read the dconf man page which might give you some more pointers.

My suggestion, since you would also need to have the user log in again anyway, would be to try the virtual terminal approach I mentioned earlier and see if that works. I am under the impression that the desktop gui may be interfering with dconf (and vice versa) since you are modifying global parameters while logged into the gui. If you don’t already know, the virtual terminal is accessible using ‘ctrl-alt-F3’ (or any F key F3 thru F6)