Dell Latitude 7400 WLAN stops working after firmware update

I’m running Fedora 30 on a Dell Latitude 7400.

Some weeks ago, I did a normal update, and the WLAN stopped working. The adapter simply wasn’t recognised anymore. I worked around the problem by reinstalling all iwl*-firmware as well as linux-firmware* packages from before the update.

I figured that such a problem would obviously be fixed in the next update, so I held back updates of these packages temporarily. It has now been several weeks, and the firmware drivers has been updated, but when I tried the problem still persists.

Is this is a known issue? I’ve searched for any mention of WLAN problems on Fedora and this particular machine, but found nothing.

In the off-chance that no one simply isn’t running Fedora on this machine, what can I do to provide more information to people who may be able to fix it?

For now, everything works fine with the old firmware, but I obviously am going to be hesitant to update to Fedora 31 while this problem persists, since there won’t be any old drivers to install at that point.

3 Likes