Dell XPS (9370) Dummy Audio F37

Since the most recent kernel updates and F37, I have lost audio and have not been able to restore it. Previously audio was never too difficult to resolve with previous Fedora changes on this laptop (XPS 9370) Any suggestions on the below would be greatly appreciated:

dmesg | grep -i snd

[ 10.238810] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380

[ 10.238836] snd_hda_intel 0000:00:1f.3: enabling device (0000 → 0002)

[ 10.239199] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

[ 10.253424] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253443] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253465] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253484] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253506] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253527] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253548] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253568] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253589] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.253610] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005

[ 10.261356] snd_hda_intel 0000:00:1f.3: no codecs initialized

[ 12.726406] usbcore: registered new interface driver snd-usb-audio

inxi -A

Audio:

Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel

Device-2: Realtek USB Audio type: USB driver: snd-usb-audio

Sound API: ALSA v: k6.0.8-300.fc37.x86_64 running: yes

Sound Server-1: PipeWire v: 0.3.60 running: yes

It looks like someone reported that disabling powersave on the sound card worked around the issue.

from bugzilla.kernel.org: 205229#c33:

For me, adding options snd_hda_intel power_save=0 in /etc/modprobe.d/audio_powersave.conf fixed this issue.

Seems like that would be worth a try.

1 Like

Thanks, this did not work. I have also tried some of the other variations of this from previous updates and problems i.e. options snd_hda_intel model=