DHCP client failing to setup gateway address

I tried plugging my new laptop into a local switch for the first time aaand it is all broken - I don’t get a gateway address setup. My old laptop and windows on my new laptop all work fine, but fedora gets an IP address and nothing else. I am a bit baffled!

My home network is ISP router → phsense firewall → netgear switch → wifi AP → laptop - All is OK

but ISP router → phsense firewall → netgear switch → netgear switch → CAT6 → laptop - broken.

I realise the cascaded swwitches shouldn’t be a problem - but you never know!

I am running tagged VLANs between the 2 switches, but the wifi (which I am currently using) and the wired connection are in the same vlan.

I initially had a problem when trying an additional access point plugged into the second switch (to get a better signal than the other AP which is plugged into the first switch. The 2 APs are configured identically (I saved the config on 1 and restored to the other, only changing the management IP address).

It looks a bit like this problem - https://askubuntu.com/questions/767002/dhcp-connection-does-not-set-default-gateway-automatically - but I can’t see any of the files they talk about in this or other similar posts.

here is the output from ifconfig with both wifi and wired connected -

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.33.212  netmask 255.255.240.0  broadcast 192.168.47.255
        inet6 fe80::81be:46e8:47ee:caa9  prefixlen 64  scopeid 0x20<link>
        ether fc:34:97:49:b4:dc  txqueuelen 1000  (Ethernet)
        RX packets 4890  bytes 1410014 (1.3 MiB)
        RX errors 0  dropped 52  overruns 0  frame 0
        TX packets 1477  bytes 120987 (118.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 36  bytes 3516 (3.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 36  bytes 3516 (3.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:3b:e3:15  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.33.227  netmask 255.255.240.0  broadcast 192.168.47.255
        inet6 fe80::5941:e134:2680:f76f  prefixlen 64  scopeid 0x20<link>
        ether b0:7d:64:13:d0:da  txqueuelen 1000  (Ethernet)
        RX packets 60636  bytes 47733349 (45.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 27583  bytes 5482130 (5.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

and here is the output from $ systemd-resolve --status


Global
       Protocols: LLMNR=resolve -mDNS -DNSOverTLS DNSSEC=no/unsupported
resolv.conf mode: stub

Link 2 (enp2s0)
Current Scopes: LLMNR/IPv4 LLMNR/IPv6
     Protocols: -DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported

Link 3 (wlp3s0)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 192.168.32.254
       DNS Servers: 192.168.32.254
        DNS Domain: pootlesplace.com

Link 4 (virbr0)
Current Scopes: none
     Protocols: -DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported

Hi,

Have you tried plugging directly into the pfsense?

Thanks Tom.

Check the output when the issue happens:

ip address show; ip route show table all
nmcli connection show 
PAGER= nmcli connection show id CON_NAME

Fixed it. Looking in the wrong place altogether… I found that wired settings DNS and routes were set to manual, even tho DHCP was turned on. Rather strange as I don’t think I have previously used the wired connection (it’s only a 3 monts since I got this laptop).

Thanks for the suggestions - it did prompt to go around the whole setup again.

1 Like