DHCP does not recognise mac address of interface

If you are here to restrict what interfaces should dhcpd listen on, be aware that dhcpd listens only on interfaces for which it finds subnet declaration in dhcpd.conf.

So, there is no need to specify on which interface DHCP should listen.

Let’s say your host has these IP addresses (please provide ip a command result…):
eth0 192.168.1.1 netmask 255.255.255.0
eth1 192.168.56.1 netmask 255.255.255.0
And you want to configure the DHCP server only on eth0, you need to define

subnet 192.168.1.0 netmask 255.255.255.0 {
   range 192.168.1.20 192.168.1.40;
   ...
}

DHCP server will be active only on the interface that is part of the subnet 192.168.1.0/255.255.255.0, hence eth0. And it will dynamically provide IPs (from 192.168.1.20 to 192.168.1.40) to the clients connected on the same subnet of eth0.
If you need to always assign the same address to a specific client identified by the xx:xx:xx:xx:xx:xx MAC address, you will add this declaration:

host fantasia {
  hardware ethernet xx:xx:xx:xx:xx:xx;
  fixed-address 192.168.1.200;
}

Said that, sorry, but it is still unclear to me what you are trying to achieve. Does your machine already have IP addresses? Do you want to configure you machine as a DHCP server on one interface to assign IPs to other hosts in the same subnetwork?
As far as I can see from the logs in one of your first posts, you have these interfaces: enp8s0f1, enp8s0f0, wls6. I don’t know the network mask, but it seems that they are all on the same subnet 192.168.0.x and you want to configure the DHCP for the 192.168.15.0/255.255.255.0 subnet, and this could not work. Moreover, here, what are you trying to do?

host server {
  hardware ethernet XX:XX:XX:XX:XX:XX;
  fixed-address 192.168.15.1;
}

If you think that this will assign the IP 192.168.15.1 to the machine where the DHCP server is running, you are wrong. You are wrong even if you think that this is the definition of the interface on which the DHCP will bind to.
As said, you should read the DHCP manual and not the Fedora one.

@valve Your dhcpd config uses 192.168.15.x but your interfaces seem to be on 192.168.0.x. I think dhcpd is right to fail. Why are you using 192.168.15.x for dhcp when your interfaces are on 192.168.0.x?

Here’s sortof what seems to happen:

  1. dhcpd starts, enumerates interfaces, detects it’s ip addresses (and subnet ranges)
  2. dhcpd finds a subnet declaration in the dhcpd config
  3. dhcpd checks to which interface that subnet declaration belongs
  4. since your subnet declaration is 192.168.15.x and your interfaces are on 192.168.0.x dhcpd concludes that it’s not configured to listen on any interfaces

Solution: use a subnet declaration that’s similar to the subnet that your preferred interface is on.

2 Likes

Did you find the file /etc/default/isc-dhcp-server?

This is Ubuntu/Debian specific.

Hi patrickl

Your observation is correct, but, that’s only because I plugged that NIC back into my LAN for now.

The error report was the same when that NIC was plugged into an independent switch or left open and assigned a fixed ip

Hi alciregi

Thanks for the detailed answer, there must be something else wrong with a .config somewhere my eyes are terrible, it could be as simple as a typo.

I am not sure I can take a proper look tonight, but will do if I can.

Oh, sorry. I don’t know dhcpd in particular.

Hi benjamind
That’s OK, I don’t either, thanks for trying to help.

Hi,
Thanks to all who tried to help! Very much appreciated!

Thanks very much.

Today I investigated a few routes to work out what to do, and it is a loose plan, but I kept coming across dead links, outdated and incorrect information etc., so, eventually, I decided to make a switch on this machine to Scientific Linux.

I still use Fedora daily as my desktop, at work and at home.

But, given the issues I experienced recently with SELinux, on its own, and its interaction with Systemd, together with the reality that, somewhere down the line, I am going to experience real problems again due to these kinds of issues, I decided to go for a RHEL based distro on this server hardware.

All it takes is one dodgy update and my kids will come down the stairs with flames coming out of their ears!

What I wanted to do is better served by a solid base and a few VMs on top anyway. I think I was expecting too much. It’s not that I am lacking power, apart from in my own knowledge.

Anyway, thanks again!

By the way, SL is a very nice distro and boots to a desktop faster than Fedora did to the CLI.

Oh, by the way, my day job is as physicist/materials scientist/electronic engineer so, I always wanted to use SL anyway!

One more thing, before I leave. This happened to me, just the other day:

I was out riding cross country with my son, and we took a detour off the normal bridle paths and came out of the fields onto a country lane.

As we were taking a drink from our water bottles, getting our bearings a guy came strolling up, on foot, obviously having walked a long way, carrying a heavy bag.

He came up to us and asked for directions to the local, to that area, church, and could I direct him to it.

He’d obviously slogged it, on foot, miles, from the town train station, and was heading to a village church, obviously poorly prepared for the distance, and particularly, the terrain involved.

What did I say to him? Buy yourself a map and read it?

No, I didn’t.

Fedora is upstream for SL. The boot process could be quicker for any number of reasons: fewer services starting up than the Fedora Workstation (which is made for a different target audience than SL) is probably one of them.

Anyway, the all important question of course: did moving to SL solve your problem? If it did, please document the solution for the benefit of others.

So what did you say to him?

Do you know if he reached his destination?

Did you know the way to the church?
What would you have said if you didnt?

Is he always going to be fortunate enough to find someone to show him the way?

Would it be better to ensure that the town train station had a map for visitors?

@valve please, read this thread again. I asked you some clarifications and your answers are only complaints without giving clarifications on what you are trying to achieve (at least I haven’t figured it out yet) and without giving detailed informations (please provide the output of ip a command…)

Please have a look to Helping your helpers and How To Ask Questions The Smart Way.
You can’t pretend that someone here will explain to you how things work from scratch or that someone will write the configuration for you (in addition without detailed informations). Instead, with a collaborative approach, you can be helped in finding resources, in looking at the starting points, you can receive assistance in the identification of the errors, but then is up to you in learning and finding a solution that fit your goals.

Hi alciregi

No, I don’t need to re read my posts, they were written as part of a thread, and, once again you are deferring to ‘read the manual’ which is patronising.

I very much appreciate your input, but, it wasn’t sufficient to solve my problem, and, I found the experience here off putting and exclusive.

Hi FransicoD

I spent some time with my phone, and luckily I had my glasses with me, to direct him to his destination.

No, I didn’t know the way, I had to find it.

I would have found the way for him, regardless.

My son and I would have ridden with him all the way there, apart from the fact that we couldn’t, because mountain bikes aren’t allowed in that area, and because he insisted we didn’t.

It’s a rural train station, he was in the middle of nowhere. Miles from the station. I invite you there, and hope you meet us.

The point here is about not being an asshole about something which is pretty insignificant, but trying to be clever about it.

DHCP is not about solving Schroedinger’s equation. It’s far more mundane and boring, which is why I wanted a simple answer to it.

Hi FranscoD

Yes, I believe it solved my problem:

Because SL7 is based on RHEL and is maintained be people with the same mindset and goals as myself. I feel I can talk to a scientist about it if I have a problem.

I created a VM and installed Sophos XG, which is doing absolutely everything I required, and more.

That leaves me to use the rest of the power of this machine to do other things, and, most importantly, leaves my brain to do other things other than read manuals on Linux or comply with abstract forum rules.

I looked for a solution on this route, and it failed, so I found another way which works.

Thanks for your help anyway.

You are right, everyone should go with the solution that works for their needs. Even if any software like isc-dhcp will work the same way in any GNU/Linux distribution.

However, talking about Scientific Linux, are you aware that it will be discontinued? https://itsfoss.com/scientific-linux-discontinued/

Excerpt from the developers announce: “[…] we will deploy CentOS 8 in our scientific computing environments rather than develop Scientific Linux 8. […] Fermilab will continue to support Scientific Linux 6 and 7 through the remainder of their respective lifecycles.”

Hi alciregi

I apologise If I was harsh and blunt. It’s unfortunate that you came into my experience after I’d already endured many battles to do with SELinux and Systemd interaction before I even got here.

SELinux, that monster can take a working system down with a simple update, and it happened to me, twice, and I wasted two entire weekends of my life over what is ultimately poor implementation.

And, if I may say, that thing which we rely on to harden our Linux kernels, is the very thing which could take half the world’s servers down. It controls absolutely everything, created by our friends, the NSA.

No need to attack anything other than SELinux, and issue a policy which makes all hard drives inaccessible. Goodnight Vienna.

In the case of DHCP, you are very probably correct, I haven’t verified it to work in my system, but I accept that you are. I don’t know enough to say otherwise, I’m simply relying on my experience.

SL7, well, yes, indeed it will be discontinued, but, not until 2024, that’s enough time for me.

I don’t know if you spent any time recently searching, using Google and such, for answers about Fedora? Most of what you’ll find are dead links. Or about ancient Fedoras.

Take a look at FreeBSD or OpenBSD documentation. I’m not totally au fait with those OS, but, it’s a model of how it should be done.

Computer science, at its core, is an incredibly complex subject, now, add in what is, in it’s essence, an exclusive jargon, about configuration scripts etc. It’s not even about being smart, or about solving problems, it’s just about remembering some kind of syntax.

There is no logic about it, it’s not like physics, or mathematics. It’s about entering something in a field without a ; and it doesn’t work, and then you get someone shove a manual in your face because you don’t know why it makes any difference.

And, what am I supposed to do? Burn incense at the alter of Linux and pray for forgiveness and hope to receive knowledge from above?

That’s what it seems like these forums are about.

I mean, honestly, how can we progress if students entered mathematics and science forums and they got shot down about the concepts of calculus, gravitation, redox reactions, let alone higher concepts, over punctuation, and punctuation which is no-one can agree about and which varies dependent upon the situation?

It’s worse than politics…