Disable OOM Killer

Hello, everyone!

I have been using Fedora for a long time but in the two last versions (F36 and F37), I am getting a lot of trouble. For some reason, when I am executing an application (in F37) that requires all the processor capability (memory and CPU), gnome kills suddenly the application. I read there is a process called OOM killer that kills the applications when the system is on low memory. My question is how to disable it. I tried to add two instructions “vm.oom-kill=0” and “vm.overcommit_memory=2” at “/etc/sysctl.conf” but the system becomes worse, firefox does not open, and some processes do not work. What can I do?

Thanks!

1 Like

See How to switch off systemd's out-of memory killer daemon - #2 by augenauf

4 Likes