Disabling radeon driver somehow did not enable amdgpu

I followed this guide to disable the radeon driver How to permanently disable radeon driver, after disabling it, somehow the amdgpu driver isn’t being used, and the gpu module in lspci -k shows no driver as “in use”

Hi, not all GPUs are supported by both radeon and amdgpu drivers (basically only 1st and 2nd gen GCN devices) and that’s not how to switch between them.
What’s your GPU? Post here output of inxi -G or relevant part of lspci -k.
Why are you trying to disable radeon driver?

the amdgpu driver is more macron ig, this is an R9 270X it’s volcanic islands
i also need to use vulkan for lutris and yuzu

I don’t understand that, plus one word brings up the worst connotations, so let’s cut to the chase :wink:

This is 1st gen GCN, that’s how you switch to amdgpu and enable vulkan support: Random freezes on fedora 36 with AMD GPU - #12 by ozeszty
Oh and undo everything you did so far to block radeon driver, just in case.

modern not macron my bad
im in the process of undoing everything right now, thanks!