Discover error on boot, 'Failed to update 1 package'

,

Basically the same error on this post Discover "Offline Updates" "could not resolve host name for mirrors fedoraproject, same error message:

Failed to update 1 package
cannot update repo 'fedora': Cannot prepare internal mirrorlist: 
Curl error (6): 
Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-35&arch=x86_64 
[Could not resolve host: mirrors.fedoraproject.org]; Last error: Curl error (6): 
Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-35&arch=x86_64 
[Could not resolve host: mirrors.fedoraproject.org] 

And the same behavior of “Repair System” button, but if I open Discover i can update almost without problems.

On the answer suggested to change the local resolvers assuming that they’re talking about dns, I’m using a pi-hole to manage dns petitions but never get a petition when the pc starts up.

So I’m thinking of disabling the “offline updates” feature, I don’t have a problem with update before turn off my pc or there is a way to debug this with Discover? or how you update all the packages that aren’t updated when use dnf? flatpak packages can be updated with ‘flatpak update’ but for the updates of others packages like themes of kde that shows on discover, there exist a command to do that?

1 Like

You might show us the output of resolvectl to see the config of it.

If the package is installed from one of the standard fedora or synced repos, then a dnf update --refresh will update all that are current in the repo. Flatpaks are separate by design since they are not an ‘official’ fedora product and not managed by dnf.

I have never allowed the system to do the offline update since it reminds me too much of MS habits.

ok, the output of the command is:

Global
       Protocols: LLMNR=resolve -mDNS -DNSOverTLS DNSSEC=no/unsupported
resolv.conf mode: stub

Link 2 (enp2s0)
Current Scopes: none
     Protocols: -DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported

Link 3 (wlp3s0)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 192.168.10.109
       DNS Servers: 192.168.10.109

Today when I power up the pc, the error shows again:
image

And on the registers of Pi-hole, there is not a petition to mirrors.fedoraproject.org at the time when the pc starts up:

After about 5 minutes Discover show another popup saying that there are updates available and now pi-hole have received the petition to mirrors.

There is a way to disable the first popup error or delay the search of new updates at least 10 min or something like that?

yes, update with dnf works ok, is discover updates that shows the popup error on every start of the pc.

Since was announced as new feature I wanted to try it, so maybe I’ll back to the old way of update my system and uninstalling again Discover.

After searching I came to the conclusion that you can’t get rid of that warning and is something that happens so randomly that I disabled offline updates and just update with dnf and flatpak commands and use discover only to update addons disabling all the sources.

For the Addons section of discover updates you can’t use any command to update Update KDE addons/widgets/themes through CLI? - #3 by 0tter - Kde Plasma - Manjaro Linux Forum, and yes already tried pkcon update but can’t update addons:

[root@fedora ~]# pkcon update
Getting updates               [=========================]         
Finished                      [=========================]         
Starting                      [=========================]         
Testing changes               [=========================]         
Finished                      [                         ] (0%)  
The following packages have to be installed:
 libappindicator-gtk3-12.10.0-31.fc35.x86_64    Application indicators library - GTK 3
 libdbusmenu-gtk3-16.04.0-18.fc35.x86_64        Library for passing menus over DBus - Development files - GTK+2 version - GTK+3 version
 libindicator-gtk3-12.10.1-21.fc35.x86_64       GTK+3 build of libindicator
The following packages have to be updated:
 VirtualBox-6.1.32-5.fc35.x86_64        A general-purpose full virtualizer for PC hardware
 VirtualBox-kmodsrc-6.1.32-5.fc35.noarch        VirtualBox kernel module source code
 VirtualBox-server-6.1.32-5.fc35.x86_64 core part (host server) for VirtualBox
 discord-0.0.17-4.fc35.x86_64   All-in-one voice and text chat for gamers
Proceed with changes? [N/y]