Discover, the KDE application installation utility, only displays Flatpaks

I have been using Fedora 34 Jam for a couple months now, and have noticed that Discover only displays Flatpaks. Hence, I have only been using dnf to install software from the command line. Is there some way I can make Discover work correctly? Please note that another post (Only Flatpak apps being shown in Discover on Fedora 33 KDE Spin) was made on this topic in December, but there was no subsequent discussion that I saw.
Will appreciate the help.

1 Like

Yes, You can enable the other repositories by clicking settings and the choose your repo to show all applications.

1 Like

Yes, the repos have been enabled as you have indicated. However, nothing appears in the application descriptions except flatpaks, so I am at a loss as far as installing rpms via Discover. That is, unless I use dnf or dnfdragora. Updates work, however. Have you any ideas of what is going wrong?

Ok, that’s occurred.
But a few checks you can try:
Make Sure the repository are selected and set as default.
Make Sure about gpg key signature.
Try update the system via terminal.

I tested it via my main system as well as VM (Testing Repo), in both that works flawlessly.
Can you please run this application via terminal by typing “plasma-discover” and show/debug the log.

The appropriate repositories have been selected and set as default. I have no problems updating the system via terminal (i.e., sudo dnf upgrade --refresh). I don’t know how to check the gpg key signature, but will be glad to if you tell me how. I ran "plasma-discover’ via terminal, and tried to see applications a bit, and then closed the Discover window. The log in the terminal is as follows:

[astauss@fedora ~]$ plasma-discover
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
invalid kns backend! “/usr/share/knsrcfiles/servicemenu.knsrc” because: “Config group not found! Check your KNS3 installation.”
kf.newstuff.core: The ChecksumPolicy feature is defunct
kf.newstuff.core: The SignaturePolicy feature is defunct
kf.newstuff.core: The ChecksumPolicy feature is defunct
kf.newstuff.core: The SignaturePolicy feature is defunct
adding empty sources model QStandardItemModel(0x562a28aac8c0)
org.kde.plasma.libdiscover: Couldn’t find a category for “fwupd-backend”
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:74:5: QML Binding: Binding loop detected for property “value”
qrc:/qml/ApplicationsListPage.qml:16:1: QML ApplicationsListPage: Binding loop detected for property “implicitHeight”
kf.kirigami: The Theme singleton is deprecated (since 5.39). Import Kirigami 2.2 or higher and use the attached property instead.
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
[astauss@fedora ~]$

Your statement that Discover works flawlessly, both on your main system and on a VM brought to mind another detail. I have two computers that do this, and I installed the Fedora 34 Jam Spin on both of them from the iso. It may be possible we have a packaging issue on this iso?
Please let me know what you think about a solution. And thank you so much for the help!

Ok Ok.

Lets do some modification in your config.
In terminal(as user),
Step 1: Type “nano $HOME/.config/mimeapps.list”
Step 2: Find [Default Applications] section.
Step 3 : Add bellow lines,

x-scheme-handler/appstream=org.kde.discover.desktop
application/x-rpm=org.kde.discover.desktop
application/vnd.flatpak=org.kde.discover.desktop
application/vnd.flatpak.repo=org.kde.discover.desktop
application/vnd.flatpak.ref=org.kde.discover.desktop

Save the file and reboot.
Then Open plasma-discover and see if the result showing as bellow.
Thanks.

Thanks, Roy, but I modified the file as you indicated, and I rebooted, but I still only see flatpaks displayed in Discover. Here is the file with modifications (just in case I messed up something)

[Default Applications]
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop
x-scheme-handler/chrome=firefox.desktop
text/html=firefox.desktop
application/x-extension-htm=firefox.desktop
application/x-extension-html=firefox.desktop
application/x-extension-shtml=firefox.desktop
application/xhtml+xml=firefox.desktop
application/x-extension-xhtml=firefox.desktop
application/x-extension-xht=firefox.desktop
x-scheme-handler/appstream=org.kde.discover.desktop
application/x-rpm=org.kde.discover.desktop
application/vnd.flatpak=org.kde.discover.desktop
application/vnd.flatpak.repo=org.kde.discover.desktop
application/vnd.flatpak.ref=org.kde.discover.desktop

And here are my results when using Discover:

[astauss@fedora ~]$ plasma-discover
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
invalid kns backend! “/usr/share/knsrcfiles/servicemenu.knsrc” because: “Config group not found! Check your KNS
3 installation.”
kf.newstuff.core: The ChecksumPolicy feature is defunct
kf.newstuff.core: The SignaturePolicy feature is defunct
kf.newstuff.core: The ChecksumPolicy feature is defunct
kf.newstuff.core: The SignaturePolicy feature is defunct
adding empty sources model QStandardItemModel(0x5633f7a9c3f0)
org.kde.plasma.libdiscover: Couldn’t find a category for “fwupd-backend”
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:74:5: QML Binding: Binding loo
p detected for property “value”
qrc:/qml/ApplicationsListPage.qml:16:1: QML ApplicationsListPage: Binding loop detected for property “implicitH
eight”
kf.kirigami: The Theme singleton is deprecated (since 5.39). Import Kirigami 2.2 or higher and use the attached
property instead.
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
qrc:/qml/ApplicationsListPage.qml:126: TypeError: Cannot read property ‘application’ of null
[astauss@fedora ~]$ ^C
[astauss@fedora ~]$

Have you any other suggestions?

Many thanks for your help with this!

I’m not sure who I have to thank for this, but I just had something interesting happen. After undoing Roy’s suggestions above, I went on doing all of my software management from the command line for the last twelve days or so. Today, just for the heck of it, I opened Discover and, lo and behold (!), it works correctly, displaying software from all enabled repositories. Undoubtedly, an update did the trick, but I have no specific idea about the source of my good fortune. Many thanks to whomever, and consider this thread closed!