Displaylink and Fedora 35

Hi

I have installed Fedora 35 on my Lenovo Ideapad 3 (15ACL6). i want to use my Laptop with my Thinkpad USB-C Dock Gen 2 but it seams that it is not possible to start the displaylink service. On the github repository that i found I found RPM packages for displaylink adapted with the evdi library for fedora 34, but this drivers do not works with Fedora 35.

Has anyone some experince with the setup of displaylink and Fedora 35? Do anyone knows when the drivers for Fedora 35 are available? Is there a workaround?

I have also tried to checkout the evdi devel code and build it by my own, but always when I try to autoisntall the modules with dkms (“sudo dkms autoinstall”), I get some build errors and I realy do not understand why.

Hello @kavdacin welcone.
on displaylink-1.9.1-1.fc34.x86_64.rpm Fedora 34 Download No mention of update.
On Releases · displaylink-rpm/displaylink-rpm · GitHub you could ask for a solution. (write an issue)

Try using the Fedora 35 negativo17 multimedia repo. There is a DisplayLink package there that worked for me. Be aware. This repo is not compatible with rpmfusion.

It worked for me like this:

  1. Add RPM Fusion repositories to your system https://fedora.pkgs.org/36/rpm-sphere-x86_64/evdi-1.10.1-1.x86_64.rpm.html

  2. Download latest rpmsphere-release rpm from

https://github.com/rpmsphere/noarch/tree/master/r
  1. Install r_rpmsphere-release rpm:
# rpm -Uvh r_rpmsphere-release*rpm
  1. Install evdi rpm package:
# dnf install evdi
  1. Download and extract the Ubuntu driver
https://support.displaylink.com/knowledgebase/articles/683482-displaylink-support-for-ubuntu-now-available
  1. Install the driver
chmod +x  displaylink-driver-*.run
sudo ./displaylink-driver*.run

You can ignore the message WARNING: This is not an officially supported distribution.