Dnf Skipping packages with conflicts

Skipping packages with conflicts when i update os

Problem 1: package telegram-desktop-2.4.7-3.fc33.x86_64 requires qt5-qtbase(x86-64) = 5.15.1, but none of the providers can be installed

  • cannot install both qt5-qtbase-5.15.2-2.fc33.x86_64 and qt5-qtbase-5.15.1-7.fc33.x86_64
  • cannot install both qt5-qtbase-5.15.1-5.fc33.x86_64 and qt5-qtbase-5.15.2-2.fc33.x86_64
  • cannot install the best update candidate for package telegram-desktop-2.4.7-3.fc33.x86_64
  • cannot install the best update candidate for package qt5-qtbase-5.15.1-7.fc33.x86_64
    Problem 2: problem with installed package telegram-desktop-2.4.7-3.fc33.x86_64
  • package telegram-desktop-2.4.7-3.fc33.x86_64 requires libQt5Gui.so.5(Qt_5.15.1_PRIVATE_API)(64bit), but none of the providers can be installed
  • cannot install both qt5-qtbase-gui-5.15.2-2.fc33.x86_64 and qt5-qtbase-gui-5.15.1-7.fc33.x86_64
  • cannot install both qt5-qtbase-gui-5.15.1-5.fc33.x86_64 and qt5-qtbase-gui-5.15.2-2.fc33.x86_64
  • cannot install the best update candidate for package qt5-qtbase-gui-5.15.1-7.fc33.x86_64

any fix?

Try removing qt5-qtwebengine-freeworld (this package seems to be the problem) and then run dnf update.
Finally, install Telegram.

Different packages seem to want different versions of same dependency

1 Like