Dnf system-upgrade fails to change anything

sudo dnf system-upgrade log



Have you downloaded them successfully with wget? I’ve tried to look up some mirrors for them, but couldn’t find any. I myself downloaded them successfully several times in the past – but that has more to do with the state of our respectful internet connections and server loads at the time of downloads than anything deterministic.

1 Like

Yes thanks, I did get a dl. I think that problem was that there was not enough disk space for the iso and FFx was giving up silently without showing what was going on. It looked like the server was not sending.

wget started OK and I checked disk space before it actually became a problem and made some room. I have not done the checksum yet and I’m a bit busy to try the live boot just now. Looks OK though.

1 Like

No that did not work out too well. The checksum verified, I dd’d it to a USB key and booted. It said "invalid isolinux.bin " and said it was booting from CD :? It then posted NVidia related msg and started doing DHCP hook-up. I’m guessing that was PXE boot attempts.

/isolinux/isolinux.bin is on the image if I mount it.

I’ll try another ISO but this looks like another day going down the toilet.

OK, more problems. Looks like my system does not want to boot of the key . I burned the image to CD and it boots fine. LXQT seems to run without obvious issues on the limited s/w that comes with the live image. This gives me enough confidence to run the upgrade if only the damned thing would actually complete.

@federic, I’ve tested dd’ing F30-LXQT-x86_64-LIVE-20191009.iso to usb drive and booting from it both is UEFI and BIOS/Legacy mode. It worked for me.

Which doesn’t help you much, I guess. :slight_smile:

Thanks, I was not thinking it was faulty iso image. It is probably some oddity with the BIOS on this laptop ( not using UEFI ). I don’t think h/w coverage is 100%.

I opened a bug on bugzilla about this but most bugs seems to die at hands of EOL robots in my experience.

I may have to do a fresh installation which will really piss me off. Having to redo all the installations and configurations I’ve done since F23 is going to be a pain.

I just recalled that I have an out of tree Geany build as well and the cross-debugger only works with qt4. That may be enough reason to at least keep this partition as a dual boot because that is something I need to retain.

1 Like