Dnf update error on fedora 32 with 'fedora-cisco-openh264' repo

Hey guys I’m having this problem shown in the picture dnf-update-error-2020-05-21 with fedora 32. This was not a problem with fedora 31.
Things I’ve tried and didn’t help:

  • Download ISO multiple different times since the 32 release
  • Use Fedora Media Writer
  • Install Fedora 31 and upgrade to Fedora 32
  • Using a virtual machine
  • Using live session
  • Installing on hardware

I created the bootable ISO using GNOME-disks and Fedora-Media-Writer.
I really want to switch to Fedora but this problem keeps me from it. It persists since launch of the 32 release.

Appreciate any help! Thanks!

PS. here is the repo file:

    [liveuser@localhost-live ~]$ cat /etc/yum.repos.d/fedora-cisco-openh264.repo 
    [fedora-cisco-openh264]
    name=Fedora $releasever openh264 (From Cisco) - $basearch
    metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-$releasever&arch=$basearch
    type=rpm
    enabled=1
    metadata_expire=14d
    repo_gpgcheck=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
    skip_if_unavailable=True

    [fedora-cisco-openh264-debuginfo]
    name=Fedora $releasever openh264 (From Cisco) - $basearch - Debug
    metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-debug-$releasever&arch=$basearch
    type=rpm
    enabled=0
    metadata_expire=14d
    repo_gpgcheck=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
    skip_if_unavailable=True
    [liveuser@localhost-live ~]$

Hello and welcome to the forum.

What happens if you run this?

sudo dnf clean all; sudo dnf --refresh check-update

Hi, and thanks!
Nothing changes unfortunately.

And what do you get if you run
nslookup mirrors.fedoraproject.org
?

[liveuser@localhost-live ~]$ sudo !!
sudo nslookup mirrors.fedoraproject.org
Server:		192.168.0.1
Address:	192.168.0.1#53

Non-authoritative answer:
mirrors.fedoraproject.org	canonical name = wildcard.fedoraproject.org.
Name:	wildcard.fedoraproject.org
Address: 152.19.134.142
Name:	wildcard.fedoraproject.org
Address: 85.236.55.6
Name:	wildcard.fedoraproject.org
Address: 209.132.181.15
Name:	wildcard.fedoraproject.org
Address: 209.132.190.2
Name:	wildcard.fedoraproject.org
Address: 152.19.134.198
Name:	wildcard.fedoraproject.org
Address: 209.132.181.16
Name:	wildcard.fedoraproject.org
Address: 67.219.144.68
Name:	wildcard.fedoraproject.org
Address: 8.43.85.67
Name:	wildcard.fedoraproject.org
Address: 140.211.169.206
Name:	wildcard.fedoraproject.org
Address: 185.141.165.254
Name:	wildcard.fedoraproject.org
Address: 2610:28:3090:3001:dead:beef:cafe:fed3
Name:	wildcard.fedoraproject.org
Address: 2605:bc80:3010:600:dead:beef:cafe:fed9
Name:	wildcard.fedoraproject.org
Address: 2620:52:3:1:dead:beef:cafe:fed7
Name:	wildcard.fedoraproject.org
Address: 2620:52:3:1:dead:beef:cafe:fed6
Name:	wildcard.fedoraproject.org
Address: 2604:1580:fe00:0:dead:beef:cafe:fed1
Name:	wildcard.fedoraproject.org
Address: 2001:4178:2:1269::fed2

[liveuser@localhost-live ~]$

I have to admit that I’m at a loss here.
If you run this
dnf --disablerepo=fedora-cisco-openh264 reinstall fedora-repos
and then do the whole “clean all” and “–refresh check-update” dance, does it get any better?

Im afraid it is still the same… :frowning:
Its very strange. I have no Idea whats wrong… Everything seems fine but I still get this error.
No one else seems to have a similar problem either. I’m very confused!
Thanks for the Help anyways!

Could you please file a bug against fedora-repos to see if someone more knowledgeable could be of more help?

Someone filed a similar bug. I think I’m having the same problem:

https://bugzilla.redhat.com/show_bug.cgi?id=1844087

Did bypassing mirrormanager solve your problem?

Yes it did.
In the file /etc/yum.repos.d/fedora-cisco-openh264.repo, I commented out the metalink=... line and inserted below:

baseurl=https://codecs.fedoraproject.org/openh264/$releasever/$basearch/

It solved the error message when updating. No idea if the openh264 thing works as intended though. I just installed the proprietary codecs from rpm-fusion.

You can follow these instructions to check.

Thanks a lot!
Should I flag this tread as solved or not? I’m unsure since the solution is more like a workaround…

There is nothing else for users to do, this is a bug caused by the combination of being in specific geographic locations and mirrormanager’s code.

You can mark your comment above as the solution and edit it adding a reference to the bug for the people who are too lazy to scroll through this thread…

Solution as described here:
https://bugzilla.redhat.com/show_bug.cgi?id=1844087

In the file /etc/yum.repos.d/fedora-cisco-openh264.repo, I commented out the metalink=... line and inserted below:

baseurl=https://codecs.fedoraproject.org/openh264/$releasever/$basearch/

and refresh with:
sudo dnf clean all && sudo dnf update

To check if openh264 works follow these instructions:
https://fedoraproject.org/wiki/OpenH264#Installation_from_fedora-cisco-openh264_repository

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.