Dnf update error

Hi all!

LANG=C dnf update
Last metadata expiration check: 0:20:03 ago on Sun Apr 25 09:22:13 2021.
Dependencies resolved.

Problem 1: cannot install the best update candidate for package gst-0.7.4-3.fc34.noarch

  • nothing provides python3-pyxdg >= 0.27 needed by gst-0.7.5-2.fc34.noarch
    Problem 2: cannot install the best update candidate for package gwe-0.15.2-2.fc34.noarch
  • nothing provides python3-pyxdg >= 0.27 needed by gwe-0.15.3-1.fc34.noarch
    Problem 3: pipewire-0.3.25-1.fc34.i686 has inferior architecture
  • cannot install both pipewire-0.3.26-1.fc34.x86_64 and pipewire-0.3.25-1.fc34.x86_64
  • cannot install both pipewire-0.3.25-1.fc34.x86_64 and pipewire-0.3.26-1.fc34.x86_64
  • cannot install the best update candidate for package pipewire-0.3.25-1.fc34.x86_64
  • cannot install the best update candidate for package pipewire-0.3.25-1.fc34.i686
    Problem 4: problem with installed package pipewire-0.3.25-1.fc34.i686
  • package pipewire-0.3.25-1.fc34.i686 requires pipewire-libs(x86-32) = 0.3.25-1.fc34, but none of the providers can be installed
  • cannot install both pipewire-libs-0.3.26-1.fc34.i686 and pipewire-libs-0.3.25-1.fc34.i686
  • cannot install both pipewire-libs-0.3.25-1.fc34.i686 and pipewire-libs-0.3.26-1.fc34.i686
  • cannot install the best update candidate for package pipewire-libs-0.3.25-1.fc34.i686

What is the best solution?

1 Like

Clean DNF cache and remove duplicates if any:

sudo dnf clean all
sudo dnf remove --duplicates

If the issue persists, post the output:

sudo dnf --showduplicates list pipewire pipewire-libs
1 Like

dnf remove --duplicates

Error: No duplicated packages found for removal

dnf --showduplicates list pipewire pipewire-libs
Last metadata expiration check: 0:03:08 ago on Sun Apr 25 15:36:55 2021.
Installed Packages
pipewire.i686 0.3.25-1.fc34 @updates-testing
pipewire.x86_64 0.3.25-1.fc34 @updates-testing
pipewire-libs.i686 0.3.25-1.fc34 @updates-testing
pipewire-libs.x86_64 0.3.25-1.fc34 @updates-testing
Available Packages
pipewire.i686 0.3.25-1.fc34 fedora
pipewire.x86_64 0.3.25-1.fc34 fedora
pipewire.x86_64 0.3.26-1.fc34 updates
pipewire-libs.i686 0.3.25-1.fc34 fedora
pipewire-libs.x86_64 0.3.25-1.fc34 fedora
pipewire-libs.i686 0.3.26-1.fc34 updates
pipewire-libs.x86_64 0.3.26-1.fc34 updates

1 Like

I can not upgrade after closing the update halfway for checksum mismatch - #2 by ilikelinux

1 Like

Just manually remove the i686 packages. How did they get there in the first place?

1 Like

It’s a typical dependency for Steam.

I encountered the same issue and I ended up removing pipewire-0.3.25-1.fc34.i686 and pipewire-0.3.25-1.fc34.i686 packages (and Steam).

Once that was done, I was able to update these packages.
pipewire-pulseaudio-0.3.26-1.fc34.x86_64.rpm
pipewire-0.3.26-1.fc34.x86_64.rpm
pipewire-alsa-0.3.26-1.fc34.x86_64.rpm
pipewire-gstreamer-0.3.26-1.fc34.x86_64.rpm
pipewire-utils-0.3.26-1.fc34.x86_64.rpm
pipewire-libs-0.3.26-1.fc34.x86_64.rpm

I was then able to reinstall Steam along with the i686 packages that were still required.

Hi there,

I had the same issue. I solved it just by removing the i686 package and then update. Didn’t need to reinstall Steam. (i686 package was reinstalled, but newer version)

2 Likes

Thx, really work!