Dnf update fails. "Failed: tpm2-abrmd-2.2.0-2.fc31.x86_64 tpm2-abrmd-2.2.0-4.fc31.x86_64"

Hey,
I’m having some trouble with dnf update, here’s what I’m getting:

[pekka@nostromo ~]$ sudo dnf update
Copr repo for wireguard owned by jdoss          4.4 kB/s | 6.0 kB     00:01    
Fedora 31 openh264 (From Cisco) - x86_64        8.3 kB/s | 5.1 kB     00:00    
Fedora Modular 31 - x86_64                      4.2 MB/s | 5.2 MB     00:01    
Fedora Modular 31 - x86_64 - Updates            3.3 MB/s | 3.8 MB     00:01    
Fedora 31 - x86_64 - Updates                    7.1 MB/s |  19 MB     00:02    
Fedora 31 - x86_64                              7.4 MB/s |  71 MB     00:09    
RPM Fusion for Fedora 31 - Free tainted         2.3 kB/s | 2.2 kB     00:00    
RPM Fusion for Fedora 31 - Free - Updates       403 kB/s | 308 kB     00:00    
RPM Fusion for Fedora 31 - Free                 693 kB/s | 663 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Steam      2.0 kB/s | 1.7 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree tainted       10 kB/s | 5.1 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Updates    127 kB/s |  59 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree              389 kB/s | 241 kB     00:00    
Dependencies resolved.

 Problem 1: package qt5-qtwebengine-freeworld-5.12.6-1.fc31.x86_64 requires qt5-qtbase(x86-64) = 5.12.5, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.13.2-1.fc31.x86_64 and qt5-qtbase-5.12.5-2.fc31.x86_64
  - cannot install both qt5-qtbase-5.12.5-1.fc31.x86_64 and qt5-qtbase-5.13.2-1.fc31.x86_64
  - cannot install the best update candidate for package qt5-qtwebengine-freeworld-5.12.6-1.fc31.x86_64
  - cannot install the best update candidate for package qt5-qtbase-5.12.5-2.fc31.x86_64
 Problem 2: problem with installed package qt5-qtwebengine-freeworld-5.12.6-1.fc31.x86_64
  - package qt5-qtwebengine-freeworld-5.12.6-1.fc31.x86_64 requires libQt5Gui.so.5(Qt_5.12.5_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtbase-gui-5.13.2-1.fc31.x86_64 and qt5-qtbase-gui-5.12.5-2.fc31.x86_64
  - cannot install both qt5-qtbase-gui-5.12.5-1.fc31.x86_64 and qt5-qtbase-gui-5.13.2-1.fc31.x86_64
  - cannot install the best update candidate for package qt5-qtbase-gui-5.12.5-2.fc31.x86_64
================================================================================
 Package               Architecture  Version               Repository      Size
================================================================================
Upgrading:
 tpm2-abrmd            x86_64        2.2.0-4.fc31          updates        109 k
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase            x86_64        5.12.5-1.fc31         fedora         3.5 M
 qt5-qtbase            x86_64        5.13.2-1.fc31         updates        3.5 M
 qt5-qtbase-gui        x86_64        5.12.5-1.fc31         fedora         5.9 M
 qt5-qtbase-gui        x86_64        5.13.2-1.fc31         updates        5.8 M

Transaction Summary
================================================================================
Upgrade  1 Package
Skip     4 Packages

Total download size: 109 k
Is this ok [y/N]: y
Downloading Packages:
tpm2-abrmd-2.2.0-4.fc31.x86_64.rpm              1.2 MB/s | 109 kB     00:00    
--------------------------------------------------------------------------------
Total                                           348 kB/s | 109 kB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Running scriptlet: tpm2-abrmd-2.2.0-4.fc31.x86_64                         1/1 
  Running scriptlet: tpm2-abrmd-2.2.0-4.fc31.x86_64                         1/2 
  Upgrading        : tpm2-abrmd-2.2.0-4.fc31.x86_64                         1/2 
error: lsetfilecon: (/usr/sbin/tpm2-abrmd;5e2d51c8, system_u:object_r:tabrmd_exec_t:s0) Invalid argument
error: Plugin selinux: hook fsm_file_prepare failed

Error unpacking rpm package tpm2-abrmd-2.2.0-4.fc31.x86_64
  Verifying        : tpm2-abrmd-2.2.0-4.fc31.x86_64                         1/2 
  Verifying        : tpm2-abrmd-2.2.0-2.fc31.x86_64                         2/2 

Skipped:
  qt5-qtbase-5.12.5-1.fc31.x86_64        qt5-qtbase-5.13.2-1.fc31.x86_64       
  qt5-qtbase-gui-5.12.5-1.fc31.x86_64    qt5-qtbase-gui-5.13.2-1.fc31.x86_64   

Failed:
  tpm2-abrmd-2.2.0-2.fc31.x86_64         tpm2-abrmd-2.2.0-4.fc31.x86_64        

Error: Transaction failed
error: lsetfilecon: (/usr/sbin/tpm2-abrmd;5e2d51c8, system_u:object_r:tabrmd_exec_t:s0) Invalid argument
error: Plugin selinux: hook fsm_file_prepare failed

Possible related:

See this post.

RedHat docs: Troubleshooting SELinux.

I tried doing this:

[pekka@nostromo ~]$ sudo restorecon -Rv /home/pekka/.cert/

Got no errors (in fact, got no feedback at all), but didn’t fix the issue.

Of course it didn’t, sorry.
“lsetfilecon” tries to set some SEL flags on /usr/sbin/tpm2-abrmd. But gets an “invalid argument”.

I’d posted the above as some reference. It isn’t the solution, i’m sorry.

2 Likes

I don’t see a bug filed against either package:

So, I’d think it’s worth filing. The maintainer should be able to shed some light on what’s happening here. In the meantime, please skip this package update using --exclude=tpm2-abrmd and so on.

https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

2 Likes