Dnf update nvidia error

LANG=C dnf update 
Last metadata expiration check: 0:50:03 ago on Tue Aug 25 20:35:02 2020.
Dependencies resolved.

 Problem 1: package akmod-nvidia-3:450.66-1.fc32.x86_64 requires nvidia-kmod-common >= 3:450.66, but none of the providers can be installed
  - cannot install the best update candidate for package akmod-nvidia-3:440.100-1.fc32.x86_64
  - package xorg-x11-drv-nvidia-3:450.66-1.fc32.x86_64 is filtered out by modular filtering
 Problem 2: cannot install both xorg-x11-drv-nvidia-cuda-libs-3:450.66-1.fc32.x86_64 and xorg-x11-drv-nvidia-cuda-libs-3:440.100-1.fc32.x86_64
  - package xorg-x11-drv-nvidia-cuda-3:440.100-1.fc32.x86_64 requires xorg-x11-drv-nvidia-cuda-libs(x86-64) = 3:440.100-1.fc32, but none of the providers can be installed
  - cannot install the best update candidate for package xorg-x11-drv-nvidia-cuda-libs-3:440.100-1.fc32.x86_64
  - problem with installed package xorg-x11-drv-nvidia-cuda-3:440.100-1.fc32.x86_64
 Problem 3: cannot install both xorg-x11-drv-nvidia-libs-3:450.66-1.fc32.x86_64 and xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.x86_64
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires libnvidia-glcore.so.440.100()(64bit), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires libnvidia-tls.so.440.100()(64bit), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires xorg-x11-drv-nvidia-libs(x86-64) = 3:440.100-1.fc32, but none of the providers can be installed
  - cannot install the best update candidate for package xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.x86_64
  - problem with installed package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64
 Problem 4: package xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.x86_64 requires (xorg-x11-drv-nvidia-libs(x86-32) = 3:440.100-1.fc32 if mesa-libGL(x86-32)), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires libnvidia-glcore.so.440.100()(64bit), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires libnvidia-tls.so.440.100()(64bit), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires xorg-x11-drv-nvidia-libs(x86-64) = 3:440.100-1.fc32, but none of the providers can be installed
  - cannot install both xorg-x11-drv-nvidia-libs-3:450.66-1.fc32.i686 and xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.i686
  - package kmod-nvidia-5.7.14-200.fc32.x86_64-3:440.100-1.fc32.x86_64 requires nvidia-kmod-common >= 3:440.100, but none of the providers can be installed
  - cannot install the best update candidate for package xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.i686
  - cannot install the best update candidate for package mesa-libGL-20.1.6-1.fc32.i686
  - problem with installed package kmod-nvidia-5.7.14-200.fc32.x86_64-3:440.100-1.fc32.x86_64
  - package xorg-x11-drv-nvidia-3:450.66-1.fc32.x86_64 is filtered out by modular filtering
 Problem 5: package xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.x86_64 requires libnvidia-fatbinaryloader.so.440.100()(64bit), but none of the providers can be installed
  - cannot install both xorg-x11-drv-nvidia-cuda-libs-3:450.66-1.fc32.x86_64 and xorg-x11-drv-nvidia-cuda-libs-3:440.100-1.fc32.x86_64
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires libnvidia-glcore.so.440.100()(64bit), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires libnvidia-tls.so.440.100()(64bit), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 requires xorg-x11-drv-nvidia-libs(x86-64) = 3:440.100-1.fc32, but none of the providers can be installed
  - xorg-x11-drv-nvidia-cuda-libs-3:450.66-1.fc32.i686 has inferior architecture
  - package kmod-nvidia-5.7.15-200.fc32.x86_64-3:440.100-1.fc32.x86_64 requires nvidia-kmod-common >= 3:440.100, but none of the providers can be installed
  - cannot install the best update candidate for package xorg-x11-drv-nvidia-cuda-libs-3:440.100-1.fc32.i686
  - problem with installed package kmod-nvidia-5.7.15-200.fc32.x86_64-3:440.100-1.fc32.x86_64
  - package xorg-x11-drv-nvidia-3:450.66-1.fc32.x86_64 is filtered out by modular filtering
==========================================================================================================================================================================================================
 Package                                                    Architecture                        Version                                      Repository                                              Size
==========================================================================================================================================================================================================
Upgrading:
 google-chrome-stable                                       x86_64                              85.0.4183.83-1                               google-chrome-unstable                                  67 M
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 xorg-x11-drv-nvidia-cuda-libs                              x86_64                              3:450.66-1.fc32                              rpmfusion-nonfree-updates                               24 M
 xorg-x11-drv-nvidia-libs                                   i686                                3:450.66-1.fc32                              rpmfusion-nonfree-updates                               19 M
 xorg-x11-drv-nvidia-libs                                   x86_64                              3:450.66-1.fc32                              rpmfusion-nonfree-updates                               62 M
Skipping packages with broken dependencies:
 akmod-nvidia                                               x86_64                              3:450.66-1.fc32                              rpmfusion-nonfree-updates                               26 k

Transaction Summary
==========================================================================================================================================================================================================
Upgrade  1 Package
Skip     4 Packages

Total download size: 67 M
Is this ok [y/N]: n
Operation aborted.

What is the problem, how to solve it?

Hello @idanka
If your system is not in English, error messages are difficult to understand.
So, in order to help people to better help you, please refer to this post: How to make my terminal speak english?

In addition, to make your post more clear and simple to read, you should consider to format system outputs as Preformatted text.
Thanks.

1 Like

Sorry, and thx!
(repaired)

1 Like

Do you have the nvidia drivers installed from rpmfusion, and also have the cuda repo enabled? You may need to exclude certain packages in the cuda repo, as mentioned here: https://rpmfusion.org/Howto/CUDA#Which_driver_Package

It looks like it’s filtering out xorg-x11-drv-nvidia. Can you run $ sudo dnf module list --disabled to see if that module is disabled?

Thx

CUDA Toolkit

If you are sticking to RPM Fusion, use this for simplicity. :smiley:

1 Like

Thx t0xic0der!
I prefer not to install Cuda and Machine Learning.
There is always a problem (nvidia driver) with it.

t0xic0der nvidia tools, no problem? (nvidia driver, cuda, machine learning)

2 Likes

Understandable.

Also, many many happy returns of the day, @idanka! :smiley:

2 Likes