DNF Upgrade fuse-common error

Hi there,

I’m having a problem after running sudo dnf upgrade.
Everything went fine, except the package fuse-common didn’t got upgraded. Now i have the following output when i run sudo dnf upgrade:

Letzte Prüfung auf abgelaufene Metadaten: vor 0:13:45 am Mo 27 Mai 2019 12:34:39 CEST.
Abhängigkeiten sind aufgelöst.

 Problem: package fuse-2.9.9-3.fc30.x86_64 requires fuse-common = 3.4.2, but none of the providers can be installed
  - cannot install both fuse-common-3.5.0-1.fc30.x86_64 and fuse-common-3.4.2-6.fc30.x86_64
  - cannot install both fuse-common-3.4.2-3.fc30.x86_64 and fuse-common-3.5.0-1.fc30.x86_64
  - cannot install the best update candidate for package fuse-common-3.4.2-6.fc30.x86_64
  - cannot install the best update candidate for package fuse-2.9.9-3.fc30.x86_64
===================================================================================================================================================================================================================
 Package                                              Architecture                                    Version                                               Repository                                        Size
===================================================================================================================================================================================================================
Pakete mit Konflikten werden übersprungen:
(fügen Sie »--best --allowerasing« zur Befehlszeile hinzu, um die Aktualisierung zu erzwingen):
 fuse-common                                          x86_64                                          3.4.2-3.fc30                                          fedora                                            19 k
 fuse-common                                          x86_64                                          3.5.0-1.fc30                                          updates                                          7.4 k

Transaktionsübersicht
===================================================================================================================================================================================================================
Überspringen  2 Pakete

Nichts zu tun.
Fertig.

Running with the proposed options --best --allowerasing generates the following output, but doesn’t solve my problem.

Letzte Prüfung auf abgelaufene Metadaten: vor 0:19:21 am Mo 27 Mai 2019 12:34:39 CEST.
Fehler: 
 Problem: cannot install the best update candidate for package fuse-2.9.9-3.fc30.x86_64
  - problem with installed package fuse-2.9.9-3.fc30.x86_64
  - package fuse-2.9.9-3.fc30.x86_64 requires fuse-common = 3.4.2, but none of the providers can be installed
  - cannot install both fuse-common-3.5.0-1.fc30.x86_64 and fuse-common-3.4.2-6.fc30.x86_64
  - cannot install both fuse-common-3.4.2-3.fc30.x86_64 and fuse-common-3.5.0-1.fc30.x86_64
  - cannot install the best update candidate for package fuse-common-3.4.2-6.fc30.x86_64
  - problem with installed package fuse-common-3.4.2-6.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

--skip-broken does also not solve the problem.

3 Likes

I am experiencing the same issue.

I am confident it will be fixed soon.

DNF will not update the package since doing so would leave your system in a broken state. --skip-broken simply skips the problematic packages.

This particular issue seems to be known:

https://bugzilla.redhat.com/show_bug.cgi?id=1714065

As the bug says, the update should fix it:

https://bodhi.fedoraproject.org/updates/?packages=fuse

You can either wait for the update to hit the stable repositories, or grab it from updates-testing (and provide feedback for the update). More on this here:

2 Likes

Hi,

On Fedora 30 I get the following error when I run my daily system update;

sudo dnf upgrade --refresh
...
 Problem: package fuse-2.9.9-3.fc30.x86_64 requires fuse-common = 3.4.2, but none of the providers can be installed
  - cannot install both fuse-common-3.5.0-1.fc30.x86_64 and fuse-common-3.4.2-6.fc30.x86_64
  - cannot install both fuse-common-3.4.2-3.fc30.x86_64 and fuse-common-3.5.0-1.fc30.x86_64
  - cannot install the best update candidate for package fuse-common-3.4.2-6.fc30.x86_64
  - cannot install the best update candidate for package fuse-2.9.9-3.fc30.x86_64

I tried to run the following command and here is the result:

sudo dnf upgrade --refresh --best --allowerasing
Error: 
 Problem: cannot install the best update candidate for package fuse-2.9.9-3.fc30.x86_64
  - problem with installed package fuse-2.9.9-3.fc30.x86_64
  - package fuse-2.9.9-3.fc30.x86_64 requires fuse-common = 3.4.2, but none of the providers can be installed
  - cannot install both fuse-common-3.5.0-1.fc30.x86_64 and fuse-common-3.4.2-6.fc30.x86_64
  - cannot install both fuse-common-3.4.2-3.fc30.x86_64 and fuse-common-3.5.0-1.fc30.x86_64
  - cannot install the best update candidate for package fuse-common-3.4.2-6.fc30.x86_64
  - problem with installed package fuse-common-3.4.2-6.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Should I try to run the above command with the suggested --skip-broken? It sounds like this would only bypass the problem, not solve it.

1 Like

The update has been release. It’s all fixed now. :slight_smile:

2 Likes