Dnf upgrade to fedora 35 beta; no sound device

dnf upgrade to fedora 35 beta; no sound device is present;
how to include/upload alsa-info.txt?

Check if you see an error while execute the following commands in terminal:

systemctl --user status "pipewire.*"
if pipewire socket and service active (running) = ok.

systemctl --user status "pipewire-pulse.*"
if pipewire-pulse socket and service active (running) = ok.

and last but not least you should see also:
systemctl --user status wireplumber

2 Likes

garberw@electron> systemctl --user status pipewire.*
● pipewire.socket - Multimedia System
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-10-17 11:11:57 PDT; 3h 21min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket

Oct 17 11:11:57 electron systemd[4400]: Listening on Multimedia System.

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Sun 2021-10-17 11:12:01 PDT; 3h 21min ago
TriggeredBy: ● pipewire.socket
   Main PID: 4836 (pipewire)
      Tasks: 2 (limit: 38079)
     Memory: 1.6M
        CPU: 36ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─4836 /usr/bin/pipewire

Oct 17 11:12:01 electron systemd[4400]: Started PipeWire Multimedia Service.
garberw@electron> systemctl --user status pipewire-pulse.*

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: disabled)
     Active: active (running) since Sun 2021-10-17 11:12:01 PDT; 3h 22min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 4837 (pipewire-pulse)
      Tasks: 2 (limit: 38079)
     Memory: 6.5M
        CPU: 35ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─4837 /usr/bin/pipewire-pulse

Oct 17 11:12:01 electron systemd[4400]: Started PipeWire PulseAudio.
Oct 17 11:16:11 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.857367 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:12 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.728985 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:13 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.607974 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:14 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.384612 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:14 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.043923 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:14 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.007508 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:14 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.000000 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:14 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.000000 ], "channels": [ "MONO" ] }, Operation not supported
Oct 17 11:16:14 electron pipewire-pulse[4837]: mod.protocol-pulse.stream-restore: failed to set metadata restore.stream.Output/Audio.media.role:Notification = { "mute": false, "volumes": [ 0.000000 ], "channels": [ "MONO" ] }, Operation not supported

● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-10-17 11:11:57 PDT; 3h 22min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket

Oct 17 11:11:57 electron systemd[4400]: Listening on PipeWire PulseAudio.

garberw@electron> systemctl --user status wireplumber
β—‹ wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
garberw@electron> systemctl --user enable --now wireplumber
Created symlink /home/garberw/.config/systemd/user/pipewire.service.wants/wireplumber.service β†’ /usr/lib/systemd/user/wireplumber.service.
garberw@electron> systemctl --user status wireplumber
● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-10-17 14:38:35 PDT; 7s ago
   Main PID: 27010 (wireplumber)
      Tasks: 5 (limit: 38079)
     Memory: 9.0M
        CPU: 1.459s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─27010 /usr/bin/wireplumber

Oct 17 14:38:35 electron systemd[4400]: Started Multimedia Service Session Manager.
garberw@electron> 

that fixed it. must have been enabling wireplumber. did not have to log out or anything.

should notify package maintainer to enable by default.
thank you :smile:

2 Likes

Dear @garberw,

just for the records: how have you enabled wireplumber? I encountered the same problem and added a new file as ~/.config/autostart/wireplumber.desktop with the following content:

[Desktop Entry]
Exec=/usr/bin/wireplumber
Icon=
Name=wireplumber
Path=
Terminal=False
Type=Application

But I wonder if there is a easier way to do…

Kind regards,

aanno

Dear aanno: do not do that please. Instead try

systemctl --user enable --now wireplumber
. If that does not work it must be a systemwide service so omit the β€œβ€“user”.

2 Likes

There’s also now Common F35 bugs - Fedora Project Wiki

The Bugzilla bug is 2016253 – wireplumber not enabled automatically

You should quote in all cases. Bash passes through the * if it didn’t match anything, but if there were a file that matched pipewire.* in the current directory, it would pass that name instead.