DNS client for Fedora?

Hi, I am looking for a privacy , security and user friendly DNS client. All recommendations and suggestions are welcomed.
I found these , NextDNS and AdGuardDNS .

Can you clarify what you are trying to do please?

If you just want to use a specific DNS provider, you can set this information up for each network in the Network Settings. For example:

1 Like

Well I am trying to setup a encrypted DNS. So I am looking for a secure and user friendly way to do it . I tried a few but not all of them so I am looking for some advice from the community.

Why not run your own DNS, like PiHole?

2 Likes

Sure if you want privacy you need to use something dns over tls or https or DNSCrypt

Easy to setup is tls and https
My recommendations are
quad9(hosted in Switzerland)
Nextdns advance but hosted in us
Adguard there public dns is good and they are planing to implement something like next dns

Some independent provider not so big
1 https://blahdns.com/ ads and tracker blocks by default
Opensourced https://github.com/ookangzheng/blahdns
2 Libredns https://libredns.gr/ open sourced LibreOps · GitLab

If you want to set up dns over tls infedora
/etc/systemd/resolved.conf (sudo required) remove # from the changes.
You can edit this file and put yours.
If you want something more
https://coredns.io/ selfhosted(expert) dns
Or if you want to use pihole it is also a good option to have in a docker podman or native f35 maybe not officially supported native
Selfhost dnscrypt https://github.com/DNSCrypt/dnscrypt-proxy/wiki/How-to-setup-your-own-DNSCrypt-server-in-less-than-10-minutes
https://github.com/DNSCrypt/dnscrypt-proxy/wiki/Installation-linux

2 Likes

https://fedoraproject.org/wiki/Changes/DNS_Over_TLS

Also, using systemd-resolved:

There’s also this topic:

2 Likes

I don’t have a Raspberry Pi at the moment near me to buy. So this would be a short- term solution. And the PiHole will be a long-term one.

Yes pihole can be hosted in a vps also
Look into my reply i have provided you details that i know and maybe possible to provide.

1 Like

Great , I will check it out , thank you all for the help.

I tried following the steps from the Fedora Magazine article. But I can’t /etc/NetworkManager/conf.d from the step two. Can anybody assist me ?

You can’t what? You need to use sudo etc. to modify files in these directories.

I also have set up mine in my kubuntu and fedora i didn’t need to do the step 2.i restarted and it was working fine.

1 Like

This is how my cat /etc/systemd/resolved.conf looks :

$ cat /etc/systemd/resolved.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it under the
#  terms of the GNU Lesser General Public License as published by the Free
#  Software Foundation; either version 2.1 of the License, or (at your option)
#  any later version.
#
# Entries in this file show the compile time defaults. Local configuration
# should be created by either modifying this file, or by creating "drop-ins" in
# the resolved.conf.d/ subdirectory. The latter is generally recommended.
# Defaults can be restored by simply deleting this file and all drop-ins.
#
# Use 'systemd-analyze cat-config systemd/resolved.conf' to display the full config.
#
# See resolved.conf(5) for details.

[Resolve]
# Some examples of DNS servers which may be used for DNS= and FallbackDNS=:
# Cloudflare: 1.1.1.1#cloudflare-dns.com 1.0.0.1#cloudflare-dns.com 2606:4700:4700::1111#cloudflare-dns.com 2606:4700:4700::1001#cloudflare-dns.com
# Google:     8.8.8.8#dns.google 8.8.4.4#dns.google 2001:4860:4860::8888#dns.google 2001:4860:4860::8844#dns.google
# Quad9:      9.9.9.9#dns.quad9.net 149.112.112.112#dns.quad9.net 2620:fe::fe#dns.quad9.net 2620:fe::9#dns.quad9.net
DNS=9.9.9.9
#FallbackDNS=
#Domains=
DNSSEC=yes
DNSOverTLS=yes
#MulticastDNS=no
#LLMNR=resolve
#Cache=yes
#CacheFromLocalhost=no
#DNSStubListener=yes
#DNSStubListenerExtra=
#ReadEtcHosts=yes
#ResolveUnicastSingleLabel=no

Why you are putting details just remove the # from quad9 one

DNS=9.9.9.9#dns.quad9.net
DNS=149.112.112.112#dns.quad9.net
DNS=2620:fe::fe#dns.quad9.net
DNS=2620:fe::9#dns.quad9.net
1 Like

It seems I am a bit tired :joy: :joy: :joy: , I just saw what I did there.

1 Like

I am unable to upload a screenshot for some reason. But when i test my connection here the mesage is : NO
You are NOT using quad9
If you would like to learn more about using quad9, you can view our guides at:

Reboot system it should start

1 Like

OK , thank you. When I read reboot I though it was to reboot the Network manager.