DNS resolution problem with fedora 33

Hi after the upgrade to fedora 33 the VPN (openconnect) does not resolve the DNS addresses anymore.
I know of the switch to systemd-resolved, but event thought i am setting apparently the right dns as shown from the output:
➜ resolvectl domain
Global:
Link 2 (wlp58s0): ~.
Link 3 (virbr0):
Link 4 (virbr0-nic):
Link 6 (tun0): corp.company.com

Global: 10.x.x.21 10.x.x.21
Link 2 (wlp58s0): 8.8.8.8 1.1.1.1
Link 3 (virbr0):
Link 4 (virbr0-nic):
Link 6 (tun0): 10.x.x.21 10.x.x.21

The dns servers are assigned to the tun0 which is the vpn network interface but those are not called for some reason.
Am i misconfiguring something?

thanks

2 Likes

It should be similar to the following:
F33 DNS from VPN is not longer in use after upgrad

1 Like

It should be similar, but actually turning off systemd-resolv or doing what you suggested in one of the linked post:
sudo nmcli connection modify id tun0
ipv4.dns-search ~. ipv6.dns-search ~.
ipv4.dns-priority -50 ipv6.dns-priority -50

does not seems to work, a part from the fact that my vpn seems to not support ipv6 in some way, that command for me does not change resolve config.
Maybe i am looking for changes in the wrong place?

No, another connection name, see:

nmcli connection show

Clearly i am missing something.
Am i suppose to modify the vpn connection? which for me is tun0.

Not really, that is just a temporary name for an active interface.

Yep, the persistent VPN connection profile:

nmcli connection show | grep -e vpn

Assuming that your VPN connection is configured and managed by NetworkManager:

sudo dnf install NetworkManager-openconnect-gnome

Ok i was using the vpn with the cli client of openconnect, so i didn’t had a persistent vpn config.
I created one profile for the vpn on network manager, and did the same processe of changing the connection profile, but it still seems to not resolve dns

Establish the VPN connection and post your configuration redacting the private parts:

PAGER= nmcli connection show id VPN_CON
resolvectl dns; resolvectl domain

I’ve done once again all the steps and for some reason now dns now works, don’t know why.
Thanks for the help.

2 Likes

Remember to re-establish the connection to apply changes.

2 Likes

For network manager, to get split-DSN, had to set (at least in the past)

$ cat /etc/NetworkManager/conf.d/local.conf
[main]
dns=dnsmasq

Split-DNS is supported by systemd-resolved, which is enabled by default in Fedora 33: