Double click using tapping on the touch pad not working

Hi everyone,

I hope you are all doing well!

I just installed Fedora as a VM in gnone-boxes. Inside the VM, the touch pad double click by tapping is not working, single click works fine.

Any thoughts?

Thanks,
Mallikarjun

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Hi @ilikelinux

Please find the output below.

07:49:17 ~ > inxi -Fzx
System:
  Kernel: 5.19.6-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-35.fc36 Desktop: GNOME v: 42.4
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Kvm System: QEMU product: Standard PC (Q35 + ICH9, 2009)
    v: pc-q35-6.2 serial: <superuser required>
  Mobo: N/A model: N/A serial: N/A BIOS: SeaBIOS v: 1.16.0-1.fc36
    date: 04/01/2014
CPU:
  Info: dual core model: Intel Core i5-3210M bits: 64 type: MT MCP
    arch: Ivy Bridge rev: 9 cache: L1: 256 KiB L2: 8 MiB L3: 16 MiB
  Speed (MHz): avg: 2494 min/max: N/A cores: 1: 2494 2: 2494 3: 2494
    4: 2494 bogomips: 19954
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Red Hat Virtio GPU driver: virtio-pci v: 1 bus-ID: 00:01.0
  Display: wayland server: X.Org v: 1.22.1.3 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: gpu: virtio_gpu resolution: 1366x768~75Hz
  OpenGL: renderer: llvmpipe (LLVM 14.0.0 256 bits) v: 4.5 Mesa 22.1.7
    direct render: Yes
Audio:
  Device-1: Intel 82801I HD Audio vendor: Red Hat QEMU Virtual Machine
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.19.6-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Red Hat Virtio network driver: virtio-pci v: 1 port: N/A
    bus-ID: 01:00.0
  IF-ID-1: enp1s0 state: up speed: -1 duplex: unknown mac: <filter>
Drives:
  Local Storage: total: 200 GiB used: 5.84 GiB (2.9%)
  ID-1: /dev/vda model: N/A size: 200 GiB
Partition:
  ID-1: / size: 199 GiB used: 5.63 GiB (2.8%) fs: btrfs dev: /dev/vda2
  ID-2: /boot size: 973.4 MiB used: 220.4 MiB (22.6%) fs: ext4
    dev: /dev/vda1
  ID-3: /home size: 199 GiB used: 5.63 GiB (2.8%) fs: btrfs dev: /dev/vda2
Swap:
  ID-1: swap-1 type: zram size: 5.3 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  Message: No sensor data found. Is lm-sensors configured?
Info:
  Processes: 674 Uptime: 23m Memory: 5.3 GiB used: 2.42 GiB (45.7%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: N/A
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

Please let me know if you need any other info.

Thanks,
Mallikarjun

I would like to provide more info:

Double click works but double tap with touchpad is not working.

Hi everyone,

Any inputs for this issue?

Please check that tap to click is on in gnome settings.

Please provide output of:
sudo /usr/bin/libinput list-devices

Thanks

1 Like

Hi,

As it is a VM, I’m not seeing the complete touchpad settings, as shown in the below snapshot.

I’ve executed the command below,

22:58:31 ~ > sudo /usr/bin/libinput list-devices
[sudo] password for msp: 
Device:           Power Button
Kernel:           /dev/input/event0
Group:            1
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           QEMU QEMU USB Tablet
Kernel:           /dev/input/event4
Group:            2
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      identity matrix
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           AT Translated Set 2 keyboard
Kernel:           /dev/input/event1
Group:            3
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           VirtualPS/2 VMware VMMouse
Kernel:           /dev/input/event3
Group:            4
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a

Device:           VirtualPS/2 VMware VMMouse
Kernel:           /dev/input/event2
Group:            4
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      identity matrix
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           spice vdagent tablet
Kernel:           /dev/input/event6
Group:            5
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      identity matrix
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   n/a
Rotation:         n/a


23:00:04 ~ > 

Hi everyone,

Please provide any suggestions.

Thanks,
Mallikarjun

You can try, USB emulation — QEMU 7.1.50 documentation

Thanks

Actually, there is no problem if I use an external mouse connected to USB port. I’m trying to work with touchpad and was not understanding why double-click by tapping on touchpad was not working. Single click by tapping on touchapd, however, is working fine.

IIRC, touchpad cannot be used with all its functionality in a VM

1 Like

Oh okay!

This issue is only for a Fedora VM. The touchpad with all functionality works fine in a Windows VM.

So, no possible solutions for a Fedora VM?

I never found any solution for any Linux VM :frowning:

Okay Thanks @lorebett

If anyone knows a solution for this case, please let me know.

Thanks,
Mallikarjun

Hey,

I just found out that double click by tapping on touchpad works fine in a Linux Mint VM, but it’s not working in Fedora VM.
Can someone please help me to find out what’s missing in the Fedora VM to get it working.

Thanks,
Mallikarjun

It might depend on guest addictions which are automatically installed by some distributions?

Try installing gnome tweaks via sudo dnf install gnome-tweaks and open


Maybe you can adjust it from here ?

Hey,

Thanks a lot for your reply. I have installed the gnome-tweaks, and it shows the touchpad enabled. But still, double-click by tapping on touchpad isn’t working.

Hey,

Thanks for your reply.

Can you please help me find which are those missing packages that need to be installed in Fedora to get the full functionalities of touchpad…

The virtual box guest additions. But I don’t know if they’re of any use for the touchpad