Driver Mess-up after Upgrade to Fedora 31

I upgraded my Fedora installation from Fedora 30 to 31 yesterday, but then I noticed that steam (as well as Lutris games) wouldn’t start any longer due to missing proprietary 32 bit nvidia driver libraries. So I installed them and Steam starts, but every game fails to start. I believe that something went wrong during upgrading and there somehow is a mess regarding the drivers on my system, as all games report

libGL error: No matching fbConfigs or visuals found 
libGL error: failed to load driver: swrast

I’d like to post some terminal output showing my current driver situation, but I don’t know which command I should use. The graphics card is a Nvidia GTX 1060.

Hi @iridium welcome to the forum.

https://rpmfusion.org/Howto/NVIDIA#x86_64_.2864bit.29_users

x86_64 (64bit) users

If you wish to have 3D acceleration in 32bit packages such as Wine, be sure to install the appropriate 32bit version of the xorg-x11-drv-nvidia-libs package for your driver variant. For example, if you installed kmod-nvidia then you will require xorg-x11-drv-nvidia-libs.i686. With Current Fedora (not EL), this is handled automatically by RPM (Boolean dependencies).

It says that is handled automatically, maybe you can try delete this package and uninstall the nvidia driver to do a clean installation of the driver again.

Maybe a clean “reinstall” can help you with this issue.

Regards.

1 Like

Thanks for the answer!
Which packages shall I uninstall? xorg-x11-drv-nvidia-libs as well as xorg-x11-drv-nvidia-libs.i686 and akmod-nividia?

According rpmfusion site the command below should do the whole work also this command will delete those libraries than you did install manually

https://rpmfusion.org/Howto/NVIDIA#Uninstall_the_NVIDIA_driver

sudo dnf remove xorg-x11-drv-nvidia\*

Edit 1: after you did remove it, if you have rpm fusion nvidia repo enable should be enough with do it:

sudo dnf install akmod-nvidia && sudo dnf --refresh update

Note: If it doesn’t work try before the reinstall clean all binaries and old libraries files according this

https://rpmfusion.org/Howto/NVIDIA?highlight=(CategoryHowto)#Recover_from_NVIDIA_installer

Please take your time first to read this 2 sites if you already didn’t which should be really helpful and will avoid problems.

https://rpmfusion.org/Howto/NVIDIA

Regards.

I read it all and tried to do the full uninstall & reinstall, even rebooted several times, but it’s still as before. Is it normal that Fedora works normally even when I uninstalled all graphic card drivers and rebooted?

Regards

Yes because it can be using the free driver of the GPU or the driver of the una hybrid CPU called usually APU what is the case of majority the intel’s CPU

Chek this link maybe the solution to one of the errors is here

I will be off until tomorrow if it doesn’t solve your problem we can continue investigating tomorrow or maybe another user come with more tips.

Another option is reinstalling steam and cleaning first the cache of your user and the steam too.

Like always do a backup of files

Regards

Unfortunately, this did not work and even though akmod-nvidia is installed, no driver is present any more as the system fell back to a resolution of 1024x768 whereas it used 1920x1080 before.
I use an AMD Ryzen 5 2600 processor which does not have an internal GPU.
I feel like akmod-nvidia is not building any driver for my system.

Post output please of

lsmod | grep -i nvidia

lsmod | grep -i nouveau

lspci -vnn | grep -i 'VGA compatible controller' -A 12

cat /proc/cmdline

ls /etc/modprobe.d/

What did you change ? because you did reinstall it out of problems like you did comment before right?

The output of
lsmod | grep -i nvidia
is
nvidia_drm 57344 0
nvidia_modeset 1118208 1 nvidia_drm
nvidia_uvm 1081344 0
nvidia 19984384 2 nvidia_uvm,nvidia_modeset
drm_kms_helper 212992 1 nvidia_drm
drm 512000 3 drm_kms_helper,nvidia_drm
ipmi_msghandler 73728 2 ipmi_devintf,nvidia
The output of
lsmod | grep -i nouveau
is empty.
The output of
lspci -vnn | grep -i 'VGA compatible controller' -A 12
shows
1c:00.0 VGA compatible controller [0300]: NVIDIA Corporation
GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) (prog-if 00
[VGA controller])
Subsystem: NVIDIA Corporation GP106 [GeForce GTX 1060
6GB] [10de:1c03]
Flags: bus master, fast devsel, latency 0, IRQ 76
Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia
1c:00.1 Audio device [0403]: NVIDIA Corporation GP106 High
Definition Audio Controller [10de:10f1] (rev a1)

cat /proc/cmdline

shows
BOOT_IMAGE=(hd2,gpt4)/vmlinuz-5.3.16-300.fc31.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=UUID=6ff75312-ef2b-4a55-a6b7-58e1a0e2f79f rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet

The last command shows
firewalld-sysctls.conf lockd.conf nvdimm-security.conf

I did uninstall everything according to the rpm fusion howto and even followed the “How to recover from Nvidia Installer section”, rebootet and ran
sudo dnf install akmod-nvidia
waited for a few minutes and rebooted, but the still, everything would fail with the libGL error. Sometime later I did an update of my system, where I noticed after shutting down and starting my computer again today, that the resolution fell back to 1024x768.

It feels a bit strange (maybe not) because:

  1. You did reinstall it before like the you commented and issue was not present but lets think than it can happen of course

  2. One install from rpmfusion, should show in the boots args these parameters (others users with Nvidia have them I have not nvidia so I can not confirm it ):

rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
  • it can maybe be caused if you do remove some package related with nouveau maybe xorg-x11-drv-nouveau or other stuff manually… not sure):*.

You also can look into /etc/X11/xorg.conf.saved and your actual /etc/X11/xorg.conf for differences and put back the saved filed in case and test it.

if roll back your backup of xorg.conf didn’t show luck you can look for the next options;

Maybe you do have a low resolution in the boot process if you have not loaded the nvidia-drm.modeset=1 in the boot parameters or don’t exit one nvidia.conf file into the /etc/modprobe.d/ to do use of this option with the syntax options nvidia-drm modeset=1 like you can see the syntax is different from the boot parameter.

Possibly adding simply nvidia-drm.modeset=1 to the boots parameters should do the trick with your resolution problem in the shutting down and starting process.

check it https://rpmfusion.org/Howto/NVIDIA#KMS

If the parameter does the trick you can do the change permanent if you don’t know how just ask again.

  • If nothing looks work, do a clean install of fedora and follow all steps that you did read/learn from rpmfusion and fedora magazine.

Regards.

Thank you very much. Interestingly, I don’t have a xorg.conf file, so I cannot compare anything.
I added the kernel boot parameters and was succesful in restoring the FullHD resolution, but the cursor is behaving very strangely and is basically unusable, as it is like dragging it through gel and also it sometimes moves by itself. Additionally, the libGL error still persists.

Hi @iridium

Check that you are not running in wayland session ( i have amd GPU) because nvidia privative driver is not going to work property, to check it you can do it.

https://docs.fedoraproject.org/en-US/fedora/rawhide/system-administrators-guide/Wayland/

In my case I am running wayland session so the commands refereed in the link above show that i am using wayland, in your case the first command would show nothing and the last command your session should be type=X11

[jorge@f31 ~]$ echo $WAYLAND_DISPLAY
wayland-0
[jorge@f31 ~]$ loginctl
SESSION  UID USER  SEAT  TTY 
      2 1000 jorge seat0 tty2

1 sessions listed.
[jorge@f31 ~]$ loginctl show-session 2 -p Type
Type=wayland

If you are running wayland you can change to x11 in the moment you do the login through the button with form of gear and choose Gnome X11.

If you are running in X11 you can change your monitor settings and create a xorg.conf trough the app that was installed in your desktop refereed to nvidia where you will can change resolution and different parameters so how save one xorg with them in the option save. You can check for documentation and videos in google about how this app does work if you don’t know

Regards

One thing more check it about your xorg conf in the rpmfusion that we do talk so ofta https://rpmfusion.org/Howto/NVIDIA#nvidia-xconfig

Begin with it.

And if nothing work like said before do a clean install because i can not imagine why you do have one thing and others no if you did delete things go to you dnf.log and roll back them. But if it take too much time try with fresh install

Regards

Thanks for your great support, I appreciate it. I just finished creating a new Fedora 31 installation on another partition and copying my home partition. The resolution is fine, and I can access
nvidia-settings
so I guess everything is fine now.

1 Like

Better decision that you could have taken.