Dual boot with Archlinux

Hi everyone, about 2 weeks ago, i decided to give Fedora a try after using archlinux for almost 2 years now. So i repartitioned my SSD to arch/debian and both share the same /home partition (both are installed on a UEFI system).
However for whatever reason, Fedora seems to be really submissive and it keeps being bullied by Arch; since i cannot change anything about GRUB’s configuration from fedora, however i found that using grub-customizer and editing arch’s grub config works. Nonetheless, i can’t seem to be able to set some required kernel parameters for CoreCtrl.

Any kind of feedback is greatly appriciated.

Be careful using Fedora’s grub to dual-boot an Arch-based distro. Fedora’s grub/os-prober won’t properly detect the fact that Arch uses multiple initrd lines. If you want to use grub to dual-boot, I would disable os-prober and manage the entries manually.

If you want a fully automated multi-boot setup, I would switch to refind or systemd-boot when combining Arch & Fedora. That being said, grub can and does work if you are willing to work through some issues as you are already discovering.

It probably isn’t that Fedora’s grub is being bullied by Arch. It is more likely that the BLS changes introduced a few versions ago are making things not work like you expect.

Fedora uses kernel-install which makes things like grub customizer not fully work. It also means that changes to GRUB_CMDLINE_LINUX often won’t be picked up.

There are a few options to overcome this:

  • You can add the kernel options you want to your running system then call kernel-install manually or re-install your kernels. It should pickup the kernel options from the running system.
  • You can create and modify /etc/kernel/cmdline
  • You can add a script to kernel-install so it calls grub-mkconfig as described here.

Alternatively, it could be that you have Arch’s grub set as the default in your BIOS. Keep in mind that settings aren’t shared between the two grubs so when you change one it doesn’t automatically change the other.

5 Likes

Woah, thanks a ton for the very detailed reply, that’s a lot to learn!
The last option did the trick, i had no idea that the UEFI boot order could matter, i thought that since the ESP is shared, both fedora and arch would be on the same page.

1 Like

Quick update: i’ve selected Fedora’s grub in the BIOS as i mentioned earlier, but now i can’t change GRUB’s theme (grub-customizer).
Nevermind! i just had to comment out GRUB_TERMINAL_OUTPUT.

1 Like