Dual Monitor Stops Working After Fedora Sleeps/Suspends Fedora 35

Hello!

I am brand new to Fedora and just installed Fedora 35 on its own SSD in my MSI GS65 Stealth.

The issue:

  • Whenever the computer sleeps/suspends and I turn it back on it seems the NVIDIA Driver (I have an NVIDIA 2060) stops working? I have a second display and it just totally goes black even when I reboot the computer.
  • Also, the WIFI stops working and it shows no WIFI card is even in the system. This is fixed when I reboot unlike the graphics issue.
  • Two errors pop up in Problem Reporting tab. Both say kernel-core unexpected system error. “A kernel problem occured, but your kernel has been tainted (Flags:GW)”

I’d love to use Fedora, but this is so annoying and I can’t find anything online that actually works to fix this. Thank you!

Hello @dandex200 ,
Welcome to the :fedora: discussion area!. For the WiFi, check out this https://ask.fedoraproject.org/t/how-to-keep-internet-connection-connected-without-interruption/15767/4. It is likely related to the power profile and I believe the solution I linked will rectify your connection issues. The NVidia/Dual monitor issue, I really cannot help out with since I run an AMD GPU.

1 Like

I have seen this with the nvidia dual gpu design. It seems to be related to using the default driver for the IGP and the nvidia driver for the GPU.

What I have done that totally solved that issue is set the nvidia GPU as primary so it can drive both devices.

  1. copy /usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf
  2. Add a single line to both stanzas in that file that will make the nvidia driver primary and prevent the conflict between drivers for the 2 devices.
    Option "Primary" "yes"

That line, combined with the line already in the server section that says Option "AllowNVIDIAGPUScreens"gives the nvidia driver control of both screen outputs and allows both screens to be active at the same time and driven by the nvidia GPU.

Thank you to the two replies!

After a bit of searching and finding this article about my specific laptop on Arch Linux’s Wiki, I’ve found that my laptop has weird issues that arise specifically after you suspend/sleep. Even some issues that carry on over if you boot back into Windows. I decided to just remove the suspend function from Fedora entirely and now all is working fine. I did this by:

$ sudo systemctl mask suspend.target

$ reboot