Dummy Output Problem After Update No Audio

I’ve been using the Fedora 36 version for about a month. I’m a novice in Linux,
About a week ago, probably after the system update, there is no sound from the 3.5 mm jack output to the speaker, but the usb output is giving a sound to the headphones, I tried a lot solutions on the forum and the internet, but I couldn’t find .

Welcome to ask :fedora:

In general you cannot output sound to 2 devices at once.
Are you trying both at the same time, or trying the headphone jack with the USB device disconnected?
Have you looked into the settings → sound panel to select the proper output device?

A problem seems to have arisen with wireplumber.
Since you have not provided any information that helps to solve the problem, I will query it. Please provide it. Thanks
Terminal input and output please in one codeblock. „</>"

What kind of headphones do you use? Is it connected via Bluetooth? You are talking there in front of a USB port.
Please show us the following queries;

inxi -bAE
wpctl status

You can also run this if there is a problem and before switching to another output device:

pactl load-module module-switch-on-connect

I also had problems which were easily solved by setting all output devices in pavucontrol to 80% maximum volume. These were strangely all adjusted and partly on over 100%. :face_with_spiral_eyes: I had an overload with this. But I noticed that only after I had controlled all plugs sliding on my knees. :confounded:

[murat@dhcppc10 ~]$ inxi -bAE
System:
Host: dhcppc10 Kernel: 5.19.8-200.fc36.x86_64 arch: x86_64 bits: 64
Desktop: GNOME v: 42.4 Distro: Fedora release 36 (Thirty Six)
Machine:
Type: Desktop System: Gigabyte product: A320M-S2H v: N/A
serial:
Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial:
UEFI: American Megatrends v: F42b date: 08/21/2019
CPU:
Info: quad core AMD Ryzen 3 3200G with Radeon Vega Graphics [MCP]
speed (MHz): avg: 1382 min/max: 1400/3600
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel
Display: wayland server: X.Org v: 1.22.1.3 with: Xwayland v: 22.1.3
compositor: gnome-shell driver: gpu: amdgpu resolution: 1920x1080~60Hz
OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.0 DRM 3.47
5.19.8-200.fc36.x86_64)
v: 4.6 Mesa 22.1.7
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: N/A
Device-2: AMD Family 17h/19h HD Audio driver: N/A
Sound Server-1: ALSA v: k5.19.8-200.fc36.x86_64 running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
Bluetooth:
Message: No bluetooth data found.
Drives:
Local Storage: total: 1.24 TiB used: 12.69 GiB (1.0%)
Info:
Processes: 285 Uptime: 11m Memory: 13.59 GiB used: 2 GiB (14.7%)
Shell: Bash inxi: 3.3.19
[murat@dhcppc10 ~]$

[murat@dhcppc10 ~]$ wpctl status
PipeWire ‘pipewire-0’ [0.3.57, murat@dhcppc10, cookie:3396941363]
└─ Clients:
31. uresourced [0.3.57, murat@dhcppc10, pid:1655]
32. wpctl [0.3.57, murat@dhcppc10, pid:3909]
39. xdg-desktop-portal [0.3.57, murat@dhcppc10, pid:2226]

Audio
├─ Devices:

├─ Sinks:

├─ Sink endpoints:

├─ Sources:

├─ Source endpoints:

└─ Streams:

Video
├─ Devices:

├─ Sinks:

├─ Sink endpoints:

├─ Sources:

├─ Source endpoints:

└─ Streams:

Settings
└─ Default Configured Node Names:
[murat@dhcppc10 ~]$

How can it be that you still have Pulseaudio installed?
Please show:
dnf repolist
and

dnf repoquery --deplist pulseaudio

I was just wondering how you manage to have two sound servers at all???

Please try a workaround.
Pipewire is the default application of Gnome.
If it still does not work, you can switch to Pulse.
Under no circumstances should you try to uninstall Pipewire, otherwise you will probably lose your desktop.

Please try:

sudo dnf reinstall --allowerasing pipewire

This should uninstall unnecessary dependencies of Pulse.
No root required anymore!
After that please activate Pipwire as default.

systemctl --user enable --now pipewire.socket
systemctl --user enable --now pipewire.service
systemctl --user enable --now wireplumber.service

For safety you can restart your computer to test.

Can you try booting with an additional kernel argument?
amd_iommu=off

Using grubby,
to add:
sudo grubby --args='amd_iommu=off' --update-kernel=ALL

to remove:
sudo grubby --remove-args='amd_iommu=off' --update-kernel=ALL

ref: Working with the GRUB 2 Boot Loader :: Fedora Docs

There’s a kernel bug:

2 Likes

Can you try booting with an additional kernel argument?
amd_iommu=off

Using grubby,
to add:
sudo grubby --args='amd_iommu=off' --update-kernel=ALL

to remove:
sudo grubby --remove-args='amd_iommu=off' --update-kernel=ALL

ref: Working with the GRUB 2 Boot Loader :: Fedora Docs

There’s a kernel bug:

[/quote]

Solved !!! Thank you very much everyone for helping ,this step solved my problem thank you Joe…

FYI, this looks like it may be fixed in 5.19.9 so when you get that update you’ll want to try removing the kernel arguments to see if it works.