Eclipse does not install in Fedora 31

I made a clean Fedora 31 install coming from Fedora 29. When I tried to install Eclipse I got the following error:
$sudo dnf install eclipse
Error:
Problem: package eclipse-jdt-1:4.11-3.fc31.noarch requires eclipse-platform = 1:4.11-3.fc31, but none of the providers can be installed

  • package eclipse-platform-1:4.11-3.fc31.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
  • conflicting requests
  • package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch is excluded
  • package glassfish-el-3.0.1-0.11.b08.fc31.noarch is excluded
    (try to add ‘–skip-broken’ to skip uninstallable packages)

I found a reported bug in https://bugzilla.redhat.com/show_bug.cgi?id=1759176 and to be honest I was a bit surprised that this was not mentioned in the Common Bugs section of Fedora Release Notes document.

My first question is: will this bug be fixed? After reading the bug description it is not clear to me that the bug is fixable, as contents of fedora-modular are frozen before GA…

My second question is: what can I do? Eclipse is my main working tool. I installed it from the Eclipse web but then I found that breakpoints doesn’t stop. The debugger doesn’t stop at breakpoints (I use C language and CDT plugin). I have googled this problem and applied all the recipes to fix this problem without success.

I have moved back to Fedora 29 (I still have the ISO image) so I can work for the moment, but I am afraid that Fedora 29 end of life is close. Can I download a Fedora 30 ISO image? Where?

Any help will be greatly appreciated.

2 Likes

Hi @karkon welcome to the forum.

Unfortunately this is not happening only with eclipse.

At this point some thing what can useful to you:

Eclipse in flatpak (in princip it should work out problems):

https://flathub.org/apps/details/org.eclipse.iot.fourdiac.Ide

Link to older versions:

Regards.

3 Likes

Hi @xtym, many thanks for your help, this is a very valuable information.

I will reinstall Fedora 31 this afternoon and give a try to Eclipse in flatpak. I will post the result as soon as I finish the test.

Thanks again.

1 Like

Just for Clarification the version on Flatpak is for supports the development of distributed industrial control solutions, deployed mainly to PLCs.

Not for Development in C, C++ or Java…

Regards.,

3 Likes

Thanks for the point!! @hhlp

Like @hhlp did comment check if it fix to you, if the installation trough of web did work but maybe the break point bug is related whit an actual bug https://bugs.eclipse.org/bugs/ (you should check it or report this in the eclipse web bugzilla). Maybe it is related with the java versión than you did select to install eclipse. (maybe if you try under instalation with other Java option the bug is not present).

Regards.

2 Likes

OK, as Fedora31 has more potential problems and the flatpak installation is not what I need I decided to install Fedora 30 and install the Eclipse out of the box. It worked perfectly so now I can work and I can wait until the problem is solved in Fedora 31 or a new version is available.

Thanks a lot to you both, @xtym and @hhlp, you saved my week.

2 Likes

Please read this message coming from eclipse packagers:

Dear Eclipse users,
Whoever faces issues installing Eclipse RPMs on Fedora 31 - this is beyond
us (Eclipse packagers) and depends on a number of bigger issues in Fedora
land both technical and political.
Until this is fixed, you're strongly recommended to try using Eclipse from
Flathub [1]. It should provide you with similar system level integration as
the RPMs and is maintained by the very same people who do the Fedora RPMs.
In case of issues don't hesitate to contact me or Mat Booth but ideally
open issues at [2] .

[1] https://flathub.org/apps/details/org.eclipse.Java
[2] https://github.com/flathub/org.eclipse.Java

Source: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/TTYWBAMDREHW6NVW76ZOB34WYVV3XO2I/

2 Likes

Hello pals , for the rest of the people, remember that you can download and use Eclipse-2019-06(4.12) from the official Eclipse website, this is another option that we have in addition to the fedora repository.

3 Likes

I can confirm this - my problem started from breakpoints in c++ eclipse projects not functioning following an upgrade from F30 to F31; I tried the Eclipse CDT team’s standalone c++ debugger as well, and that exhibited exactly the same problem. Error messages indicate that a lot of the Java classes around the Eclipse debug server were absent (or invisible). This is a serious problem for c/c++ developers, as the alternatives such as VScode and Anjuta from Gnome just aren’t in the same class. I do hope that this problem is taken seriously and am happy to help in any way I can to get a solution in place.
Mike

1 Like

By the way, if I put a breakpoint in the source code of a static library called by my c++ project that won’t see breakpoints, it does break in the library function… Maybe this will help nail down the technical aspects of the problem, but will probably not help with the political aspects :frowning:(
Mike

1 Like

you can install it enabling the eclipse latest module, somehow the maven module have glassfish. type in your prompt "sudo dnf module enable eclipse:latest "

Thanks, evilgamer; I tried your recommendation, but the problem persisted, no breakpoints could be activated except that set by the debugger for main(). Since I was using this version of Eclipse, installed only for myself (my username on the system) -

"Eclipse IDE for C/C++ Developers

Version: 2019-09 R (4.13.0)
Build id: 20190917-1200"

  • I thought I’d try to install the Fedora Eclipse group (sudo dnf group install “Fedora Eclipse”) and see if that worked. What I got was the standalone C/C++ debugger; running it on my C++ project still failed to stop at breakpoints…

Not sure where we go from here…

thanks its very helpful

If you need Fedora 30, you can download from here https://dl.fedoraproject.org/pub/fedora/linux/releases/30/Workstation/x86_64/iso/

1 Like