Eclipse failes to start (fresh install)

I installed eclipse via
sudo dnf install eclipse
Eclispe failed to start and prompt location of log file: LOGFILE LINK

[galeon@localhost ~]$ alternatives --display java
java — stan: automatycznie.
 dowiązanie obecnie wskazuje na /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/java
/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/java - rodzina java-11-openjdk.x86_64 priorytet 11000911
 podrzędne jjs: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/jjs
 podrzędne keytool: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/keytool
 podrzędne pack200: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/pack200
 podrzędne rmid: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/rmid
 podrzędne rmiregistry: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/rmiregistry
 podrzędne unpack200: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/unpack200
 podrzędne jre: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64
 podrzędne java.1.gz: /usr/share/man/man1/java-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne jjs.1.gz: /usr/share/man/man1/jjs-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne keytool.1.gz: /usr/share/man/man1/keytool-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne pack200.1.gz: /usr/share/man/man1/pack200-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne rmid.1.gz: /usr/share/man/man1/rmid-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne rmiregistry.1.gz: /usr/share/man/man1/rmiregistry-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne unpack200.1.gz: /usr/share/man/man1/unpack200-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
Obecnie „najlepszą” wersją jest /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/java.
1 Like

Post the log file and check this:

alternatives --display java
[galeon@localhost ~]$ alternatives --display java
java — stan: automatycznie.
 dowiązanie obecnie wskazuje na /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/java
/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/java - rodzina java-11-openjdk.x86_64 priorytet 11000911
 podrzędne jjs: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/jjs
 podrzędne keytool: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/keytool
 podrzędne pack200: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/pack200
 podrzędne rmid: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/rmid
 podrzędne rmiregistry: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/rmiregistry
 podrzędne unpack200: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/unpack200
 podrzędne jre: /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64
 podrzędne java.1.gz: /usr/share/man/man1/java-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne jjs.1.gz: /usr/share/man/man1/jjs-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne keytool.1.gz: /usr/share/man/man1/keytool-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne pack200.1.gz: /usr/share/man/man1/pack200-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne rmid.1.gz: /usr/share/man/man1/rmid-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne rmiregistry.1.gz: /usr/share/man/man1/rmiregistry-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
 podrzędne unpack200.1.gz: /usr/share/man/man1/unpack200-java-11-openjdk-11.0.9.11-0.fc33.x86_64.1.gz
Obecnie „najlepszą” wersją jest /usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/java.
1 Like

Logifile:
LOGFILE

EDIT: Fixed acces permissions

1 Like
1 Like

Similar issues:

Possible solution:

sudo dnf install java-1.8.0-openjdk

And switch the defaults like this: Java can't find library

Thx for interest :slight_smile:

It seems this do not help. I set up java to 1.8.0. Seems not help. Enclosing new logfile.

[galeon@localhost ~]$ java -version
openjdk version "1.8.0_272"
OpenJDK Runtime Environment (build 1.8.0_272-b10)
OpenJDK 64-Bit Server VM (build 25.272-b10, mixed mode)

[galeon@localhost ~]$ alternatives --list | grep java
jre_1.8.0             	auto  	/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.272.b10-0.fc33.x86_64/jre
javac                 	auto  	/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64/bin/javac
java_sdk_11_openjdk   	auto  	/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64
java                  	manual	/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.272.b10-0.fc33.x86_64/jre/bin/java
jre_11                	auto  	/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64
java_sdk_11           	auto  	/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64
jre_openjdk           	auto  	/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64
java_sdk_openjdk      	auto  	/usr/lib/jvm/java-11-openjdk-11.0.9.11-0.fc33.x86_64

LogFile 2

1 Like

Hello, galeon.

Was it a fresh install of Fedora 33 or only Eclipse? I upgraded from Fedora 32 to 33 seamless and Eclipse works in my computer with no issues, so your problem must be another thing.

Java 8 isn’t needed by Libreoffce Calc or Eclipse Platform any more. They were upgraded to use Java 11 instead. So please, uninstall Java 8 unless you need Open JFX, which still depends on Java 8. That’s for sure.

If it was an upgrade of Eclipse only, perhaps there is an old plugin which is causing the issue. I used to reset everything whenever I had an issue like yours.

  1. Delete hidden Eclipse folder in your $HOME.
    $ rm -rf .eclipse
  2. Delete hidden metatada folder in your all your projects. Look out not to delete your source code folders! You will be able to recreate your project afterwards.
    $ rm -rf $YOUR_PROJECT_DIR/.metadata
    $ rm -rf $YOUR_PROJECT_DIR/.project
    $ rm -rf $YOUR_PROJECT_DIR/.classpath
  3. Reinstall.
    # dnf remove ‘eclipse*’ ‘java-1.8.0-openjdk*’
    # dnf install eclipse-platform java-11-openjdk* --exclude=’*slowdebug*’

Finally, I once had issues with a custom GNOME theme that I downloaded from https://www.gnome-look.org. Eclipse didn’t start because of some kind of weird incompatibility. I found out that it was solved if I restored default GNOME theme.

Please try and tell us.

Regards.

1 Like

Now I tried to install eclipse in VM (gnome boxes, fedora 33) and had no issues.


Tried 1-3, reinstall didn’t help.

Was it a fresh install of Fedora 33 or only Eclipse?

Both, reinstalled fedora few days ago. I do install some software before eclipse. Maybe some of it can cause this. It was:

  • google chrome
  • nvidia drivers and cuda (see rpm fusion guide)
  • visual studio code (but no java plugin)
  • geany
    I think that’s it, but i may forget sth,

Finally, I once had issues with a custom GNOME theme

I’m using default theme.

I run Eclipse in a physical machine. I use it every day with no issues. I skimmed the log but, honestly, I don’t understand a line. If it works in your VM, then it should work in your physical computer, as well. Why don’t you try to reinstall F33, upgrade and install eclipse-platform as the first package after the upgrade? Don’t install anything else before. Not even Java 11. Let it install its dependencies itself. If the issue still happens, then you’d rather fill a bug at https://bugzilla.redhat.com/

Regards.

1 Like

Yep, I’ve tested it the same way and it works for me too.
Perhaps you should check it from a new user with default profile.

1 Like

I’ve tested various scenarios in VM’s and I localized when it broke. It’s due to something that NVidia repo provide when you install CUDA.

What I’ve done to reproduce error:

  1. Fresh fedora 33 install
  2. Update to newest version (as 7 Nov 2020)
    sudo dnf update -y
  3. Install NVidia drivars from rpmfusion (NVidia)
    sudo dnf install akmod-nvidia
    sudo dnf install xorg-x11-drv-nvidia-cuda
    When you install eclipse at this point, it works fine
  4. Enable cuda developer repo as described in rpmfusion (CUDA)
    sudo dnf config-manager --add-repo https://developer.download.nvidia.com/compute/cuda/repos/fedora32/x86_64/cuda-fedora32.repo
    sudo dnf clean all
    sudo dnf module disable nvidia-driver
    When you try install eclipse now it install some componenst from cuda-fedora repo:

    This brokes eclipse form some reason
    (Yoo do not see this when you install: sudo dnf install -y cuda first, as those 3 libraries are installed with it and you dont see them in eclipse instalation)

Now, I managed to fix it by uninstalling cuda, java and eclipse and then install it with right order and with disabling cuda-fedora32 repo.

  1. Remove cuda, eclipse and java
    rm -rf ~/.eclipse
    sudo dnf remove cuda java eclipse
  2. Install eclipse disabling cuda repo (and run to check if run)
    sudo dnf install eclipse --disablerepo=cuda-fedora32-x86_64
    eclipse
  3. Install cuda
    sudo dnf install cuda
    Now eclipse and cuda work for me. :slight_smile:

1 Like

You don’t need that repository in order to have the NVIDIA proprietary driver. Besides, you’d better remove it to avoid conflicts later. I enabled that repo, tried to upgrade and… well… see it by yourself :smiley:

Delete cuda-fedora32.repo file at /etc/yum.repos.d, just add rpmfusion repository and:

# dnf install xorg-x11-drv-nvidia-cuda

That’s all.

Regards.

There’s a simpler method.
Just modify the repo priority right after enabling it:

sudo dnf config-manager --save --setopt=cuda-\*.priority=100

This makes DNF prefer the official Fedora repos.

2 Likes

For drivers Yes, but i need to use pycuda (needed by gprMax) for now and it does not work without whole cudatoolkit including nvcc compiler. Sadly, they are not provided by rpmfusion.