emergency mode after bios update

Lenovo Yoga 730-13IKB recently upgrade BIOS to 7LCN3022(V1.11) 7LEC30WW(V1.11)

Neither Grub nor the Windows 10 can find the partitions. I can boot to USB Live CD, but it can’t find anything but the USB. All auto repairs from Windows boot, fail.

None of the Emergency Mode correction commands are available after dropping in Emergency Mode when Fedora 31 fails to load.

I have a Lenovo USB which is supposed to restore to factory defaults, but that will wipe the drive if it works.

Marv

Since you did a bios update - did you reset the bios to factory defaults after the update? That is usually recommended.
Also, please check if the configuration to legacy BIOS/UEFI is set to whatever your system needs. If you have a legacy booting table but have the system set to UEFI this might not work.

Reset to defaults didn’t help. One message in Fedora Emergency Mode is a recommendation to “regenerate initramfs.” Booting in Fedora Rescue mode results in the same behavior,

Did you make sure that the bios configuration is set to UEFI OR legacy, depending on what you need? That is crucial!

And: did you change the disks by any chance? Did you move from HD to SSD or similar?

And can you please provide the error message which appears when you are dropped to the emergency mode shell?

The messages were, check the error report and you may need to regenerate initramfs.

In the meantime, I back tracked to the steps I used to install Fedora. I followed the steps of a successful installation of Fedora on a Yoga 910.

I think this is the problem area:
in Windows 10, as Administrator mode I ran “bcdedit /set {current} safe boot minimal”
and then restarted UEFI from the boot menu
which changed from RST to ACHI

I believe that’s what the BIOS upgrade did; ie reset to RST mode
that effectively disabled both Windows and and Fedora boots. I reset BIOS to boot Fedora first to get to the Grub menu, which allowed me to try Fedora and Fedora Rescue modes.

I found several posts elsewhere about problems with dual boot after bios upgrades, so this is another - use caution about updating BIOS in Windows!

I gave up and reinstalled Windows.

Thanks for your efforts.

@marvw So you changed the SATA mode? That explains a lot :sweat_smile: If you change the SATA mode you of course have to change the initramfs - you need an entirely different set of modules (“drivers”) now.

I am sorry that in the end you just re-installed Windows. If I would have known about the SATA mode change earlier I would have been able to help you.

So to put a bow on the topic, what would have been the alternative to changing RST to ACHI?
Thank you!

You can change - but with such changes the best is to let the OS know in advance:Before you change it in the BIOS, rebuilt the intiramfs with the right module, then reboot into BIOS, change to ACHI, save BIOS and normally boot into Linux.